summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2011-12-04 19:27:46 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2011-12-04 19:27:46 +0000
commit178affd6ebc4d2921ff134fac3bbf566a1ba0689 (patch)
tree0e1c0b892ae4808b4944cdb810cb2304c61887d8 /net-analyzer
parentdrop old glibc pie checking as this has worked since at least version 2.4 (diff)
downloadgentoo-2-178affd6ebc4d2921ff134fac3bbf566a1ba0689.tar.gz
gentoo-2-178affd6ebc4d2921ff134fac3bbf566a1ba0689.tar.bz2
gentoo-2-178affd6ebc4d2921ff134fac3bbf566a1ba0689.zip
updated metadata.xml
removed 1.5.1-r3 updated initscripts (fixing ido2db to the new icinga var path) (Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga/ChangeLog9
-rwxr-xr-xnet-analyzer/icinga/files/icinga-init.d-24
-rw-r--r--net-analyzer/icinga/files/ido2db-init.d15
-rw-r--r--net-analyzer/icinga/icinga-1.5.1-r3.ebuild225
-rw-r--r--net-analyzer/icinga/icinga-1.6.1-r1.ebuild (renamed from net-analyzer/icinga/icinga-1.6.1.ebuild)2
-rw-r--r--net-analyzer/icinga/metadata.xml1
6 files changed, 19 insertions, 237 deletions
diff --git a/net-analyzer/icinga/ChangeLog b/net-analyzer/icinga/ChangeLog
index e2b22e045445..92a246ce6a2b 100644
--- a/net-analyzer/icinga/ChangeLog
+++ b/net-analyzer/icinga/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/icinga
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.7 2011/12/03 07:26:17 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.8 2011/12/04 19:27:45 prometheanfire Exp $
+
+*icinga-1.6.1-r1 (04 Dec 2011)
+
+ 04 Dec 2011; mthode <mthode@gentoo.org> -icinga-1.6.1.ebuild,
+ +icinga-1.6.1-r1.ebuild, files/icinga-init.d-2, files/ido2db-init.d:
+ fixed error in old ido2db-init and updated icinga-init to be in line with new
+ openrc
03 Dec 2011; mthode <mthode@gentoo.org> -icinga-1.5.1.ebuild,
-icinga-1.5.1-r1.ebuild:
diff --git a/net-analyzer/icinga/files/icinga-init.d-2 b/net-analyzer/icinga/files/icinga-init.d-2
index 062a33aadb7d..8f05cc7dcdce 100755
--- a/net-analyzer/icinga/files/icinga-init.d-2
+++ b/net-analyzer/icinga/files/icinga-init.d-2
@@ -1,11 +1,11 @@
#!/sbin/runscript
-opts="${opts} reload checkconfig"
+extra_commands="${extra_commands} reload checkconfig"
depend() {
need net
use dns logger firewall
- after mysql postgresql
+ after mysql postgresql ido2db
}
reload()
diff --git a/net-analyzer/icinga/files/ido2db-init.d b/net-analyzer/icinga/files/ido2db-init.d
index 75051abbf934..302a24881959 100644
--- a/net-analyzer/icinga/files/ido2db-init.d
+++ b/net-analyzer/icinga/files/ido2db-init.d
@@ -1,17 +1,18 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/ido2db-init.d,v 1.1 2011/11/15 00:14:29 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/ido2db-init.d,v 1.2 2011/12/04 19:27:46 prometheanfire Exp $
IDO2DBBIN="/usr/sbin/ido2db"
-SOCKET="/var/icinga/ido.sock"
+IDO2DBSOCKET="/var/lib/icinga/ido.sock"
+IDO2DBLOCK="/var/lib/icinga/ido2db.lock"
function check() {
- if [ -S "${SOCKET}" ] ; then
- ewarn "Strange, the socket file already exist in \"${SOCKET}\""
+ if [ -S "${IDO2DBSOCKET}" ] ; then
+ ewarn "Strange, the socket file already exist in \"${IDO2DBSOCKET}\""
ewarn "it will be removed now and re-created by ido2db"
ewarn "BUT please make your checks."
- rm -f "${SOCKET}"
+ rm -f "${IDO2DBSOCKET}"
fi
}
@@ -24,12 +25,12 @@ depend() {
start() {
check
ebegin "Starting ido2db"
- start-stop-daemon --quiet --start --pidfile /var/icinga/ido2db.lock --startas ${IDO2DBBIN} -- -c ${IDO2DBCFG}
+ start-stop-daemon --start --exec ${IDO2DBBIN} --pidfile ${IDO2DBLOCK} --name ${IDO2DBBIN} -- -c ${IDO2DBCFG}
eend $?
}
stop() {
ebegin "Stopping ido2db"
- start-stop-daemon --quiet --stop --pidfile /var/icinga/ido2db.lock --name /usr/sbin/ido2db
+ start-stop-daemon --stop --exec ${IDO2DBBIN} --pidfile ${IDO2DBLOCK} --name ${IDO2DBBIN}
eend $?
}
diff --git a/net-analyzer/icinga/icinga-1.5.1-r3.ebuild b/net-analyzer/icinga/icinga-1.5.1-r3.ebuild
deleted file mode 100644
index 91c54b41022a..000000000000
--- a/net-analyzer/icinga/icinga-1.5.1-r3.ebuild
+++ /dev/null
@@ -1,225 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.5.1-r3.ebuild,v 1.2 2011/11/22 21:06:50 prometheanfire Exp $
-
-EAPI=2
-
-inherit depend.apache eutils multilib toolchain-funcs
-
-DESCRIPTION="Nagios Fork - Check daemon, CGIs, docs, IDOutils"
-HOMEPAGE="http://www.icinga.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+apache2 api debug +idoutils lighttpd +mysql perl plugins postgres ssl +vim-syntax +web"
-DEPEND="idoutils? ( dev-db/libdbi-drivers[mysql?,postgres?] )
- perl? ( dev-lang/perl )
- virtual/mailx
- web? (
- media-libs/gd[jpeg,png]
- lighttpd? ( www-servers/lighttpd dev-lang/php[cgi] )
- apache2? ( || ( dev-lang/php[apache2] dev-lang/php[cgi] ) )
- )
- !net-analyzer/nagios-core"
-RDEPEND="${DEPEND}
- plugins? ( net-analyzer/nagios-plugins )"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
- enewgroup icinga
- enewgroup nagios
- enewuser icinga -1 -1 /var/spool/icinga "icinga,nagios"
- if use web ; then
- elog "This does not include cgis that are perl-dependent"
- elog "Currently traceroute.cgi is perl-dependent"
- elog "Note that the user your webserver is running as needs"
- elog "read-access to /etc/icinga."
- elog
- if use apache2 || use lighttpd ; then
- elog "There are several possible solutions to accomplish this,"
- elog "choose the one you are most comfortable with:"
- elog
- if use apache2 ; then
- elog " usermod -G icinga apache"
- elog "or"
- elog " chown icinga:apache /etc/icinga"
- elog
- elog "Also edit /etc/conf.d/apache2 and add \"-D ICINGA\""
- elif use lighttpd ; then
- elog " usermod -G icinga lighttpd "
- elog "or"
- elog " chown icinga:lighttpd /etc/icinga"
- elog "Also edit /etc/lighttpd/lighttpd.conf and add 'include \"lighttpd_icinga.conf\"'"
- fi
- elog
- elog "That will make icinga's web front end visable via"
- elog "http://localhost/icinga/"
- elog
- else
- elog "IMPORTANT: Do not forget to add the user your webserver"
- elog "is running as to the icinga group!"
- fi
-
- else
- ewarn "Please note that you have installed Icinga without web interface."
- ewarn "Please don't file any bugs about having no web interface when you do this."
- ewarn "Thank you!"
- fi
-
-}
-
-src_prepare() {
- epatch "${FILESDIR}/fix-prestripped-binaries.patch"
-}
-
-src_configure() {
- local myconf
- local myconf2
-
- myconf="$(use_enable perl embedded-perl)
- $(use_with perl perlcache)
- $(use_enable idoutils)
- $(use_enable ssl)
- $(use_enable debug DEBUG0)
- $(use_enable debug DEBUG1)
- $(use_enable debug DEBUG2)
- $(use_enable debug DEBUG3)
- $(use_enable debug DEBUG4)
- $(use_enable debug DEBUG5)
- --disable-statuswrl
- --with-cgiurl=/icinga/cgi-bin
- --with-log-dir=/var/log/icinga"
-
- myconf2="--bindir=/usr/sbin
- --sbindir=/usr/$(get_libdir)/icinga/cgi-bin
- --datarootdir=/usr/share/icinga/htdocs
- --localstatedir=/var/lib/icinga
- --sysconfdir=/etc/icinga"
-
- if use plugins ; then
- myconf2+=" --libexecdir=/usr/$(get_libdir)/nagios/plugins"
- else
- myconf2+=" --libexecdir=/usr/$(get_libdir)/icinga/plugins"
- fi
-
- if use !apache2 && use !lighttpd ; then
- myconf2+=" --with-command-group=icinga"
- else
- if use apache2 ; then
- myconf+=" --with-httpd-conf=/etc/apache2/conf.d"
- myconf2+=" --with-command-group=apache"
- elif use lighttpd ; then
- myconf2+=" --with-command-group=lighttpd"
- fi
- fi
-
- econf ${myconf} ${myconf2}
- if use api ; then
- cd module/icinga-api || die
- econf ${myconf2}
- fi
-}
-
-src_compile() {
- tc-export CC
-
- emake icinga || die "make failed"
-
- if use web ; then
- emake DESTDIR="${D}" cgis || die
- fi
-
- if use idoutils ; then
- emake DESTDIR="${D}" idoutils || die
- fi
-}
-
-src_install() {
- dodoc Changelog README UPGRADING || die
-
- if ! use web ; then
- sed -i -e '/cd $(SRC_\(CGI\|HTM\))/d' Makefile || die
- fi
-
- sed -i -e 's/^contactgroups$//g' Makefile || die
-
- emake DESTDIR="${D}" install{,-config,-commandmode} || die
-
- sed -i -e 's/var\/lib\/icinga\/icinga.lock/var\/run\/icinga\/icinga.lock/g' "${D}"/etc/icinga/icinga.cfg || die
- sed -i -e 's/var\/icinga\/icinga.tmp/tmp\/icinga\/icinga.tmp/g' "${D}"/etc/icinga/icinga.cfg || die
-
- if use idoutils ; then
- emake DESTDIR="${D}" install-idoutils || die
- fi
- if use api ; then
- emake DESTDIR="${D}" install-api || die
- fi
-
- newinitd "${FILESDIR}"/icinga-init.d-2 icinga || die
- newconfd "${FILESDIR}"/icinga-conf.d icinga || die
- if use idoutils ; then
- newinitd "${FILESDIR}"/ido2db-init.d ido2db || die
- newconfd "${FILESDIR}"/ido2db-conf.d ido2db || die
- insinto /usr/share/icinga/contrib/db
- doins -r module/idoutils/db/* || die
- fi
- # Apache Module
- if use web ; then
- if use apache2 ; then
- insinto "${APACHE_MODULES_CONFDIR}"
- newins "${FILESDIR}"/icinga-apache.conf 99_icinga.conf || die
- elif use lighttpd ; then
- insinto /etc/lighttpd
- newins "${FILESDIR}"/icinga-lighty.conf lighttpd_icinga.conf || die
- else
- ewarn "${CATEGORY}/${PF} only supports Apache-2.x or Lighttpd webserver"
- ewarn "out-of-the-box. Since you are not using one of them, you"
- ewarn "have to configure your webserver accordingly yourself."
- fi
- fi
-
- fowners -R root:root /usr/$(get_libdir)/icinga || die
- cd "${D}" || die
- find usr/$(get_libdir)/icinga -type d -exec fperms 755 {} +
- find usr/$(get_libdir)/icinga/cgi-bin -type f -exec fperms 755 {} +
- dodir /var/run/icinga || die
- fowners icinga:icinga /var/run/icinga || die
-
- keepdir /etc/icinga
- keepdir /var/lib/icinga
- keepdir /var/lib/icinga/archives
- keepdir /var/lib/icinga/rw
- keepdir /var/lib/icinga/spool/checkresults
-
- if use apache2 ; then
- webserver=apache
- elif use lighttpd ; then
- webserver=lighttpd
- else
- webserver=icinga
- fi
-
- fowners icinga:icinga /var/lib/icinga || die "Failed chown of /var/lib/icinga"
- fowners -R icinga:${webserver} /var/lib/icinga/rw || die "Failed chown of /var/lib/icinga/rw"
-
- fperms 6755 /var/lib/icinga/rw || die "Failed Chmod of ${D}/var/lib/icinga/rw"
- fperms 0750 /etc/icinga || die "Failed chmod of ${D}/etc/icinga"
-}
-
-pkg_postinst() {
- elog "If you want icinga to start at boot time"
- elog "remember to execute:"
- elog " rc-update add icinga default"
- elog
- elog "If your kernel has /proc protection, icinga"
- elog "will not be happy as it relies on accessing the proc"
- elog "filesystem. You can fix this by adding icinga into"
- elog "the group wheel, but this is not recomended."
- elog
- elog "/var/icinga was moved to /var/lib/icinga"
- elog "please move the file if this was an upgrade"
-}
diff --git a/net-analyzer/icinga/icinga-1.6.1.ebuild b/net-analyzer/icinga/icinga-1.6.1-r1.ebuild
index 88a675b0ba81..016e935598f1 100644
--- a/net-analyzer/icinga/icinga-1.6.1.ebuild
+++ b/net-analyzer/icinga/icinga-1.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.6.1.ebuild,v 1.1 2011/12/02 22:09:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.6.1-r1.ebuild,v 1.1 2011/12/04 19:27:45 prometheanfire Exp $
EAPI=2
diff --git a/net-analyzer/icinga/metadata.xml b/net-analyzer/icinga/metadata.xml
index bc77e2a88d41..3ab11f8551fb 100644
--- a/net-analyzer/icinga/metadata.xml
+++ b/net-analyzer/icinga/metadata.xml
@@ -4,7 +4,6 @@
<herd>no-herd</herd>
<longdescription lang="en">A rebuild of nagios from the ground up</longdescription>
<use>
- <flag name="api">Adds support for the icinga API</flag>
<flag name="idoutils">Adds DB support</flag>
<flag name="lighttpd">Adds Lighttpd support</flag>
<flag name="plugins">Adds support for nagios plugins</flag>