summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-08-19 07:23:10 +0000
committerPeter Volkov <pva@gentoo.org>2008-08-19 07:23:10 +0000
commit1f79c001870c0c9ca01476d01710514abedcd513 (patch)
tree56444299db8227e547ed57ec2027360a90e0235d /net-analyzer
parentStable for HPPA (bug #234927). (diff)
downloadgentoo-2-1f79c001870c0c9ca01476d01710514abedcd513.tar.gz
gentoo-2-1f79c001870c0c9ca01476d01710514abedcd513.tar.bz2
gentoo-2-1f79c001870c0c9ca01476d01710514abedcd513.zip
Added reset_each_patch upstream patch. Removed unused.
(Portage version: 2.2_rc8/cvs/Linux 2.6.22-ovz005 i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/cacti-0.8.7b-r3.ebuild (renamed from net-analyzer/cacti/cacti-0.8.7b-r1.ebuild)6
-rw-r--r--net-analyzer/cacti/cacti-0.8.7b.ebuild92
3 files changed, 11 insertions, 95 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index a368d5150346..6e2363e29c51 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.141 2008/08/04 19:25:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.142 2008/08/19 07:23:10 pva Exp $
+
+*cacti-0.8.7b-r3 (19 Aug 2008)
+
+ 19 Aug 2008; Peter Volkov <pva@gentoo.org> -cacti-0.8.7b.ebuild,
+ -cacti-0.8.7b-r1.ebuild, +cacti-0.8.7b-r3.ebuild:
+ Added reset_each_patch upstream patch. Removed unused.
04 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Describe local USE flags for GLEP 56.
diff --git a/net-analyzer/cacti/cacti-0.8.7b-r1.ebuild b/net-analyzer/cacti/cacti-0.8.7b-r3.ebuild
index dea5f0620863..595a7683e592 100644
--- a/net-analyzer/cacti/cacti-0.8.7b-r1.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.7b-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7b-r1.ebuild,v 1.1 2008/03/03 18:50:54 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7b-r3.ebuild,v 1.1 2008/08/19 07:23:10 pva Exp $
inherit eutils webapp depend.apache depend.php
@@ -14,7 +14,9 @@ SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
# patches
if [ "${HAS_PATCHES}" == "1" ] ; then
- UPSTREAM_PATCHES="snmp_auth_none_notice"
+ UPSTREAM_PATCHES="upgrade_from_086k_fix
+ snmp_auth_none_notice
+ reset_each_patch"
for i in $UPSTREAM_PATCHES ; do
SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
done
diff --git a/net-analyzer/cacti/cacti-0.8.7b.ebuild b/net-analyzer/cacti/cacti-0.8.7b.ebuild
deleted file mode 100644
index 0491fdf8dae6..000000000000
--- a/net-analyzer/cacti/cacti-0.8.7b.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7b.ebuild,v 1.6 2008/02/26 14:40:22 armin76 Exp $
-
-inherit eutils webapp depend.apache depend.php
-
-# Support for _p* in version.
-MY_P=${P/_p*/}
-HAS_PATCHES=0
-
-DESCRIPTION="Cacti is a complete frontend to rrdtool"
-HOMEPAGE="http://www.cacti.net/"
-SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
-
-# patches
-if [ "${HAS_PATCHES}" == "1" ] ; then
- UPSTREAM_PATCHES=""
- for i in $UPSTREAM_PATCHES ; do
- SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
- done
-fi
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ~hppa ppc ppc64 sparc x86"
-IUSE="snmp bundled-adodb"
-
-DEPEND=""
-
-want_apache
-need_php_cli
-need_php_httpd
-
-RDEPEND="!apache2? ( www-servers/lighttpd )
- snmp? ( net-analyzer/net-snmp )
- net-analyzer/rrdtool
- !bundled-adodb? ( dev-php/adodb )
- virtual/mysql
- virtual/cron"
-
-src_unpack() {
- if [ "${HAS_PATCHES}" == "1" ] ; then
- unpack ${MY_P}.tar.gz
- [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
- # patches
- for i in ${UPSTREAM_PATCHES} ; do
- EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
- done ;
- else
- unpack ${MY_P}.tar.gz
- fi
-
- use bundled-adodb || sed -i -e \
- 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
- "${S}"/include/global.php
-}
-
-pkg_setup() {
- webapp_pkg_setup
- has_php
- if [ $PHP_VERSION = 5 ] ; then
- phpUseFlags="cli mysql xml session pcre"
- elif [ $PHP_VERSION = 4 ] ; then
- phpUseFlags="cli mysql xml session pcre expat"
- fi
- use bundled-adodb || phpUseFlags="${phpUseFlags} sockets"
- require_php_with_use ${phpUseFlags}
-}
-
-src_compile() {
- einfo "Nothing to compile."
-}
-
-src_install() {
- webapp_src_preinst
-
- rm LICENSE README
- dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
- rm -rf docs
- use bundled-adodb || rm -rf lib/adodb
-
- edos2unix `find -type f -name '*.php'`
-
- dodir ${MY_HTDOCSDIR}
- cp -r . "${D}"${MY_HTDOCSDIR}
-
- webapp_serverowned ${MY_HTDOCSDIR}/rra
- webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
- webapp_configfile ${MY_HTDOCSDIR}/include/config.php
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}