summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-29 15:05:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-29 15:05:59 +0000
commit20358bff443d169a0d026b43822c58deff7ba196 (patch)
treee252884ea45fdd7b3692ccfe871240e8603c1b16 /net-analyzer
parentMarked ~ppc (bug #305781). (diff)
downloadgentoo-2-20358bff443d169a0d026b43822c58deff7ba196.tar.gz
gentoo-2-20358bff443d169a0d026b43822c58deff7ba196.tar.bz2
gentoo-2-20358bff443d169a0d026b43822c58deff7ba196.zip
Fix building with -Wl,--as-needed wrt #277794 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fe3d/ChangeLog6
-rw-r--r--net-analyzer/fe3d/fe3d-0.11.2.ebuild13
-rw-r--r--net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch39
3 files changed, 53 insertions, 5 deletions
diff --git a/net-analyzer/fe3d/ChangeLog b/net-analyzer/fe3d/ChangeLog
index 62fd703490c2..6f5a940974ec 100644
--- a/net-analyzer/fe3d/ChangeLog
+++ b/net-analyzer/fe3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/fe3d
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fe3d/ChangeLog,v 1.10 2010/03/01 13:37:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fe3d/ChangeLog,v 1.11 2010/06/29 15:05:59 ssuominen Exp $
+
+ 29 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> fe3d-0.11.2.ebuild,
+ +files/fe3d-0.11.2-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #277794 by Kacper Kowalik.
*fe3d-0.11.2 (01 Mar 2010)
diff --git a/net-analyzer/fe3d/fe3d-0.11.2.ebuild b/net-analyzer/fe3d/fe3d-0.11.2.ebuild
index 6d6b0745f87c..536135ca505e 100644
--- a/net-analyzer/fe3d/fe3d-0.11.2.ebuild
+++ b/net-analyzer/fe3d/fe3d-0.11.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fe3d/fe3d-0.11.2.ebuild,v 1.1 2010/03/01 13:37:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fe3d/fe3d-0.11.2.ebuild,v 1.2 2010/06/29 15:05:59 ssuominen Exp $
-EAPI=1
+EAPI=2
WX_GTK_VER="2.8"
-inherit eutils wxwidgets
+inherit autotools eutils wxwidgets
if [[ "${PV}" =~ (_p)([0-9]+) ]] ; then
inherit subversion
@@ -34,8 +34,13 @@ pkg_setup() {
check_wxuse opengl
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS doc/{ChangeLog,README}.txt
}
diff --git a/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch b/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch
new file mode 100644
index 000000000000..5399da4b8e97
--- /dev/null
+++ b/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch
@@ -0,0 +1,39 @@
+--- configure.ac
++++ configure.ac
+@@ -46,16 +46,15 @@
+ ])
+ fi
+
+-CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
+-CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
+-CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
+-LIBS="$LIBS $WX_LIBS"
++#CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
++#CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
++#CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
++#LIBS="$LIBS $WX_LIBS"
+
+ AM_CPPFLAGS="$AM_CPPFLAGS $GL_CFLAGS $GLU_CFLAGS"
+-AM_LDFLAGS="$AM_LDFLAGS $GL_LIBS $GLU_LIBS"
+ AC_SUBST([AM_CPPFLAGS])
+ AC_SUBST([AM_LDFLAGS])
+-AC_SUBST([$PREFIX])
++#AC_SUBST([$PREFIX])
+
+ AC_OUTPUT
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,8 +1,10 @@
+-fe3d_CPPFLAGS = -DFE_DATA_DIR="\"@datadir@/@PACKAGE@/\""
++fe3d_CPPFLAGS = -DFE_DATA_DIR="\"@datadir@/@PACKAGE@/\"" @WX_CPPFLAGS@
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/src/include
+ bin_PROGRAMS = fe3d
+ fe3d_SOURCES = fe_config.cpp fe_core.cpp fe_draw.cpp fe_events.cpp fe_host.cpp fe_hosts.cpp fe_match.cpp fe_node.cpp fe_os_rgx.cpp fe_port.cpp fe_root_node.cpp fe_tools.cpp geo_cache.cpp gl_util.cpp libfe3d.cpp nmap_parser.cpp tex_cache.cpp wxfe3d_app.cpp wxfe3d_frame.cpp wxfe3d_glcanvas.cpp ui_nmap_ctrl.cpp ./gui/fe3d_ui.cpp ./regexp/Matcher.cpp ./regexp/Pattern.cpp ./regexp/WCMatcher.cpp ./regexp/WCPattern.cpp
+-
++fe3d_CFLAGS = @WX_CFLAGS@
++fe3d_CXXFLAGS = @WX_CXXFLAGS_ONLY@
++fe3d_LDADD = @GLU_LIBS@ @WX_LIBS@
+ fe3ddir = @datadir@/@PACKAGE@
+ fe3d_imgdir = @datadir@/@PACKAGE@/img
+ fe3d_DATA = $(top_srcdir)/data/*