summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-04-10 18:08:03 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-04-10 18:08:03 +0000
commit2668a6659b66d3a4dc3feb529c8fc159e1242572 (patch)
tree7971557c76fe00cd8c16f3395ee3847959984300 /net-analyzer
parentMarked stable on mips. (diff)
downloadgentoo-2-2668a6659b66d3a4dc3feb529c8fc159e1242572.tar.gz
gentoo-2-2668a6659b66d3a4dc3feb529c8fc159e1242572.tar.bz2
gentoo-2-2668a6659b66d3a4dc3feb529c8fc159e1242572.zip
gcc-4 fix
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/isic/ChangeLog6
-rw-r--r--net-analyzer/isic/files/isic-0.06-gcc4.patch50
-rw-r--r--net-analyzer/isic/isic-0.06.ebuild3
3 files changed, 57 insertions, 2 deletions
diff --git a/net-analyzer/isic/ChangeLog b/net-analyzer/isic/ChangeLog
index 9b75363cd3a4..4ae1ff125de0 100644
--- a/net-analyzer/isic/ChangeLog
+++ b/net-analyzer/isic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/isic
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/isic/ChangeLog,v 1.7 2005/01/08 22:35:26 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/isic/ChangeLog,v 1.8 2005/04/10 18:08:03 vanquirius Exp $
+
+ 10 Apr 2005; Marcelo Goes <vanquirius@gentoo.org>
+ +files/isic-0.06-gcc4.patch, isic-0.06.ebuild:
+ Adding gcc-4 patch from Debian.
09 Jan 2005; Daniel Black <dragonheart@gentoo.org> metadata.xml,
-files/0.05-libnet-1.0.patch, -isic-0.05-r1.ebuild, -isic-0.05.ebuild,
diff --git a/net-analyzer/isic/files/isic-0.06-gcc4.patch b/net-analyzer/isic/files/isic-0.06-gcc4.patch
new file mode 100644
index 000000000000..a2b9087650bd
--- /dev/null
+++ b/net-analyzer/isic/files/isic-0.06-gcc4.patch
@@ -0,0 +1,50 @@
+diff -urN ../tmp-orig/isic-0.05/icmpsic.c ./icmpsic.c
+--- ../tmp-orig/isic-0.05/icmpsic.c 2000-01-25 18:35:25.000000000 +0100
++++ ./icmpsic.c 2004-12-20 14:29:04.714661648 +0100
+@@ -253,7 +253,7 @@
+
+ payload = (short int *)((u_char *) icmp + 4);
+ for(cx = 0; cx <= (payload_s >> 1); cx+=1)
+- (u_short) payload[cx] = rand() & 0xffff;
++ payload[cx] = rand() & 0xffff;
+
+
+ if ( rand() <= (RAND_MAX * ICMPCksm) )
+diff -urN ../tmp-orig/isic-0.05/isic.c ./isic.c
+--- ../tmp-orig/isic-0.05/isic.c 2000-01-30 22:55:25.000000000 +0100
++++ ./isic.c 2004-12-20 14:28:13.952378688 +0100
+@@ -232,8 +232,8 @@
+
+ payload = (short int *)(buf + IP_H);
+ for(cx = 0; cx <= (payload_s >> 1); cx+=1)
+- (u_int16_t) payload[cx] = rand() & 0xffff;
+- (u_int16_t) payload[payload_s] = rand() & 0xffff;
++ payload[cx] = rand() & 0xffff;
++ payload[payload_s] = rand() & 0xffff;
+
+ if ( printout ) {
+ printf("%s ->",
+diff -urN ../tmp-orig/isic-0.05/tcpsic.c ./tcpsic.c
+--- ../tmp-orig/isic-0.05/tcpsic.c 2000-01-29 20:04:13.000000000 +0100
++++ ./tcpsic.c 2004-12-20 14:28:36.223992888 +0100
+@@ -304,7 +304,7 @@
+
+ payload = (short int *)((u_char *) tcp + 20);
+ for(cx = 0; cx <= (payload_s >> 1); cx+=1)
+- (u_int16_t) payload[cx] = rand() & 0xffff;
++ payload[cx] = rand() & 0xffff;
+
+ if ( rand() <= (RAND_MAX * TCPCksm) )
+ libnet_do_checksum(buf, IPPROTO_TCP, (tcp->th_off << 2)
+diff -urN ../tmp-orig/isic-0.05/udpsic.c ./udpsic.c
+--- ../tmp-orig/isic-0.05/udpsic.c 2000-01-29 20:04:14.000000000 +0100
++++ ./udpsic.c 2004-12-20 14:28:51.290702400 +0100
+@@ -279,7 +279,7 @@
+
+ payload = (short int *)((u_char *) udp + UDP_H);
+ for(cx = 0; cx <= (payload_s >> 1); cx+=1)
+- (u_int16_t) payload[cx] = rand() & 0xffff;
++ payload[cx] = rand() & 0xffff;
+
+ if ( printout ) {
+ printf("%s,%i ->",
diff --git a/net-analyzer/isic/isic-0.06.ebuild b/net-analyzer/isic/isic-0.06.ebuild
index 6667d644ffec..4445e6bcd62f 100644
--- a/net-analyzer/isic/isic-0.06.ebuild
+++ b/net-analyzer/isic/isic-0.06.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/isic/isic-0.06.ebuild,v 1.2 2005/01/08 22:35:26 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/isic/isic-0.06.ebuild,v 1.3 2005/04/10 18:08:03 vanquirius Exp $
inherit eutils
@@ -19,6 +19,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-makefile.patch || die "patch failed"
+ epatch ${FILESDIR}/${P}-gcc4.patch || die "patch failed"
}
src_compile() {