summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-27 21:30:52 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-27 21:30:52 +0000
commit2d0c75f8f55960c91ac69180fbc31526a28f1610 (patch)
tree7a80777d50313bcab7a1b859363da754974c2754 /net-analyzer
parentmarking x86 stable (diff)
downloadgentoo-2-2d0c75f8f55960c91ac69180fbc31526a28f1610.tar.gz
gentoo-2-2d0c75f8f55960c91ac69180fbc31526a28f1610.tar.bz2
gentoo-2-2d0c75f8f55960c91ac69180fbc31526a28f1610.zip
cleanup
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-core/Manifest2
-rw-r--r--net-analyzer/nagios-core/files/digest-nagios-core-1.1-r31
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r3.ebuild158
3 files changed, 0 insertions, 161 deletions
diff --git a/net-analyzer/nagios-core/Manifest b/net-analyzer/nagios-core/Manifest
index 4d5edced612d..009c26f3802a 100644
--- a/net-analyzer/nagios-core/Manifest
+++ b/net-analyzer/nagios-core/Manifest
@@ -1,7 +1,5 @@
MD5 a476e7ead91e67a4cfb9a770ea009c63 nagios-core-1.1-r4.ebuild 5350
-MD5 3559363bf71e7d6a054b27614afa3636 nagios-core-1.1-r3.ebuild 4930
MD5 96cbe07485bf91776ef8d6f7911b12de ChangeLog 2399
-MD5 de44d331b40a2395b74c5ebf887b7675 files/digest-nagios-core-1.1-r3 63
MD5 565ce2a690d50aeb542e7afe44b8c733 files/Makefile-distclean.diff.bz2 1133
MD5 713531258f08d24d3c9ee3eb4bba2276 files/nagios 820
MD5 93fc29972ca48db69fc84adba9754c62 files/nagios.cfg-sample 22287
diff --git a/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r3 b/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r3
deleted file mode 100644
index 14267bedc75b..000000000000
--- a/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5f48ecd9bad2c4d7c9d88d0b6f347ecf nagios-1.1.tar.gz 1619888
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r3.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r3.ebuild
deleted file mode 100644
index 79d061274930..000000000000
--- a/net-analyzer/nagios-core/nagios-core-1.1-r3.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r3.ebuild,v 1.4 2003/11/26 17:25:59 mholzer Exp $
-
-inherit eutils
-
-DESCRIPTION="Nagios $PV core - Host and service monitor cgi, docs etc..."
-HOMEPAGE="http://www.nagios.org/"
-SRC_URI="mirror://sourceforge/nagios/nagios-1.1.tar.gz"
-RESTRICT="nomirror"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~sparc ~ppc"
-IUSE="gd apache2 perl"
-
-DEPEND=">=mailx-8.1
- apache2? ( >=net-www/apache-2.0.43-r1 )
- gd? (
- >=jpeg-6b-r3
- >=libpng-1.2.5-r4
- >=libgd-1.8.3-r5
- )
- perl? ( >=perl-5.6.1-r7 )
- mysql? ( >=dev-db/mysql-3.23.56 )
- pgsql? ( >=dev-db/postgresql-7.3.2 )"
-
-S="${WORKDIR}/nagios-${PV}"
-
-pkg_setup() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /dev/null nagios
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/Makefile-distclean.diff.bz2
- [ `use gd` ] && epatch ${FILESDIR}/tac.cgi.diff.bz2
-}
-
-src_compile() {
- local myconf
-
- use mysql && myconf="${myconf} --with-mysql-xdata \
- --with-mysql-status --with-mysql-comments --with-mysql-extinfo \
- --with-mysql-retention --with-mysql-downtime"
-
- use pgsql && myconf="${myconf} --with-pgsql-xdata \
- --with-pgsql-status --with-pgsql-comments --with-pgsql-extinfo \
- --with-pgsql-retention --with-pgsql-downtime"
-
- use perl && myconf="${myconf} --enable-embedded-perl --with-perlcache"
-
- use debug0 && myconf="${myconf} --enable-DEBUG0"
- use debug1 && myconf="${myconf} --enable-DEBUG1"
- use debug2 && myconf="${myconf} --enable-DEBUG2"
- use debug3 && myconf="${myconf} --enable-DEBUG3"
- use debug4 && myconf="${myconf} --enable-DEBUG4"
- use debug5 && myconf="${myconf} --enable-DEBUG5"
-
- ./configure ${myconf} \
- --host=${CHOST} \
- --prefix=/usr/nagios \
- --localstatedir=/var/nagios \
- --sysconfdir=/etc/nagios \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
- emake all || die "make failed"
-}
-
-src_install() {
- dodoc Changelog INSTALLING LEGAL LICENSE README UPGRADING
- if [ -n "`use gd`" ]; then
- make DESTDIR=${D} fullinstall install-config || die
- if [ -n "`use apache2`" ]; then
- insinto /etc/apache2/conf/modules.d
- doins ${FILESDIR}/99_nagios.conf
- else
- insinto /etc/apache/conf/addon-modules
- doins ${FILESDIR}/nagios.conf
- fi
- else
- make DESTDIR=${D} fullinstall install-config || die
- rm -rf ${D}/usr/nagios/{sbin,share}/*
- fi
- exeinto /etc/init.d
- doexe ${FILESDIR}/nagios
- insinto /etc/nagios
- doins ${FILESDIR}/nagios.cfg-sample
-}
-
-pkg_preinst() {
- einfo "Sample config files installed by default will always"
- einfo "include cgi.cfg"
- chown -R nagios:nagios ${D}/etc/nagios || die "Failed Chown of ${D}/etc/nagios"
- touch ${D}/usr/nagios/share/ssi/.keep
- chown -R nagios:nagios ${D}/usr/nagios || die "Failed Chown of ${D}/usr/nagios"
- touch ${D}/var/nagios/.keep
- touch ${D}/var/nagios/archives/.keep
- chown -R nagios:nagios ${D}/var/nagios || die "Failed Chown of ${D}/var/nagios"
- touch ${D}/var/nagios/rw/.keep
- chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
-}
-
-pkg_postinst() {
- einfo
- einfo "Remember to edit the config files in /etc/nagios"
- einfo "Also, if you want nagios to start at boot time"
- einfo "remember to execute rc-update add nagios default"
- einfo
- if [ -n "`use gd`" ]; then
- einfo "This does not include cgis that are perl-dependent"
- einfo "Currently traceroute.cgi is perl-dependent"
- einfo "To have ministatus.cgi requires copying of ministatus.c"
- einfo "to cgi directory for compiling"
- if [ -n "`use apache2`" ]; then
- einfo "To have nagios visable on the web, please do the following:"
- einfo "Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
- einfo "The Apache2 config file for nagios will be in"
- einfo "/etc/apache2/conf/modules.d with the name of"
- einfo "99_nagios.conf."
- else
- einfo "1. Execute the command:"
- einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
- einfo " 2. Edit /etc/conf.d/apache and add \"-D NAGIOS\""
- einfo "The Apache config file for nagios will be in"
- einfo "/etc/apache/conf/addon-modules/ with the name of"
- einfo "nagios.conf."
- fi
- einfo
- einfo "That will make nagios's web front end visable via"
- einfo "http://localhost/nagios/"
- einfo
- fi
- einfo "Also, if your kernel has /proc protection, nagios"
- einfo "will not be happy as it relies on accessing the proc"
- einfo "filesystem. You can fix this by adding nagios into"
- einfo "the group wheel, but this is not recomended."
- einfo
-}
-
-pkg_config() {
- if [ "`use gd`" ]; then
- if [ "`use apache2`" ]; then
- einfo "Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
- fi
- echo "Include conf/addon-modules/nagios.conf" >> ${ROOT}/etc/apache/conf/apache.conf
- einfo
- einfo "Remember to edit /etc/conf.d/apache and add \"-D NAGIOS\""
- einfo
- fi
-}
-
-pkg_prerm() {
- /etc/init.d/nagios stop
-}