summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-08-16 07:35:32 +0000
committerEldad Zack <eldad@gentoo.org>2004-08-16 07:35:32 +0000
commit492bc437280af7f89b76b927f2d9c7905b09b1e2 (patch)
tree1684ddd9fb8311789b44f223d7bfe76ec0b9b4d8 /net-analyzer
parentsync IUSE (Manifest recommit) (diff)
downloadgentoo-2-492bc437280af7f89b76b927f2d9c7905b09b1e2.tar.gz
gentoo-2-492bc437280af7f89b76b927f2d9c7905b09b1e2.tar.bz2
gentoo-2-492bc437280af7f89b76b927f2d9c7905b09b1e2.zip
Got rid of the patch in favor of flag-o-matic
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ChangeLog6
-rw-r--r--net-analyzer/ethereal/ethereal-0.10.6.ebuild15
-rw-r--r--net-analyzer/ethereal/files/0.10.3-gcc34.patch11
-rw-r--r--net-analyzer/ethereal/files/0.10.6-gcc34.patch11
4 files changed, 9 insertions, 34 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index 6b11746152e4..a19641c41bb2 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.81 2004/08/15 21:36:40 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.82 2004/08/16 07:35:32 eldad Exp $
+
+ 16 Aug 2004; Eldad Zack <eldad@gentoo.org> -files/0.10.3-gcc34.patch,
+ -files/0.10.6-gcc34.patch, ethereal-0.10.6.ebuild:
+ Got rid of the patch in favor of flag-o-matic.
15 Aug 2004; Tony Vroon <chainsaw@gentoo.org> +files/0.10.6-gcc34.patch,
ethereal-0.10.6.ebuild:
diff --git a/net-analyzer/ethereal/ethereal-0.10.6.ebuild b/net-analyzer/ethereal/ethereal-0.10.6.ebuild
index ee36638ca0c5..e94a8434cb20 100644
--- a/net-analyzer/ethereal/ethereal-0.10.6.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.10.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.6.ebuild,v 1.2 2004/08/15 21:36:40 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.6.ebuild,v 1.3 2004/08/16 07:35:32 eldad Exp $
inherit libtool flag-o-matic gcc eutils
@@ -33,21 +33,14 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex"
-src_unpack() {
- unpack ${A}
- cd ${S}
+src_compile() {
replace-flags -O3 -O
replace-flags -O2 -O
- # Fix gcc-3.4 segfault #49238
- [ "`gcc-version`" == "3.4" ] && epatch ${FILESDIR}/0.10.6-gcc34.patch
- # running a full elibtoolize seems to break things in this
- # package... see bug 41831 (17 Feb 2004 agriffis)
- # elibtoolize --patch-only
-}
+ # Fix gcc-3.4 segfault #49238
+ [ "`gcc-version`" == "3.4" ] && append-flags -fno-unroll-loops
-src_compile() {
local myconf="
$(use_with ssl)
$(use_enable ipv6)
diff --git a/net-analyzer/ethereal/files/0.10.3-gcc34.patch b/net-analyzer/ethereal/files/0.10.3-gcc34.patch
deleted file mode 100644
index 7f7a5d2451c2..000000000000
--- a/net-analyzer/ethereal/files/0.10.3-gcc34.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- epan/Makefile.in.old 2004-03-26 04:05:56.000000000 +0000
-+++ epan/Makefile.in 2004-04-23 08:59:22.353604120 +0100
-@@ -1453,7 +1453,7 @@
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
- $(AM_LDFLAGS) $(LDFLAGS) -o $@
--CFLAGS = @CFLAGS@
-+CFLAGS = @CFLAGS@ -fno-unroll-loops
- DIST_SOURCES = $(libethereal_la_SOURCES) $(EXTRA_libethereal_la_SOURCES)
-
- RECURSIVE_TARGETS = info-recursive dvi-recursive install-info-recursive \
diff --git a/net-analyzer/ethereal/files/0.10.6-gcc34.patch b/net-analyzer/ethereal/files/0.10.6-gcc34.patch
deleted file mode 100644
index c198202cd25f..000000000000
--- a/net-analyzer/ethereal/files/0.10.6-gcc34.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- epan/Makefile.in.orig 2004-08-15 22:41:56.667034016 +0100
-+++ epan/Makefile.in 2004-08-15 22:42:42.952997480 +0100
-@@ -96,7 +96,7 @@
- AWK = @AWK@
- CC = @CC@
- CCDEPMODE = @CCDEPMODE@
--CFLAGS = @CFLAGS@
-+CFLAGS = @CFLAGS@ -fno-unroll-loops
- CPP = @CPP@
- CPPFLAGS = @CPPFLAGS@
- CYGPATH_W = @CYGPATH_W@