summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-26 18:21:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-26 18:21:52 +0000
commit59f2e8bc0ef5535d4981e25633889f11a06cc099 (patch)
treecec044c511d93017afdf3a2ed7f0ae1213a9132c /net-analyzer
parentStable for HPPA (bug #427964). (diff)
downloadgentoo-2-59f2e8bc0ef5535d4981e25633889f11a06cc099.tar.gz
gentoo-2-59f2e8bc0ef5535d4981e25633889f11a06cc099.tar.bz2
gentoo-2-59f2e8bc0ef5535d4981e25633889f11a06cc099.zip
Add a note to check the Wiki for documentation; fix the ipmi_ plugin and add the new freeipmi_ plugin I wrote; add an impi USE flag to bring in the required dependencies. The configuration file is updated to use root for IPMI-based plugins.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/munin/ChangeLog9
-rw-r--r--net-analyzer/munin/files/munin-1.3.2-plugins.conf12
-rw-r--r--net-analyzer/munin/metadata.xml5
-rw-r--r--net-analyzer/munin/munin-2.0.3.ebuild25
4 files changed, 42 insertions, 9 deletions
diff --git a/net-analyzer/munin/ChangeLog b/net-analyzer/munin/ChangeLog
index e16c7a510f6f..f8dbe5ce3bd5 100644
--- a/net-analyzer/munin/ChangeLog
+++ b/net-analyzer/munin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/munin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.82 2012/07/25 03:32:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.83 2012/07/26 18:21:51 flameeyes Exp $
+
+ 26 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ files/munin-1.3.2-plugins.conf, metadata.xml, munin-2.0.3.ebuild:
+ Add a note to check the Wiki for documentation; fix the ipmi_ plugin and add
+ the new freeipmi_ plugin I wrote; add an impi USE flag to bring in the
+ required dependencies. The configuration file is updated to use root for IPMI-
+ based plugins.
*munin-1.4.7-r2 (25 Jul 2012)
diff --git a/net-analyzer/munin/files/munin-1.3.2-plugins.conf b/net-analyzer/munin/files/munin-1.3.2-plugins.conf
index b0bcaed20145..81ef6c379caa 100644
--- a/net-analyzer/munin/files/munin-1.3.2-plugins.conf
+++ b/net-analyzer/munin/files/munin-1.3.2-plugins.conf
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/files/munin-1.3.2-plugins.conf,v 1.5 2010/10/18 03:22:28 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/files/munin-1.3.2-plugins.conf,v 1.6 2012/07/26 18:21:52 flameeyes Exp $
#
# This file contains configuration options for the plugins. Three
# options are understood by munin-node itself:
@@ -19,6 +19,14 @@
user root
group disk
+# ipmitool and freeipmi need access to the IPMI device nodes, which
+# are only readable by root
+[ipmi_*]
+user root
+
+[freeipmi_*]
+user root
+
# Example for a 3ware 8000-series card, with 2 disks
# use /dev/twe0 as the actual device
# and replicate this entry for each drive, increasing the number in -d
diff --git a/net-analyzer/munin/metadata.xml b/net-analyzer/munin/metadata.xml
index 2532c9195d9d..89d0b20ac090 100644
--- a/net-analyzer/munin/metadata.xml
+++ b/net-analyzer/munin/metadata.xml
@@ -40,6 +40,11 @@
Install the packages required for memcached
monitoring. Disabling the flag does not remove any plugin files.
</flag>
+ <flag name="ipmi">
+ Install <pkg>sys-apps/ipmitool</pkg> required for monitoring
+ IPMI sensors. Disabling the flag does not remove any plugin
+ file.
+ </flag>
<flag name="java">
Build the Java-based plugins to monitor JMX-compatible
applications. Disabling the flag removes the jmx monitoring
diff --git a/net-analyzer/munin/munin-2.0.3.ebuild b/net-analyzer/munin/munin-2.0.3.ebuild
index 6a2f5ec0f53a..8ddd3ece7ad0 100644
--- a/net-analyzer/munin/munin-2.0.3.ebuild
+++ b/net-analyzer/munin/munin-2.0.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.3.ebuild,v 1.2 2012/07/25 03:32:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.3.ebuild,v 1.3 2012/07/26 18:21:51 flameeyes Exp $
EAPI=4
-PATCHSET=1
+PATCHSET=4
inherit eutils user java-pkg-opt-2
@@ -18,12 +18,15 @@ SRC_URI="mirror://sourceforge/munin/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~x86"
-IUSE="asterisk irc java memcached minimal mysql postgres ssl test +cgi ipv6 syslog"
+IUSE="asterisk irc java memcached minimal mysql postgres ssl test +cgi ipv6 syslog ipmi"
REQUIRED_USE="cgi? ( !minimal )"
# Upstream's listing of required modules is NOT correct!
# Some of the postgres plugins use DBD::Pg, while others call psql directly.
# Some of the mysql plugins use DBD::mysql, while others call mysqladmin directly.
+# There are three ipmi plugins: two original ones using ipmitool (and
+# python or gawk) and one using freeipmi that Flameeyes wrote (which works fine with
+# any awk provider). Once freeipmi_ is feature-par with ipmi_, we'll drop the former.
DEPEND_COM="dev-lang/perl
sys-process/procps
asterisk? ( dev-perl/Net-Telnet )
@@ -36,10 +39,13 @@ DEPEND_COM="dev-lang/perl
memcached? ( dev-perl/Cache-Memcached )
cgi? ( dev-perl/FCGI )
syslog? ( virtual/perl-Sys-Syslog )
+ ipmi? (
+ sys-apps/ipmitool sys-apps/gawk
+ sys-libs/freeipmi virtual/awk
+ )
dev-perl/DBI
dev-perl/DateManip
dev-perl/File-Copy-Recursive
- dev-perl/IO-Socket-INET6
dev-perl/Log-Log4perl
dev-perl/Net-CIDR
dev-perl/Net-Netmask
@@ -52,8 +58,11 @@ DEPEND_COM="dev-lang/perl
virtual/perl-Storable
virtual/perl-Text-Balanced
virtual/perl-Time-HiRes
- !minimal? ( dev-perl/HTML-Template
- >=net-analyzer/rrdtool-1.3[perl] )"
+ !minimal? (
+ dev-perl/HTML-Template
+ dev-perl/IO-Socket-INET6
+ >=net-analyzer/rrdtool-1.3[perl]
+ )"
# Keep this seperate, as previous versions have had other deps here
DEPEND="${DEPEND_COM}
@@ -65,6 +74,7 @@ DEPEND="${DEPEND_COM}
dev-perl/Test-MockModule
dev-perl/File-Slurp
dev-perl/IO-stringy
+ dev-perl/IO-Socket-INET6
)"
RDEPEND="${DEPEND_COM}
java? ( >=virtual/jre-1.5 )
@@ -228,4 +238,7 @@ pkg_postinst() {
elog "your munin master installation, please:"
elog "emerge --config net-analyzer/munin"
fi
+ elog ""
+ elog "Further information about setting up Munin in Gentoo can be found"
+ elog "in the Gentoo Wiki: https://wiki.gentoo.org/wiki/Munin"
}