summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-10-13 20:00:17 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-10-13 20:00:17 +0000
commit7e025d7789594476fc33c3ef5771ec21c7b7ccea (patch)
treee2da6e6bc6cbc5b2f8a75b99171cd6dc9367608d /net-analyzer
parentRemove arm workaround now that its been fixed on gcc-4.4.3-r3 (diff)
downloadgentoo-2-7e025d7789594476fc33c3ef5771ec21c7b7ccea.tar.gz
gentoo-2-7e025d7789594476fc33c3ef5771ec21c7b7ccea.tar.bz2
gentoo-2-7e025d7789594476fc33c3ef5771ec21c7b7ccea.zip
Added pnp4nagios-0.6.5-r1.ebuild with QA fixes from bug 332451 by c1pher as well as fixes required for PHP 5.3
(Portage version: 2.1.9.11/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog10
-rw-r--r--net-analyzer/pnp4nagios/files/pnp4nagios-0.6.5-makefile.patch11
-rw-r--r--net-analyzer/pnp4nagios/files/pnp4nagios-0.6.5-stripped.patch13
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.6.5-r1.ebuild62
4 files changed, 95 insertions, 1 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
index b3795aee86e3..cfa86fd3b872 100644
--- a/net-analyzer/pnp4nagios/ChangeLog
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/pnp4nagios
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.21 2010/07/30 15:56:07 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.22 2010/10/13 20:00:17 olemarkus Exp $
+
+*pnp4nagios-0.6.5-r1 (13 Oct 2010)
+
+ 13 Oct 2010; <olemarkus@gentoo.org> +pnp4nagios-0.6.5-r1.ebuild,
+ +files/pnp4nagios-0.6.5-makefile.patch,
+ +files/pnp4nagios-0.6.5-stripped.patch:
+ Added pnp4nagios-0.6.5-r1.ebuild with QA fixes from bug 332451 by c1pher
+ as well as fixes required for PHP 5.3
30 Jul 2010; Tobias Scherbaum <dertobi123@gentoo.org>
pnp4nagios-0.6.4.ebuild, pnp4nagios-0.6.5.ebuild:
diff --git a/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.5-makefile.patch b/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.5-makefile.patch
new file mode 100644
index 000000000000..d9e4df866d02
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.5-makefile.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.in 2010-06-03 10:00:23.000000000 -0400
++++ src/Makefile.in.new 2010-08-12 12:02:10.000000000 -0400
+@@ -82,7 +82,7 @@
+ #
+ ###############################
+ npcd: npcd.c $(NPCDOBJS) $(NPCDHEAD)
+- $(CC) $(CFLAGS) -o $@ npcd.c $(NPCDOBJS) -lpthread
++ $(CC) $(CFLAGS) $(LDFLAGS) npcd.c $(NPCDOBJS) -lpthread -o npcd
+
+ ###############################
+ #
diff --git a/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.5-stripped.patch b/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.5-stripped.patch
new file mode 100644
index 000000000000..b34adabc226f
--- /dev/null
+++ b/net-analyzer/pnp4nagios/files/pnp4nagios-0.6.5-stripped.patch
@@ -0,0 +1,13 @@
+--- Makefile.in 2010-06-03 10:00:23.000000000 -0400
++++ Makefile.in.new 2010-08-12 12:21:41.000000000 -0400
+@@ -121,8 +121,8 @@
+
+ install-unstripped:
+ cd $(SRC_BASE) && $(MAKE) $@
+- cd $(SRC_SHARE) && $(MAKE) $@
+- cd $(SRC_SCRIPTS) && $(MAKE) $@
++ cd $(SRC_SHARE) && $(MAKE) install
++ cd $(SRC_SCRIPTS) && $(MAKE) install
+ $(MAKE) install-basic
+
+ install-basic:
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.6.5-r1.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.6.5-r1.ebuild
new file mode 100644
index 000000000000..e7113e816ba3
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.6.5-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.6.5-r1.ebuild,v 1.1 2010/10/13 20:00:17 olemarkus Exp $
+
+EAPI="2"
+
+inherit depend.apache eutils
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+
+SRC_URI="mirror://sourceforge/${PN}/PNP-0.6/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/php[json,simplexml,zlib,xml,filter]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ || ( >=dev-lang/php-4.3[gd-external] >=dev-lang/php-4.3[gd] )
+ >=net-analyzer/rrdtool-1.2
+ net-analyzer/nagios-core"
+RDEPEND="${DEPEND}
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+ media-fonts/dejavu
+ apache2? ( www-servers/apache[apache2_modules_rewrite] )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-stripped.patch
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/pnp \
+ --datarootdir=/usr/share/pnp \
+ --with-perfdata-dir=/var/nagios/perfdata \
+ --with-perfdata-spool-dir=/var/spool/pnp || die "econf failed"
+}
+
+src_compile() {
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-unstripped install-config || die "emake install failed"
+ doinitd "${FILESDIR}/npcd"
+ rm "${D}/usr/share/pnp/install.php"
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/98_pnp4nagios.conf
+ fi
+}