summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-30 14:49:12 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-30 14:49:12 +0000
commita74fac81681f55f013b255d425c9cda4844267c4 (patch)
treef78f11ffe548016f309161f341ce0bcf612064c9 /net-analyzer
parentFix bug #515766 (diff)
downloadgentoo-2-a74fac81681f55f013b255d425c9cda4844267c4.tar.gz
gentoo-2-a74fac81681f55f013b255d425c9cda4844267c4.tar.bz2
gentoo-2-a74fac81681f55f013b255d425c9cda4844267c4.zip
Fix building against dev-lang/perl-5.18. Move configuration logic to src_configure().
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/symon/ChangeLog7
-rw-r--r--net-analyzer/symon/files/symon-2.86-perl-5.18.patch38
-rw-r--r--net-analyzer/symon/symon-2.86-r1.ebuild10
3 files changed, 51 insertions, 4 deletions
diff --git a/net-analyzer/symon/ChangeLog b/net-analyzer/symon/ChangeLog
index 329160f36203..393095cdf9ed 100644
--- a/net-analyzer/symon/ChangeLog
+++ b/net-analyzer/symon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/symon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/symon/ChangeLog,v 1.15 2014/06/24 01:31:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/symon/ChangeLog,v 1.16 2014/07/30 14:49:12 jer Exp $
+
+ 30 Jul 2014; Jeroen Roovers <jer@gentoo.org> symon-2.86-r1.ebuild,
+ +files/symon-2.86-perl-5.18.patch:
+ Fix building against dev-lang/perl-5.18. Move configuration logic to
+ src_configure().
*symon-2.86-r1 (24 Jun 2014)
diff --git a/net-analyzer/symon/files/symon-2.86-perl-5.18.patch b/net-analyzer/symon/files/symon-2.86-perl-5.18.patch
new file mode 100644
index 000000000000..83ea4b013dad
--- /dev/null
+++ b/net-analyzer/symon/files/symon-2.86-perl-5.18.patch
@@ -0,0 +1,38 @@
+--- a/client/SymuxClient.pm
++++ b/client/SymuxClient.pm
+@@ -267,23 +267,35 @@
+
+ =head2 METHODS
+
++=over 4
++
+ =item getitem (host, stream, item)
+
++=back
++
+ Refresh the measured data and get an item from a stream for a particular
+ host. Note that successive calls for this function deal with successive
+ measurements of B<symon>. Set C<host> to '*' if data about any host is of
+ interest. Any errors are sent out on STDOUT prepended with 'error: '.
+
++=over 4
++
+ =item getcacheditem (host, stream, item)
+
++=back
++
+ Get an item from a stream for a particular host. Returns C<undef> if no data is
+ cached, or if the data cached does not match the B<host>. Can be called
+ multiple times to obtain items from the same measurement. Set C<host> to '*' if
+ data about any host is of interest. Any errors are sent out on STDOUT prepended
+ with 'error: '.
+
++=over 4
++
+ =item getsource ()
+
++=back
++
+ Get the symon source host of the currently cached information. Usefull to see
+ what host's data getcacheditem is working on.
+
diff --git a/net-analyzer/symon/symon-2.86-r1.ebuild b/net-analyzer/symon/symon-2.86-r1.ebuild
index b4c824856c86..2d1ea9ec9e7f 100644
--- a/net-analyzer/symon/symon-2.86-r1.ebuild
+++ b/net-analyzer/symon/symon-2.86-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/symon/symon-2.86-r1.ebuild,v 1.1 2014/06/24 01:31:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/symon/symon-2.86-r1.ebuild,v 1.2 2014/07/30 14:49:12 jer Exp $
EAPI=5
-inherit perl-module toolchain-funcs
+inherit eutils perl-module toolchain-funcs
DESCRIPTION="Performance and information monitoring tool"
HOMEPAGE="http://www.xs4all.nl/~wpd/symon/"
@@ -25,7 +25,7 @@ S=${WORKDIR}/${PN}
# Deletes the directory passed as an argument from the internal pmake
# variable SUBDIR.
zap_subdir() {
- sed -i "/^SUBDIR/s/$1//" Makefile || die
+ sed -i "/^SUBDIR/s|$1||" Makefile || die
}
pkg_setup() {
@@ -44,6 +44,10 @@ src_prepare() {
-e '/^[ \t]*${CC}.*\${LIBS}/s:\${CC}:$(CC) $(LDFLAGS):' \
sym*/Makefile || die
+ epatch "${FILESDIR}"/${P}-perl-5.18.patch
+}
+
+src_configure() {
# Do some sed magic in accordance with the USE flags.
use perl && [[ -z ${USE_SYMON} ]] && ! use symux && zap_subdir lib
! use perl && zap_subdir client