summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-01-29 22:49:44 +0000
committerMichael Januszewski <spock@gentoo.org>2006-01-29 22:49:44 +0000
commitb0070ff78c1790738af92ffc36d9b6567bebec25 (patch)
tree57db2b8bcdc5d211f845c2fe53bff292795f66a5 /net-analyzer
parentadd --disable-valgrind to econf, should fix #115421 (diff)
downloadgentoo-2-b0070ff78c1790738af92ffc36d9b6567bebec25.tar.gz
gentoo-2-b0070ff78c1790738af92ffc36d9b6567bebec25.tar.bz2
gentoo-2-b0070ff78c1790738af92ffc36d9b6567bebec25.zip
Version bump (bug #120844).
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog9
-rw-r--r--net-analyzer/nmap/files/digest-nmap-3.99993
-rw-r--r--net-analyzer/nmap/nmap-3.9999.ebuild46
3 files changed, 56 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 318a68616514..ffd99e1f7189 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.106 2005/12/10 17:47:52 spock Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.107 2006/01/29 22:49:44 spock Exp $
+
+*nmap-3.9999 (29 Jan 2006)
+
+ 29 Jan 2006; Michał Januszewski <spock@gentoo.org> +nmap-3.9999.ebuild:
+ Version bump (bug #120844).
*nmap-3.95 (10 Dec 2005)
diff --git a/net-analyzer/nmap/files/digest-nmap-3.9999 b/net-analyzer/nmap/files/digest-nmap-3.9999
new file mode 100644
index 000000000000..d3e60d53724b
--- /dev/null
+++ b/net-analyzer/nmap/files/digest-nmap-3.9999
@@ -0,0 +1,3 @@
+MD5 feba239675108be5c27c0f6fc76291f7 nmap-3.9999.tar.bz2 1894965
+RMD160 58899ff3e986fdcf6015bc6c779ee7995125c8c8 nmap-3.9999.tar.bz2 1894965
+SHA256 85d7c5dcbe92d7bb93aebb2e33110861e4f18ee91106551ec3e81be3f712d954 nmap-3.9999.tar.bz2 1894965
diff --git a/net-analyzer/nmap/nmap-3.9999.ebuild b/net-analyzer/nmap/nmap-3.9999.ebuild
new file mode 100644
index 000000000000..cd8c4bb4981b
--- /dev/null
+++ b/net-analyzer/nmap/nmap-3.9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.9999.ebuild,v 1.1 2006/01/29 22:49:44 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="gtk ssl"
+
+DEPEND="virtual/libc
+ dev-libs/libpcre
+ gtk? ( =x11-libs/gtk+-2* )
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed 's:Icon=icon-network:Icon=nmap-logo-64.png:' -i nmapfe.desktop
+ echo ";" >> nmapfe.desktop
+}
+
+src_compile() {
+ use ppc-macos && filter-flags -fstrict-aliasing -O2
+ econf \
+ $(use_with gtk nmapfe) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
+ dohtml docs/*.html
+
+ if use gtk; then
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/nmap-logo-64.png
+ fi
+}