summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-02-07 10:32:27 +0000
committerJeroen Roovers <jer@gentoo.org>2015-02-07 10:32:27 +0000
commitd939aa0e624e8673fea94b126f50e8d98d7cd721 (patch)
treeff2977366d96f736dec9f4355382f31d664ad000 /net-analyzer
parentInitial commit of cgmanager. Thanks to Fabian Henze and Yixun Lan on bug #524846 (diff)
downloadgentoo-2-d939aa0e624e8673fea94b126f50e8d98d7cd721.tar.gz
gentoo-2-d939aa0e624e8673fea94b126f50e8d98d7cd721.tar.bz2
gentoo-2-d939aa0e624e8673fea94b126f50e8d98d7cd721.zip
Add simpler patch 23 (bug #506076 by Yun Zheng Hu).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/dsniff/ChangeLog8
-rw-r--r--net-analyzer/dsniff/dsniff-2.4_beta1-r8.ebuild75
-rw-r--r--net-analyzer/dsniff/files/2.4_beta1-urlsnarf-pcap_timestamps.patch15
3 files changed, 97 insertions, 1 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index da21af510a8c..d1adf1058892 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/dsniff
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.58 2015/02/07 10:16:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.59 2015/02/07 10:32:27 jer Exp $
+
+*dsniff-2.4_beta1-r8 (07 Feb 2015)
+
+ 07 Feb 2015; Jeroen Roovers <jer@gentoo.org> +dsniff-2.4_beta1-r8.ebuild,
+ +files/2.4_beta1-urlsnarf-pcap_timestamps.patch:
+ Add simpler patch 23 (bug #506076 by Yun Zheng Hu).
*dsniff-2.4_beta1-r7 (07 Feb 2015)
diff --git a/net-analyzer/dsniff/dsniff-2.4_beta1-r8.ebuild b/net-analyzer/dsniff/dsniff-2.4_beta1-r8.ebuild
new file mode 100644
index 000000000000..df48819a5944
--- /dev/null
+++ b/net-analyzer/dsniff/dsniff-2.4_beta1-r8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.4_beta1-r8.ebuild,v 1.1 2015/02/07 10:32:27 jer Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A collection of tools for network auditing and penetration testing"
+HOMEPAGE="http://monkey.org/~dugsong/dsniff/"
+SRC_URI="
+ http://monkey.org/~dugsong/${PN}/beta/${P/_beta/b}.tar.gz
+ mirror://debian/pool/main/d/${PN}/${PN}_2.4b1+debian-22.1.debian.tar.gz
+"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.2.1-r1
+ >=net-libs/libnids-1.21
+ >=dev-libs/openssl-0.9.6e
+ >=sys-libs/db-4.2.52_p4
+ X? ( x11-libs/libXmu )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P/_beta1/}"
+
+src_prepare() {
+ # replace Debian patch 23 with a simpler one (bug #506076)
+ mv -v \
+ "${WORKDIR}"/debian/patches/23_urlsnarf_timestamp.patch{,.old} || die
+ cp -v \
+ "${FILESDIR}"/${PV}-urlsnarf-pcap_timestamps.patch \
+ "${WORKDIR}"/debian/patches/23_urlsnarf_timestamp.patch || die
+
+ # Debian patchset, needs to be applied in the exact order that "series"
+ # lists or patching will fail.
+ # Bug #479882
+ epatch $(
+ for file in $(< "${WORKDIR}"/debian/patches/series ); do
+ printf "%s/debian/patches/%s " "${WORKDIR}" "${file}"
+ done
+ )
+
+ # Bug 125084
+ epatch "${FILESDIR}"/${PV}-httppostfix.patch
+
+ # various Makefile.in patches
+ epatch "${FILESDIR}"/${PV}-make.patch
+
+ # bug #538462
+ epatch "${FILESDIR}"/${PV}-macof-size-calculation.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with X x) \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake install install_prefix="${D}"
+ dodir /etc/dsniff
+ cp "${D}"/usr/share/dsniff/{dnsspoof.hosts,dsniff.{magic,services}} \
+ "${D}"/etc/dsniff/
+ dodoc CHANGES README TODO
+}
diff --git a/net-analyzer/dsniff/files/2.4_beta1-urlsnarf-pcap_timestamps.patch b/net-analyzer/dsniff/files/2.4_beta1-urlsnarf-pcap_timestamps.patch
new file mode 100644
index 000000000000..a2a7a36966ac
--- /dev/null
+++ b/net-analyzer/dsniff/files/2.4_beta1-urlsnarf-pcap_timestamps.patch
@@ -0,0 +1,15 @@
+Author: Hilko Bengen <bengen@debian.org>
+Description: urlsnarf: use timestamps from pcap file if available. Closes: #573365
+Index: dsniff-2.4b1+debian/urlsnarf.c
+===================================================================
+--- a/urlsnarf.c
++++ b/urlsnarf.c
+@@ -57,7 +57,7 @@
+ {
+ static char tstr[32], sign;
+ struct tm *t, gmt;
+- time_t tt = time(NULL);
++ time_t tt = nids_last_pcap_header->ts.tv_sec;
+ int days, hours, tz, len;
+
+ gmt = *gmtime(&tt);