summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-25 17:08:00 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-25 17:08:00 +0000
commitde6b627b871a9737e0f73009f986079987c05115 (patch)
tree7863cd1c229d52fe0d0f0fe0187fa0ba42a9fa50 /net-analyzer
parentFix kdeenablefinal build, bug 395993 (diff)
downloadgentoo-2-de6b627b871a9737e0f73009f986079987c05115.tar.gz
gentoo-2-de6b627b871a9737e0f73009f986079987c05115.tar.bz2
gentoo-2-de6b627b871a9737e0f73009f986079987c05115.zip
Version Bump
(Portage version: 2.2.0_alpha82/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/ChangeLog7
-rw-r--r--net-analyzer/linkchecker/linkchecker-7.3.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index ca13e0c830d0..0c622d3fd615 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.61 2011/12/11 22:04:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.62 2011/12/25 17:08:00 jlec Exp $
+
+*linkchecker-7.3 (25 Dec 2011)
+
+ 25 Dec 2011; Justin Lecher <jlec@gentoo.org> +linkchecker-7.3.ebuild:
+ Version Bump
11 Dec 2011; Markus Meier <maekke@gentoo.org> linkchecker-7.1.ebuild:
x86 stable, bug #386673
diff --git a/net-analyzer/linkchecker/linkchecker-7.3.ebuild b/net-analyzer/linkchecker/linkchecker-7.3.ebuild
new file mode 100644
index 000000000000..cd07e48e5f47
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-7.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-7.3.ebuild,v 1.1 2011/12/25 17:08:00 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+PYTHON_MODNAME="linkcheck"
+
+inherit bash-completion-r1 distutils eutils
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://linkchecker.sourceforge.net/ http://pypi.python.org/pypi/linkchecker"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion bookmarks clamav doc geoip gnome login syntax-check X"
+
+RDEPEND="
+ dev-python/dnspython
+ bash-completion? ( dev-python/optcomplete )
+ bookmarks? ( dev-python/pysqlite:2 )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python )
+ gnome? ( dev-python/pygtk:2 )
+ login? ( dev-python/twill )
+ syntax-check? (
+ dev-python/cssutils
+ dev-python/utidylib
+ )
+ X? (
+ dev-python/PyQt4[X,assistant]
+ dev-python/qscintilla-python
+ )"
+DEPEND="
+ doc? ( x11-libs/qt-assistant )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/5.2-missing-files.patch \
+ "${FILESDIR}"/7.0-unbundle.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc/html || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ delete_gui() {
+ if ! use X; then
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ fi
+ }
+ python_execute_function -q delete_gui
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+ use bash-completion && dobashcompletion config/linkchecker-completion
+}