summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-05-22 15:47:28 +0000
committerJeroen Roovers <jer@gentoo.org>2010-05-22 15:47:28 +0000
commite3bf05f7982f486ab2664c96291459de74c57b74 (patch)
tree7c5642cc243bc35c7c89f8b282e5867a5935e5eb /net-analyzer
parentVarious cleanups. (diff)
downloadgentoo-2-e3bf05f7982f486ab2664c96291459de74c57b74.tar.gz
gentoo-2-e3bf05f7982f486ab2664c96291459de74c57b74.tar.bz2
gentoo-2-e3bf05f7982f486ab2664c96291459de74c57b74.zip
Old.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/mtr/files/mtr-0.73-CVE-2008-2357.patch217
-rw-r--r--net-analyzer/mtr/files/mtr-0.73-am_path_gtk.patch18
-rw-r--r--net-analyzer/mtr/files/mtr-ac-res_mkquery.patch12
-rw-r--r--net-analyzer/mtr/mtr-0.73-r2.ebuild57
-rw-r--r--net-analyzer/mtr/mtr-0.75.ebuild5
5 files changed, 3 insertions, 306 deletions
diff --git a/net-analyzer/mtr/files/mtr-0.73-CVE-2008-2357.patch b/net-analyzer/mtr/files/mtr-0.73-CVE-2008-2357.patch
deleted file mode 100644
index bd69db702e93..000000000000
--- a/net-analyzer/mtr/files/mtr-0.73-CVE-2008-2357.patch
+++ /dev/null
@@ -1,217 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=223017
-
-CVE-2008-2357:
-Stack-based buffer overflow in the split_redraw function in split.c in mtr
-before 0.73, when invoked with the -p (aka --split) option, allows remote
-attackers to execute arbitrary code via a crafted DNS PTR record. NOTE: it
-could be argued that this is a vulnerability in the ns_name_ntop function in
-resolv/ns_name.c in glibc and the proper fix should be in glibc; if so, then
-this should not be treated as a vulnerability in mtr.
-
-Index: mtr-0.73/dns.c
-===================================================================
---- mtr-0.73.orig/dns.c
-+++ mtr-0.73/dns.c
-@@ -883,7 +883,7 @@ void resendrequest(struct resolve *rp,in
- if (type == T_A) {
- dorequest(rp->hostname,type,rp->id);
- if (debug) {
-- sprintf(tempstring,"Resolver: Sent reverse authentication request for \"%s\".",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Sent reverse authentication request for \"%s\".",
- rp->hostname);
- restell(tempstring);
- }
-@@ -904,7 +904,7 @@ void resendrequest(struct resolve *rp,in
- }
- dorequest(tempstring,type,rp->id);
- if (debug) {
-- sprintf(tempstring,"Resolver: Sent domain lookup request for \"%s\".",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Sent domain lookup request for \"%s\".",
- strlongip( &(rp->ip) ));
- restell(tempstring);
- }
-@@ -940,7 +940,7 @@ void passrp(struct resolve *rp,long ttl)
- rp->expiretime = sweeptime + (double)ttl;
- untieresolve(rp);
- if (debug) {
-- sprintf(tempstring,"Resolver: Lookup successful: %s\n",rp->hostname);
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Lookup successful: %s\n",rp->hostname);
- restell(tempstring);
- }
- }
-@@ -997,7 +997,7 @@ void parserespacket(byte *s, int l)
- case NOERROR:
- if (hp->ancount) {
- if (debug) {
-- sprintf(tempstring,"Resolver: Received nameserver reply. (qd:%u an:%u ns:%u ar:%u)",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Received nameserver reply. (qd:%u an:%u ns:%u ar:%u)",
- hp->qdcount,hp->ancount,hp->nscount,hp->arcount);
- restell(tempstring);
- }
-@@ -1037,14 +1037,14 @@ void parserespacket(byte *s, int l)
- namestring[strlen(stackstring)] = '\0';
- if (strcasecmp(stackstring,namestring)) {
- if (debug) {
-- sprintf(tempstring,"Resolver: Unknown query packet dropped. (\"%s\" does not match \"%s\")",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Unknown query packet dropped. (\"%s\" does not match \"%s\")",
- stackstring,namestring);
- restell(tempstring);
- }
- return;
- }
- if (debug) {
-- sprintf(tempstring,"Resolver: Queried domain name: \"%s\"",namestring);
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Queried domain name: \"%s\"",namestring);
- restell(tempstring);
- }
- c+= r;
-@@ -1055,7 +1055,7 @@ void parserespacket(byte *s, int l)
- qdatatype = sucknetword(c);
- qclass = sucknetword(c);
- if (qclass != C_IN) {
-- sprintf(tempstring,"Resolver error: Received unsupported query class: %u (%s)",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver error: Received unsupported query class: %u (%s)",
- qclass,qclass < ClasstypeCount ? classtypes[qclass] :
- classtypes[ClasstypeCount]);
- restell(tempstring);
-@@ -1069,7 +1069,7 @@ void parserespacket(byte *s, int l)
- }
- break;
- default:
-- sprintf(tempstring,"Resolver error: Received unimplemented query type: %u (%s)",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver error: Received unimplemented query type: %u (%s)",
- qdatatype,qdatatype < ResourcetypeCount ?
- resourcetypes[qdatatype] : resourcetypes[ResourcetypeCount]);
- restell(tempstring);
-@@ -1091,7 +1091,7 @@ void parserespacket(byte *s, int l)
- else
- usefulanswer = 1;
- if (debug) {
-- sprintf(tempstring,"Resolver: answered domain query: \"%s\"",namestring);
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: answered domain query: \"%s\"",namestring);
- restell(tempstring);
- }
- c+= r;
-@@ -1104,10 +1104,10 @@ void parserespacket(byte *s, int l)
- ttl = sucknetlong(c);
- rdatalength = sucknetword(c);
- if (class != qclass) {
-- sprintf(tempstring,"query class: %u (%s)",qclass,qclass < ClasstypeCount ?
-+ snprintf(tempstring, sizeof(tempstring), "query class: %u (%s)",qclass,qclass < ClasstypeCount ?
- classtypes[qclass] : classtypes[ClasstypeCount]);
- restell(tempstring);
-- sprintf(tempstring,"rr class: %u (%s)",class,class < ClasstypeCount ?
-+ snprintf(tempstring, sizeof(tempstring), "rr class: %u (%s)",class,class < ClasstypeCount ?
- classtypes[class] : classtypes[ClasstypeCount]);
- restell(tempstring);
- restell("Resolver error: Answered class does not match queried class.");
-@@ -1123,20 +1123,20 @@ void parserespacket(byte *s, int l)
- }
- if (datatype == qdatatype || datatype == T_CNAME) {
- if (debug) {
-- sprintf(tempstring,"Resolver: TTL: %s",strtdiff(sendstring,ttl));
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: TTL: %s",strtdiff(sendstring,ttl));
- restell(tempstring);
- }
- if (usefulanswer)
- switch (datatype) {
- case T_A:
- if (rdatalength != 4) {
-- sprintf(tempstring,"Resolver error: Unsupported rdata format for \"A\" type. (%u bytes)",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver error: Unsupported rdata format for \"A\" type. (%u bytes)",
- rdatalength);
- restell(tempstring);
- return;
- }
- if ( addrcmp( (void *) &(rp->ip), (void *) c, af ) == 0 ) {
-- sprintf(tempstring,"Resolver: Reverse authentication failed: %s != ",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Reverse authentication failed: %s != ",
- strlongip( &(rp->ip) ));
- addrcpy( (void *) &alignedip, (void *) c, af );
- strcat(tempstring,strlongip( &alignedip ));
-@@ -1144,7 +1144,7 @@ void parserespacket(byte *s, int l)
- res_hostipmismatch++;
- failrp(rp);
- } else {
-- sprintf(tempstring,"Resolver: Reverse authentication complete: %s == \"%s\".",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Reverse authentication complete: %s == \"%s\".",
- strlongip( &(rp->ip) ),nonull(rp->hostname));
- restell(tempstring);
- res_reversesuccess++;
-@@ -1161,7 +1161,7 @@ void parserespacket(byte *s, int l)
- return;
- }
- if (debug) {
-- sprintf(tempstring,"Resolver: Answered domain: \"%s\"",namestring);
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Answered domain: \"%s\"",namestring);
- restell(tempstring);
- }
- if (r > HostnameLength) {
-@@ -1186,14 +1186,14 @@ void parserespacket(byte *s, int l)
- }
- break;
- default:
-- sprintf(tempstring,"Resolver error: Received unimplemented data type: %u (%s)",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver error: Received unimplemented data type: %u (%s)",
- datatype,datatype < ResourcetypeCount ?
- resourcetypes[datatype] : resourcetypes[ResourcetypeCount]);
- restell(tempstring);
- }
- } else {
- if (debug) {
-- sprintf(tempstring,"Resolver: Ignoring resource type %u. (%s)",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Ignoring resource type %u. (%s)",
- datatype,datatype < ResourcetypeCount ?
- resourcetypes[datatype] : resourcetypes[ResourcetypeCount]);
- restell(tempstring);
-@@ -1211,7 +1211,7 @@ void parserespacket(byte *s, int l)
- failrp(rp);
- break;
- default:
-- sprintf(tempstring,"Resolver: Received error response %u. (%s)",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Received error response %u. (%s)",
- getheader_rcode(hp),getheader_rcode(hp) < ResponsecodeCount ?
- responsecodes[getheader_rcode(hp)] : responsecodes[ResponsecodeCount]);
- restell(tempstring);
-@@ -1242,13 +1242,13 @@ void dns_ack(void)
- (void *) &(from4->sin_addr), AF_INET ) == 0 )
- break;
- if (i == _res.nscount) {
-- sprintf(tempstring,"Resolver error: Received reply from unknown source: %s",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver error: Received reply from unknown source: %s",
- inet_ntoa(from4->sin_addr ));
- restell(tempstring);
- } else
- parserespacket((byte *)resrecvbuf,r);
- } else {
-- sprintf(tempstring,"Resolver: Socket error: %s",strerror(errno));
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Socket error: %s",strerror(errno));
- restell(tempstring);
- }
- }
-@@ -1277,7 +1277,7 @@ void dns_events(double *sinterval)
- case STATE_FINISHED: /* TTL has expired */
- case STATE_FAILED: /* Fake TTL has expired */
- if (debug) {
-- sprintf(tempstring,"Resolver: Cache record for \"%s\" (%s) has expired. (state: %u) Marked for expire at: %g, time: %g.",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Cache record for \"%s\" (%s) has expired. (state: %u) Marked for expire at: %g, time: %g.",
- nonull(rp->hostname), strlongip( &(rp->ip) ),
- rp->state, rp->expiretime, sweeptime);
- restell(tempstring);
-@@ -1321,14 +1321,14 @@ char *dns_lookup2(ip_t * ip)
- if ((rp->state == STATE_FINISHED) || (rp->state == STATE_FAILED)) {
- if ((rp->state == STATE_FINISHED) && (rp->hostname)) {
- if (debug) {
-- sprintf(tempstring,"Resolver: Used cached record: %s == \"%s\".\n",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Used cached record: %s == \"%s\".\n",
- strlongip(ip),rp->hostname);
- restell(tempstring);
- }
- return rp->hostname;
- } else {
- if (debug) {
-- sprintf(tempstring,"Resolver: Used failed record: %s == ???\n",
-+ snprintf(tempstring, sizeof(tempstring), "Resolver: Used failed record: %s == ???\n",
- strlongip(ip));
- restell(tempstring);
- }
diff --git a/net-analyzer/mtr/files/mtr-0.73-am_path_gtk.patch b/net-analyzer/mtr/files/mtr-0.73-am_path_gtk.patch
deleted file mode 100644
index 85f983e032e0..000000000000
--- a/net-analyzer/mtr/files/mtr-0.73-am_path_gtk.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -ru mtr-0.73~/configure.in mtr-0.73/configure.in
---- mtr-0.73~/configure.in 2008-05-18 14:04:04.000000000 +0200
-+++ mtr-0.73/configure.in 2008-05-18 14:05:26.000000000 +0200
-@@ -61,11 +61,9 @@
- AC_DEFINE(NO_GTK)
- GTK_OBJ="")
- else
-- AM_PATH_GTK(1.0.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
-- LIBS="$LIBS $GTK_LIBS",
-- AC_MSG_WARN(Building without GTK+ display support)
-- AC_DEFINE(NO_GTK)
-- GTK_OBJ="")
-+ AC_MSG_WARN(Building without GTK+ display support)
-+ AC_DEFINE(NO_GTK)
-+ GTK_OBJ=""
- fi
- else
- AC_DEFINE(NO_GTK)
diff --git a/net-analyzer/mtr/files/mtr-ac-res_mkquery.patch b/net-analyzer/mtr/files/mtr-ac-res_mkquery.patch
deleted file mode 100644
index afeb12e69acc..000000000000
--- a/net-analyzer/mtr/files/mtr-ac-res_mkquery.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.in.orig 2004-08-22 01:52:55.807318544 +0300
-+++ configure.in 2004-08-22 01:55:46.415382176 +0300
-@@ -83,7 +83,8 @@
-
- AC_CHECK_FUNC(res_mkquery, ,
- AC_CHECK_LIB(bind, res_mkquery, ,
-- AC_CHECK_LIB(resolv, res_mkquery, , AC_MSG_ERROR(No resolver library found))))
-+ AC_CHECK_LIB(resolv, res_mkquery, ,
-+ AC_CHECK_LIB(resolv, __res_mkquery, , AC_MSG_ERROR(No resolver library found)))))
-
- AC_CHECK_FUNC(herror, , AC_DEFINE(NO_HERROR))
- AC_CHECK_FUNC(strerror, , AC_DEFINE(NO_STRERROR))
diff --git a/net-analyzer/mtr/mtr-0.73-r2.ebuild b/net-analyzer/mtr/mtr-0.73-r2.ebuild
deleted file mode 100644
index 6b19397fed30..000000000000
--- a/net-analyzer/mtr/mtr-0.73-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.73-r2.ebuild,v 1.8 2008/11/09 12:15:15 vapier Exp $
-
-inherit flag-o-matic autotools eutils
-
-DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
-HOMEPAGE="http://www.bitwizard.nl/mtr/"
-SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz
- mirror://gentoo/gtk-2.0-for-mtr.m4.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 s390 sh sparc x86"
-IUSE="gtk ipv6"
-
-RDEPEND="sys-libs/ncurses
- gtk? ( >=x11-libs/gtk+-2 )"
-DEPEND="${RDEPEND}
- gtk? ( dev-util/pkgconfig )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4
- epatch "${FILESDIR}"/${P}-am_path_gtk.patch
- epatch "${FILESDIR}"/${P}-CVE-2008-2357.patch
- AT_M4DIR="." eautoreconf
-}
-
-src_compile() {
- local myconf
- use gtk || myconf="${myconf} --without-gtk"
-
- [[ ${CHOST} == *-darwin* ]] && append-flags "-DBIND_8_COMPAT"
-
- econf ${myconf} \
- $(use_enable gtk gtk2) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # this binary is universal. ie: it does both console and gtk.
- emake DESTDIR="${D}" install || die "make install failed"
-
- insinto /usr/share/${PN}
- doins img/mtr_icon.xpm
-
- fowners root:0 /usr/sbin/mtr
- fperms 4710 /usr/sbin/mtr
-
- dodoc AUTHORS ChangeLog FORMATS NEWS README SECURITY TODO
-}
diff --git a/net-analyzer/mtr/mtr-0.75.ebuild b/net-analyzer/mtr/mtr-0.75.ebuild
index 00e0d20c3ca1..1980f11bfa87 100644
--- a/net-analyzer/mtr/mtr-0.75.ebuild
+++ b/net-analyzer/mtr/mtr-0.75.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.75.ebuild,v 1.9 2009/12/28 20:55:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.75.ebuild,v 1.10 2010/05/22 15:47:26 jer Exp $
EAPI="2"
+
inherit eutils autotools
DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
@@ -22,7 +23,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}/${P}--Wno-pointer-sign.patch"
- # Keep this comment and following move, even incase ebuild does not needs
+ # Keep this comment and following mv, even in case ebuild does not need
# it: kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 #222909
AT_M4DIR="." eautoreconf