summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2014-01-06 02:21:09 +0000
committerStephen Klimaszewski <steev@gentoo.org>2014-01-06 02:21:09 +0000
commitef80b1baecb12a3e405a9966a4dc1e51f1b857a0 (patch)
treee472905cd3daec498d73223dce13ba599239d821 /net-analyzer
parentAdd new snapshot. (diff)
downloadgentoo-2-ef80b1baecb12a3e405a9966a4dc1e51f1b857a0.tar.gz
gentoo-2-ef80b1baecb12a3e405a9966a4dc1e51f1b857a0.tar.bz2
gentoo-2-ef80b1baecb12a3e405a9966a4dc1e51f1b857a0.zip
Fix driftnet to build with the latest stable libpng, update EAPI
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 06F34B01)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/driftnet/ChangeLog8
-rw-r--r--net-analyzer/driftnet/driftnet-0.1.6_p20090401.ebuild10
2 files changed, 13 insertions, 5 deletions
diff --git a/net-analyzer/driftnet/ChangeLog b/net-analyzer/driftnet/ChangeLog
index 98dfcd1ff77d..273382f8504b 100644
--- a/net-analyzer/driftnet/ChangeLog
+++ b/net-analyzer/driftnet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/driftnet
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/driftnet/ChangeLog,v 1.42 2012/05/04 06:08:09 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/driftnet/ChangeLog,v 1.43 2014/01/06 02:21:09 steev Exp $
+
+ 06 Jan 2014; Steev Klimaszewski <steev@gentoo.org>
+ driftnet-0.1.6_p20090401.ebuild:
+ Fix driftnet to build with the latest stable libpng, update eapi
04 May 2012; Jeff Horelick <jdhore@gentoo.org> driftnet-0.1.6-r4.ebuild,
driftnet-0.1.6_p20090401.ebuild:
diff --git a/net-analyzer/driftnet/driftnet-0.1.6_p20090401.ebuild b/net-analyzer/driftnet/driftnet-0.1.6_p20090401.ebuild
index 01557a03153e..9fd5daddea2e 100644
--- a/net-analyzer/driftnet/driftnet-0.1.6_p20090401.ebuild
+++ b/net-analyzer/driftnet/driftnet-0.1.6_p20090401.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/driftnet/driftnet-0.1.6_p20090401.ebuild,v 1.8 2012/05/04 06:08:09 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/driftnet/driftnet-0.1.6_p20090401.ebuild,v 1.9 2014/01/06 02:21:09 steev Exp $
-EAPI=2
+EAPI=5
inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="A program which listens to network traffic and picks out images from TCP streams it observes"
@@ -29,6 +29,10 @@ src_prepare() {
sed -i \
-e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:' \
png.c || die
+ # With newer libpng, --cflags causes build failures.
+ sed -i \
+ -e 's:pkg-config --cflags libpng:pkg-config --libs libpng:' \
+ Makefile || die
}
src_compile() {