summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-10-04 19:41:23 +0000
committerAlin Năstac <mrness@gentoo.org>2005-10-04 19:41:23 +0000
commit2126f2e2568c8613e9fe39ab5b93023ac46765cb (patch)
treeeb7215eacdd1fe3e86c45e41efd79c6cee72e9bd /net-dialup/pptpclient/pptpclient-1.7.0.ebuild
parentAdded libglade to DEPEND. This close bug #108113 (diff)
downloadgentoo-2-2126f2e2568c8613e9fe39ab5b93023ac46765cb.tar.gz
gentoo-2-2126f2e2568c8613e9fe39ab5b93023ac46765cb.tar.bz2
gentoo-2-2126f2e2568c8613e9fe39ab5b93023ac46765cb.zip
Remove obsolete version. Mark stable on x86. Version bump. Remove INSTALL from docs
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-dialup/pptpclient/pptpclient-1.7.0.ebuild')
-rw-r--r--net-dialup/pptpclient/pptpclient-1.7.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dialup/pptpclient/pptpclient-1.7.0.ebuild b/net-dialup/pptpclient/pptpclient-1.7.0.ebuild
new file mode 100644
index 000000000000..e0962587cb43
--- /dev/null
+++ b/net-dialup/pptpclient/pptpclient-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.7.0.ebuild,v 1.1 2005/10/04 19:41:23 mrness Exp $
+
+MY_P=${P/client}
+MY_CMD=pptp-command-20050401
+
+DESCRIPTION="Linux client for PPTP"
+HOMEPAGE="http://pptpclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pptpclient/${MY_P}.tar.gz
+ mirror://gentoo/${MY_CMD}.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="tcltk"
+
+DEPEND=">=net-dialup/ppp-2.4.2
+ dev-lang/perl
+ tcltk? ( dev-perl/perl-tk )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake OPTIMISE= DEBUG= CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dosbin pptp
+ dodoc AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING
+ dodoc Documentation/*
+ dodoc Reference/*
+ dodir /etc/pptp.d
+
+ # The current version of pptp-linux doesn't include the
+ # RH-specific portions, so include them ourselves.
+ cd ${FILESDIR}
+ insinto /etc/ppp
+ doins new-mppe/options.pptp
+ newsbin ${WORKDIR}/${MY_CMD} pptp-command
+ dosbin pptp_fe.pl
+ use tcltk && dosbin xpptp_fe.pl
+}