summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-07-16 06:19:20 +0000
committerAlin Năstac <mrness@gentoo.org>2009-07-16 06:19:20 +0000
commitce5833285f32519d505fd4b4235b90f313a7a9e9 (patch)
tree5d1eda9bfa794a2f0b85133e638b8623369bde28 /net-dialup/xl2tpd/xl2tpd-1.2.4.ebuild
parentversion bump (diff)
downloadgentoo-2-ce5833285f32519d505fd4b4235b90f313a7a9e9.tar.gz
gentoo-2-ce5833285f32519d505fd4b4235b90f313a7a9e9.tar.bz2
gentoo-2-ce5833285f32519d505fd4b4235b90f313a7a9e9.zip
Stable on amd64 and x86. Migrate to EAPI 2. Version bump (#277951).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/xl2tpd/xl2tpd-1.2.4.ebuild')
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.2.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/xl2tpd-1.2.4.ebuild b/net-dialup/xl2tpd/xl2tpd-1.2.4.ebuild
new file mode 100644
index 000000000000..26aa6ff80c9d
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.2.4.ebuild,v 1.1 2009/07/16 06:19:19 mrness Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/software/xl2tpd/"
+SRC_URI="ftp://ftp.xelerance.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ append-flags -DTRUST_PPPD_TO_DIE
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc CREDITS README.xl2tpd \
+ doc/README.patents doc/rfc2661.txt doc/*.sample
+
+ dodir /etc/xl2tpd
+ head -n 2 doc/l2tp-secrets.sample > "${D}/etc/xl2tpd/l2tp-secrets"
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+ newinitd "${FILESDIR}"/xl2tpd-init xl2tpd
+
+ keepdir /var/run/xl2tpd
+}