summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2010-11-27 11:01:36 +0000
committerAlin Năstac <mrness@gentoo.org>2010-11-27 11:01:36 +0000
commit62336a61ee823bb3d900e2663a3762415c0dba2f (patch)
tree1423ab346c8c7d09a7b78938972ed3e607215ea2 /net-dialup/xl2tpd
parentarm/sparc stable (bug 346395) (diff)
downloadgentoo-2-62336a61ee823bb3d900e2663a3762415c0dba2f.tar.gz
gentoo-2-62336a61ee823bb3d900e2663a3762415c0dba2f.tar.bz2
gentoo-2-62336a61ee823bb3d900e2663a3762415c0dba2f.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/xl2tpd')
-rw-r--r--net-dialup/xl2tpd/ChangeLog8
-rw-r--r--net-dialup/xl2tpd/files/xl2tpd-1.2.7-as-needed.patch12
-rw-r--r--net-dialup/xl2tpd/files/xl2tpd-1.2.7-qa-fixes.patch25
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.2.7.ebuild40
4 files changed, 84 insertions, 1 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
index 1e9d6976ea86..d697289850dd 100644
--- a/net-dialup/xl2tpd/ChangeLog
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/xl2tpd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.21 2010/09/19 11:31:22 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.22 2010/11/27 11:01:36 mrness Exp $
+
+*xl2tpd-1.2.7 (27 Nov 2010)
+
+ 27 Nov 2010; Alin Năstac <mrness@gentoo.org> +xl2tpd-1.2.7.ebuild,
+ +files/xl2tpd-1.2.7-as-needed.patch, +files/xl2tpd-1.2.7-qa-fixes.patch:
+ Version bump.
*xl2tpd-1.2.6-r1 (19 Sep 2010)
diff --git a/net-dialup/xl2tpd/files/xl2tpd-1.2.7-as-needed.patch b/net-dialup/xl2tpd/files/xl2tpd-1.2.7-as-needed.patch
new file mode 100644
index 000000000000..d92c7e653f11
--- /dev/null
+++ b/net-dialup/xl2tpd/files/xl2tpd-1.2.7-as-needed.patch
@@ -0,0 +1,12 @@
+diff -Nru xl2tpd-1.2.7.orig/Makefile xl2tpd-1.2.7/Makefile
+--- xl2tpd-1.2.7.orig/Makefile 2010-08-06 00:33:46.000000000 +0200
++++ xl2tpd-1.2.7/Makefile 2010-11-27 11:57:10.000000000 +0100
+@@ -113,7 +113,7 @@
+
+ pfc:
+ $(CC) $(CFLAGS) -c contrib/pfc.c
+- $(CC) $(LDFLAGS) -lpcap $(LDLIBS) -o pfc pfc.o
++ $(CC) $(LDFLAGS) -o pfc pfc.o -lpcap $(LDLIBS)
+
+ romfs:
+ $(ROMFSINST) /bin/$(EXEC)
diff --git a/net-dialup/xl2tpd/files/xl2tpd-1.2.7-qa-fixes.patch b/net-dialup/xl2tpd/files/xl2tpd-1.2.7-qa-fixes.patch
new file mode 100644
index 000000000000..10c5e6dde53d
--- /dev/null
+++ b/net-dialup/xl2tpd/files/xl2tpd-1.2.7-qa-fixes.patch
@@ -0,0 +1,25 @@
+diff -Nru xl2tpd-1.2.7.orig/call.c xl2tpd-1.2.7/call.c
+--- xl2tpd-1.2.7.orig/call.c 2010-08-06 00:33:46.000000000 +0200
++++ xl2tpd-1.2.7/call.c 2010-11-27 11:58:13.000000000 +0100
+@@ -665,15 +665,19 @@
+ */
+ if (gconfig.debug_tunnel)
+ {
++ struct in_addr inaddr;
++ inaddr.s_addr = addr;
+ l2tp_log (LOG_DEBUG,
+ "%s: allocating new tunnel for host %s, port %d.\n",
+- __FUNCTION__, IPADDY (addr), ntohs (port));
++ __FUNCTION__, IPADDY (inaddr), ntohs (port));
+ }
+ if (!(st = new_tunnel ()))
+ {
++ struct in_addr inaddr;
++ inaddr.s_addr = addr;
+ l2tp_log (LOG_WARNING,
+ "%s: unable to allocate new tunnel for host %s, port %d.\n",
+- __FUNCTION__, IPADDY (addr), ntohs (port));
++ __FUNCTION__, IPADDY (inaddr), ntohs (port));
+ return NULL;
+ };
+ st->peer.sin_family = AF_INET;
diff --git a/net-dialup/xl2tpd/xl2tpd-1.2.7.ebuild b/net-dialup/xl2tpd/xl2tpd-1.2.7.ebuild
new file mode 100644
index 000000000000..ecd45ab30466
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.2.7.ebuild,v 1.1 2010/11/27 11:01:36 mrness Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/software/"
+SRC_URI="ftp://ftp.xelerance.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dnsretry"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-qa-fixes.patch
+ use dnsretry && epatch "${FILESDIR}"/${PN}-dnsretry.patch
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc CREDITS README.xl2tpd \
+ doc/README.patents doc/rfc2661.txt doc/*.sample
+
+ dodir /etc/xl2tpd
+ head -n 2 doc/l2tp-secrets.sample > "${D}/etc/xl2tpd/l2tp-secrets"
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+ newinitd "${FILESDIR}"/xl2tpd-init xl2tpd
+
+ keepdir /var/run/xl2tpd
+}