summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-11-06 18:26:57 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-11-06 18:26:57 +0000
commit6b1d793a7add1c4a41bbdccc46ee056d8a8ddb2c (patch)
tree76fb5ab284e049a9dd8266501cbd2e34630663a0 /net-dialup
parentFixed with newer gcc (bug #454072), build in source fixing bug #488450, switc... (diff)
downloadgentoo-2-6b1d793a7add1c4a41bbdccc46ee056d8a8ddb2c.tar.gz
gentoo-2-6b1d793a7add1c4a41bbdccc46ee056d8a8ddb2c.tar.bz2
gentoo-2-6b1d793a7add1c4a41bbdccc46ee056d8a8ddb2c.zip
Version bump, drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/pptpd/ChangeLog9
-rw-r--r--net-dialup/pptpd/files/pptpd-1.4.0-gentoo.patch59
-rw-r--r--net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch21
-rw-r--r--net-dialup/pptpd/pptpd-1.4.0.ebuild (renamed from net-dialup/pptpd/pptpd-1.3.4-r3.ebuild)11
4 files changed, 91 insertions, 9 deletions
diff --git a/net-dialup/pptpd/ChangeLog b/net-dialup/pptpd/ChangeLog
index a933f21b9247..4c017ede557e 100644
--- a/net-dialup/pptpd/ChangeLog
+++ b/net-dialup/pptpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/pptpd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/ChangeLog,v 1.54 2013/11/04 12:14:10 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/ChangeLog,v 1.55 2013/11/06 18:26:56 pinkbyte Exp $
+
+*pptpd-1.4.0 (06 Nov 2013)
+
+ 06 Nov 2013; Sergey Popov <pinkbyte@gentoo.org> -pptpd-1.3.4-r3.ebuild,
+ +pptpd-1.4.0.ebuild, +files/pptpd-1.4.0-gentoo.patch,
+ +files/pptpd-1.4.0-sandbox-fix.patch:
+ Version bump, drop old
04 Nov 2013; Sergey Popov <pinkbyte@gentoo.org> pptpd-1.3.4-r4.ebuild:
Stable on amd64 and x86, bug #489772
diff --git a/net-dialup/pptpd/files/pptpd-1.4.0-gentoo.patch b/net-dialup/pptpd/files/pptpd-1.4.0-gentoo.patch
new file mode 100644
index 000000000000..9e7db7ea3454
--- /dev/null
+++ b/net-dialup/pptpd/files/pptpd-1.4.0-gentoo.patch
@@ -0,0 +1,59 @@
+diff -Naur pptpd-1.3.4.orig/Makefile.am pptpd-1.3.4/Makefile.am
+--- pptpd-1.3.4.orig/Makefile.am 2007-04-16 04:53:53.000000000 +0400
++++ pptpd-1.3.4/Makefile.am 2007-05-01 21:29:15.000000000 +0400
+@@ -11,7 +11,7 @@
+ ## warning with -Wmissing-prototypes).
+ ## -Wmissing-prototypes removed (eg, Linux 2.2.6 headers
+ ## aren't up to it).
+-CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
++CFLAGS += -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
+ #CFLAGS = -O2 -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"'
+ #CFLAGS = -O2 -fno-builtin -Wall -ansi -pedantic -Wmissing-prototypes -Werror -DSBINDIR='"$(sbindir)"'
+
+diff -Naur pptpd-1.3.4.orig/plugins/Makefile pptpd-1.3.4/plugins/Makefile
+--- pptpd-1.3.4.orig/plugins/Makefile 2006-08-03 06:02:01.000000000 +0400
++++ pptpd-1.3.4/plugins/Makefile 2007-05-01 21:29:15.000000000 +0400
+@@ -1,6 +1,5 @@
+-CC = gcc
++CC ?= gcc
+-COPTS = -O2 -g
+-CFLAGS = $(COPTS) -I.. -I../../include -fPIC
++CFLAGS += -I.. -I../../include -fPIC
+-LDFLAGS = -shared
++LDFLAGS += -shared
+ LDADD = -lutil
+ INSTALL = install -o root
+diff -Naur pptpd-1.3.4.orig/pptpgre.c pptpd-1.3.4/pptpgre.c
+--- pptpd-1.3.4.orig/pptpgre.c 2007-04-16 04:21:02.000000000 +0400
++++ pptpd-1.3.4/pptpgre.c 2007-05-01 21:29:50.000000000 +0400
+@@ -326,9 +326,11 @@
+ "GRE: timeout waiting for %d packets",
+ head->seq - gre.seq_recv - 1);
+ }
++#ifdef LOG_DEBUG_GRE_ACCEPTING_PACKET
+ if (pptpctrl_debug)
+ syslog(LOG_DEBUG, "GRE: accepting #%d from queue",
+ head->seq);
++#endif
+ gre.seq_recv = head->seq;
+ status = callback(cl, head->packet, head->packlen);
+ pqueue_del(head);
+diff -Naur pptpd-1.3.4.orig/pqueue.c pptpd-1.3.4/pqueue.c
+--- pptpd-1.3.4.orig/pqueue.c 2005-08-03 12:53:22.000000000 +0400
++++ pptpd-1.3.4/pqueue.c 2007-05-01 21:29:15.000000000 +0400
+@@ -7,13 +7,11 @@
+ #include "pqueue.h"
+
+ #ifdef DEBUG_PQUEUE
+-#define DEBUG_ON 1
++# define DEBUG_CMD(_a) { _a }
+ #else
+-#define DEBUG_ON 0
++# define DEBUG_CMD(_a)
+ #endif
+
+-#define DEBUG_CMD(_a) if (DEBUG_ON) { _a }
+-
+ #define MIN_CAPACITY 128 /* min allocated buffer for a packet */
+
+ static int pqueue_alloc (int seq, unsigned char *packet, int packlen, pqueue_t **new);
diff --git a/net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch b/net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch
new file mode 100644
index 000000000000..de91753f33f5
--- /dev/null
+++ b/net-dialup/pptpd/files/pptpd-1.4.0-sandbox-fix.patch
@@ -0,0 +1,21 @@
+--- plugins/Makefile.orig 2013-05-15 14:36:33.994231829 +0400
++++ plugins/Makefile 2013-05-15 14:37:06.686234429 +0400
+@@ -17,14 +17,14 @@
+ %.so: %.c
+ $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
+
+-LIBDIR ?= $(DESTDIR)$(prefix)/lib/pptpd
++LIBDIR ?= $(prefix)/lib/pptpd
+
+ install: $(PLUGINS)
+- $(INSTALL) -d $(LIBDIR)
+- $(INSTALL) $? $(LIBDIR)
++ $(INSTALL) -d $(DESTDIR)$(LIBDIR)
++ $(INSTALL) $? $(DESTDIR)$(LIBDIR)
+
+ uninstall:
+- rm -f $(LIBDIR)$(PLUGINS)
++ rm -f $(DESTDIR)$(LIBDIR)$(PLUGINS)
+
+ clean:
+ rm -f *.o *.so *.a
diff --git a/net-dialup/pptpd/pptpd-1.3.4-r3.ebuild b/net-dialup/pptpd/pptpd-1.4.0.ebuild
index 03efc04c0022..59dee417b753 100644
--- a/net-dialup/pptpd/pptpd-1.3.4-r3.ebuild
+++ b/net-dialup/pptpd/pptpd-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/pptpd-1.3.4-r3.ebuild,v 1.4 2013/10/25 09:24:36 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/pptpd-1.4.0.ebuild,v 1.1 2013/11/06 18:26:56 pinkbyte Exp $
EAPI="5"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/poptop/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="gre-extreme-debug tcpd"
DEPEND="net-dialup/ppp:=
@@ -23,7 +23,6 @@ DOCS=( AUTHORS ChangeLog NEWS README TODO )
src_prepare() {
epatch "${FILESDIR}/${P}-gentoo.patch"
- epatch "${FILESDIR}/${P}-more-reodering-fixes.patch"
epatch "${FILESDIR}/${P}-sandbox-fix.patch"
# Match pptpd-logwtmp.so's version with pppd's version (#89895)
@@ -32,9 +31,6 @@ src_prepare() {
PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
sed -i -e "s:\\(#define[ \\t]*VERSION[ \\t]*\\)\".*\":\\1\"${PPPD_VER}\":" plugins/patchlevel.h || die
- # respect LDFLAGS
- sed -i -e "/^LDFLAGS/{s:=:+=:}" plugins/Makefile || die
-
# Automake 1.13, compatibility, bug #469476
sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADER/' configure.in || die 'sed on configure.ac failed'
@@ -74,6 +70,5 @@ src_install () {
newconfd "${FILESDIR}/pptpd-confd" pptpd
dodoc README.*
- docinto samples
- dodoc samples/*
+ dodoc -r samples
}