summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-14 23:18:19 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-14 23:18:19 +0000
commit725e9ddf45283a5fdb5c39b93ef655df75a26699 (patch)
tree1a2102d68e037745af3d604c4dfc00ab2a80ef99 /net-dns/bind
parentGentoo Technologies -> Gentoo Foundation (diff)
downloadgentoo-2-725e9ddf45283a5fdb5c39b93ef655df75a26699.tar.gz
gentoo-2-725e9ddf45283a5fdb5c39b93ef655df75a26699.tar.bz2
gentoo-2-725e9ddf45283a5fdb5c39b93ef655df75a26699.zip
fix ebuild error: you can't negate use with use -flag, you have to do either use !flag or negate the conditional in bash. otherwise, add selinux to IUSE and remove mysql
Diffstat (limited to 'net-dns/bind')
-rw-r--r--net-dns/bind/bind-9.2.2-r1.ebuild4
-rw-r--r--net-dns/bind/bind-9.2.2-r2.ebuild4
-rw-r--r--net-dns/bind/bind-9.2.2-r3.ebuild5
-rw-r--r--net-dns/bind/bind-9.2.2-r4.ebuild5
-rw-r--r--net-dns/bind/bind-9.2.2.ebuild4
-rw-r--r--net-dns/bind/bind-9.2.3.ebuild6
-rw-r--r--net-dns/bind/bind-9.3.0_rc2.ebuild4
-rw-r--r--net-dns/bind/files/named.rc64
8 files changed, 17 insertions, 19 deletions
diff --git a/net-dns/bind/bind-9.2.2-r1.ebuild b/net-dns/bind/bind-9.2.2-r1.ebuild
index b82ba7e00614..6439bbcc57a1 100644
--- a/net-dns/bind/bind-9.2.2-r1.ebuild
+++ b/net-dns/bind/bind-9.2.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r1.ebuild,v 1.8 2004/06/24 22:33:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r1.ebuild,v 1.9 2004/07/14 23:18:19 agriffis Exp $
-IUSE="ssl ipv6 doc"
+IUSE="doc ipv6 selinux ssl"
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz"
diff --git a/net-dns/bind/bind-9.2.2-r2.ebuild b/net-dns/bind/bind-9.2.2-r2.ebuild
index b49723692b64..8fb24ce8b0c7 100644
--- a/net-dns/bind/bind-9.2.2-r2.ebuild
+++ b/net-dns/bind/bind-9.2.2-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r2.ebuild,v 1.11 2004/06/24 22:33:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r2.ebuild,v 1.12 2004/07/14 23:18:19 agriffis Exp $
-IUSE="ssl ipv6 doc"
+IUSE="doc ipv6 selinux ssl"
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz"
diff --git a/net-dns/bind/bind-9.2.2-r3.ebuild b/net-dns/bind/bind-9.2.2-r3.ebuild
index 8d17bc4bf01e..f805bb40074f 100644
--- a/net-dns/bind/bind-9.2.2-r3.ebuild
+++ b/net-dns/bind/bind-9.2.2-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r3.ebuild,v 1.9 2004/07/11 14:26:28 jforman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r3.ebuild,v 1.10 2004/07/14 23:18:19 agriffis Exp $
inherit eutils
-IUSE="ssl ipv6 doc"
+IUSE="doc ipv6 selinux ssl"
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz ftp://ftp.isc.org/isc/bind9/${PV}/patch.${PV}-P1"
@@ -170,4 +170,3 @@ pkg_config() {
einfo
fi
}
-
diff --git a/net-dns/bind/bind-9.2.2-r4.ebuild b/net-dns/bind/bind-9.2.2-r4.ebuild
index e2f0a229904a..5a3c110bd7cd 100644
--- a/net-dns/bind/bind-9.2.2-r4.ebuild
+++ b/net-dns/bind/bind-9.2.2-r4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r4.ebuild,v 1.2 2004/06/24 22:33:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r4.ebuild,v 1.3 2004/07/14 23:18:19 agriffis Exp $
inherit eutils
-IUSE="ssl ipv6 doc mysql"
+IUSE="doc ipv6 mysql selinux ssl"
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz ftp://ftp.isc.org/isc/bind9/${PV}/patch.${PV}-P1"
@@ -175,4 +175,3 @@ pkg_config() {
einfo
fi
}
-
diff --git a/net-dns/bind/bind-9.2.2.ebuild b/net-dns/bind/bind-9.2.2.ebuild
index 5474c74d5df2..d6398c5286bb 100644
--- a/net-dns/bind/bind-9.2.2.ebuild
+++ b/net-dns/bind/bind-9.2.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2.ebuild,v 1.13 2004/06/24 22:33:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2.ebuild,v 1.14 2004/07/14 23:18:19 agriffis Exp $
-IUSE="ssl ipv6 doc"
+IUSE="doc ipv6 selinux ssl"
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz"
diff --git a/net-dns/bind/bind-9.2.3.ebuild b/net-dns/bind/bind-9.2.3.ebuild
index 88914d1e6463..d608513116c4 100644
--- a/net-dns/bind/bind-9.2.3.ebuild
+++ b/net-dns/bind/bind-9.2.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.3.ebuild,v 1.13 2004/07/06 14:15:39 jforman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.3.ebuild,v 1.14 2004/07/14 23:18:19 agriffis Exp $
-IUSE="ssl ipv6 doc caps"
+IUSE="caps doc ipv6 selinux ssl"
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz"
@@ -36,7 +36,7 @@ src_compile() {
use ssl && myconf="${myconf} --with-openssl"
use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
- use -caps && myconf="${myconf} --disable-linux-caps"
+ use caps || myconf="${myconf} --disable-linux-caps"
econf --sysconfdir=/etc/bind \
--localstatedir=/var \
diff --git a/net-dns/bind/bind-9.3.0_rc2.ebuild b/net-dns/bind/bind-9.3.0_rc2.ebuild
index 44d1f1c19bc5..b7f2cef68b36 100644
--- a/net-dns/bind/bind-9.3.0_rc2.ebuild
+++ b/net-dns/bind/bind-9.3.0_rc2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.0_rc2.ebuild,v 1.1 2004/07/11 13:35:37 jforman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.0_rc2.ebuild,v 1.2 2004/07/14 23:18:19 agriffis Exp $
-IUSE="ssl ipv6 doc caps"
+IUSE="caps doc ipv6 selinux ssl"
DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
MY_P="${P/_/}"
diff --git a/net-dns/bind/files/named.rc6 b/net-dns/bind/files/named.rc6
index 44c912e65cd1..7c3f4dfabbf2 100644
--- a/net-dns/bind/files/named.rc6
+++ b/net-dns/bind/files/named.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/files/named.rc6,v 1.14 2004/03/04 19:17:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/files/named.rc6,v 1.15 2004/07/14 23:18:19 agriffis Exp $
opts="start stop reload restart"