summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-10-30 15:20:10 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-10-30 15:20:10 +0000
commit6c21d27803096d909bc5e22ffddfd6f7e8aeeafa (patch)
treee4e3540b321cffbaea700fb50bb7e8519061e98a /net-dns/pdns/pdns-2.9.12.ebuild
parentversion bump. (diff)
downloadgentoo-2-6c21d27803096d909bc5e22ffddfd6f7e8aeeafa.tar.gz
gentoo-2-6c21d27803096d909bc5e22ffddfd6f7e8aeeafa.tar.bz2
gentoo-2-6c21d27803096d909bc5e22ffddfd6f7e8aeeafa.zip
version bump.
Diffstat (limited to 'net-dns/pdns/pdns-2.9.12.ebuild')
-rw-r--r--net-dns/pdns/pdns-2.9.12.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-dns/pdns/pdns-2.9.12.ebuild b/net-dns/pdns/pdns-2.9.12.ebuild
new file mode 100644
index 000000000000..f6e5a89d31f5
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12.ebuild,v 1.1 2003/10/30 15:20:07 jhhudso Exp $
+
+DESCRIPTION="The PowerDNS Daemon."
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="mysql static"
+
+DEPEND="virtual/glibc
+ mysql? ( >=dev-db/mysql-3.23.54a )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf=""
+ local modules=""
+
+ use static && myconf="$myconf --enable-static-binaries"
+ use mysql && modules="gmysql $modules"
+ myconf="$myconf --with-modules=$modules"
+
+ econf $myconf
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog HACKING INSTALL README TODO WARNING pdns/COPYING
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/pdns
+
+ mv ${D}/etc/pdns.conf-dist ${D}/etc/pdns.conf
+}