summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-02-23 00:01:31 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-02-23 00:01:31 +0000
commit8d9b2da066ee4f8d58a7a443664148c14f8054d9 (patch)
tree90518a7ef57a1b419ed59ccd8c2c86714b6882e5 /net-dns/pdnsd/pdnsd-1.1.10.ebuild
parenthppa repoman (diff)
downloadgentoo-2-8d9b2da066ee4f8d58a7a443664148c14f8054d9.tar.gz
gentoo-2-8d9b2da066ee4f8d58a7a443664148c14f8054d9.tar.bz2
gentoo-2-8d9b2da066ee4f8d58a7a443664148c14f8054d9.zip
ebuild cleanup and initscript cleanup
Diffstat (limited to 'net-dns/pdnsd/pdnsd-1.1.10.ebuild')
-rw-r--r--net-dns/pdnsd/pdnsd-1.1.10.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/net-dns/pdnsd/pdnsd-1.1.10.ebuild b/net-dns/pdnsd/pdnsd-1.1.10.ebuild
index 6b2e31e973b4..0608f1626807 100644
--- a/net-dns/pdnsd/pdnsd-1.1.10.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.1.10.ebuild,v 1.1 2004/02/22 08:20:03 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.1.10.ebuild,v 1.2 2004/02/23 00:01:31 dragonheart Exp $
DESCRIPTION="Proxy DNS server with permanent caching"
@@ -13,7 +13,8 @@ HOMEPAGE="http://www.phys.uu.nl/%7Erombouts/pdnsd.html http://home.t-online.de/h
IUSE="ipv6 debug isdn"
DEPEND="virtual/glibc
- >=sys-apps/sed-4"
+ sys-apps/sed
+ sys-apps/gawk"
RDEPEND="virtual/glibc"
@@ -35,7 +36,7 @@ src_compile() {
cd ${S} || die
local myconf
- if [ `use debug` ]; then
+ if use debug; then
myconf="${myconf} --with-debug=3"
CFLAGS="${CFLAGS} -g"
fi
@@ -45,6 +46,7 @@ src_compile() {
--sysconfdir=/etc/pdnsd \
--with-cachedir=/var/cache/pdnsd \
--infodir=/usr/share/info --mandir=/usr/share/man \
+ --with-default-id=pdnsd \
`use_enable ipv6` `use_enable isdn` \
${myconf} \
|| die "bad configure"
@@ -64,12 +66,6 @@ src_install() {
# Don't clobber existing cache
[ -f /var/cache/pdnsd/pdnsd.cache ] && rm ${D}/var/cache/pdnsd/pdnsd.cache
- fowners pdnsd:pdnsd /var/cache/pdnsd
-
- [ -f ${D}/var/cache/pdnsd/pdnsd.cache ] fowners pdnsd:pdnsd /var/cache/pdnsd/pdnsd.cache
-
- sed -i 's/run_as=.*/run_as="pdnsd";/' ${D}/etc/pdnsd/pdnsd.conf.sample
-
dodoc AUTHORS COPYING* ChangeLog* NEWS README THANKS TODO README.par
docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
docinto html ; dohtml doc/html/*
@@ -85,16 +81,20 @@ src_install() {
keepdir /etc/conf.d
local config=${D}/etc/conf.d/pdnsd-online
- echo "# Enter the interface that connects you to the dns servers" > ${config}
+
+ ${D}/usr/sbin/pdnsd --help | sed "s/^/# /g" > ${config}
+ echo "# Enter the interface that connects you to the dns servers" >> ${config}
echo "# This will correspond to /etc/init.d/net.${IFACE}" >> ${config}
echo "IFACE=ppp0" >> ${config}
use ipv6 && echo PDNSDCONFIG="-6" >> ${config} \
|| echo PDNSDCONFIG="" >> ${config}
- ${D}/usr/sbin/pdnsd --help | sed "s/^/# /g" >> ${config}
einfo "Add pdnsd to your default runlevel."
einfo ""
einfo "Add pdnsd-online to your online runlevel."
einfo "The online interface will be listed in /etc/conf.d/pdnsd-online"
+ einfo ""
+ einfo "Sample config file in /etc/pdnsd/pdnsd.conf.sample"
+
}