summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-10-08 06:06:58 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-10-08 06:06:58 +0000
commit0579690fc2d641abea20efeebbc4a3814dd06b53 (patch)
tree62f338f52592f17e2535361ba769844d31e09745 /net-dns/pdnsd
parentBump (diff)
downloadgentoo-2-0579690fc2d641abea20efeebbc4a3814dd06b53.tar.gz
gentoo-2-0579690fc2d641abea20efeebbc4a3814dd06b53.tar.bz2
gentoo-2-0579690fc2d641abea20efeebbc4a3814dd06b53.zip
Changed "need net" to "use net" in init script (bug #484658). Converted ebuild to EAPI-5. Took over maintenance
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-dns/pdnsd')
-rw-r--r--net-dns/pdnsd/ChangeLog9
-rw-r--r--net-dns/pdnsd/files/pdnsd.rc76
-rw-r--r--net-dns/pdnsd/metadata.xml4
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.9a.ebuild31
4 files changed, 29 insertions, 21 deletions
diff --git a/net-dns/pdnsd/ChangeLog b/net-dns/pdnsd/ChangeLog
index d0a352a24261..69235d29821e 100644
--- a/net-dns/pdnsd/ChangeLog
+++ b/net-dns/pdnsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/pdnsd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.111 2012/12/19 01:18:33 polynomial-c Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.112 2013/10/08 06:06:58 polynomial-c Exp $
+
+ 08 Oct 2013; Lars Wendler <polynomial-c@gentoo.org> pdnsd-1.2.9a.ebuild,
+ files/pdnsd.rc7, metadata.xml:
+ Changed "need net" to "use net" in init script (bug #484658). Converted
+ ebuild to EAPI-5. Took over maintenance.
19 Dec 2012; Lars Wendler <polynomial-c@gentoo.org> files/pdnsd.rc7:
Small fix in the new init.d file.
diff --git a/net-dns/pdnsd/files/pdnsd.rc7 b/net-dns/pdnsd/files/pdnsd.rc7
index 92122b1217f0..f6c91add617c 100644
--- a/net-dns/pdnsd/files/pdnsd.rc7
+++ b/net-dns/pdnsd/files/pdnsd.rc7
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/files/pdnsd.rc7,v 1.2 2012/12/19 01:18:33 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/files/pdnsd.rc7,v 1.3 2013/10/08 06:06:58 polynomial-c Exp $
pidfile="/var/run/pdnsd.pid"
command="/usr/sbin/pdnsd"
@@ -9,7 +9,7 @@ command_args="-s -t -d -p ${pidfile} ${PDNSDCONFIG}"
extra_started_commands="reload"
depend() {
- need net
+ use net
provide dns
}
diff --git a/net-dns/pdnsd/metadata.xml b/net-dns/pdnsd/metadata.xml
index d440a20e725a..796f42735df4 100644
--- a/net-dns/pdnsd/metadata.xml
+++ b/net-dns/pdnsd/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-dialup</herd>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
<longdescription>
A proxy DNS server with permanent caching (the cache contents are
written to hard disk on exit) that is designed to cope with
diff --git a/net-dns/pdnsd/pdnsd-1.2.9a.ebuild b/net-dns/pdnsd/pdnsd-1.2.9a.ebuild
index 0b913e0ceb62..a6acc3a1eb83 100644
--- a/net-dns/pdnsd/pdnsd-1.2.9a.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.9a.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.9a.ebuild,v 1.1 2012/12/19 01:14:36 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.9a.ebuild,v 1.2 2013/10/08 06:06:58 polynomial-c Exp $
-EAPI="2"
+EAPI=5
inherit user
@@ -35,23 +35,22 @@ src_configure() {
--with-default-id=pdnsd \
$(use_enable ipv6) $(use_enable ipv6 ipv6-startup) \
$(use_enable isdn) \
- ${myconf} \
- || die "bad configure"
+ ${myconf}
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO README.par || die
- docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl} || die
- docinto html ; dohtml doc/html/* || die
- docinto txt ; dodoc doc/txt/* || die
- newdoc doc/pdnsd.conf pdnsd.conf.sample || die
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO README.par
+ docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
+ docinto html ; dohtml doc/html/*
+ docinto txt ; dodoc doc/txt/*
+ newdoc doc/pdnsd.conf pdnsd.conf.sample
- newinitd "${FILESDIR}/pdnsd.rc7" pdnsd || die
- newinitd "${FILESDIR}/pdnsd.online.2" pdnsd-online || die
+ newinitd "${FILESDIR}/pdnsd.rc7" pdnsd
+ newinitd "${FILESDIR}/pdnsd.online.2" pdnsd-online
- mkdir "${T}"/confd
+ mkdir "${T}"/confd || die
cat - > "${T}"/confd/pdnsd-online <<EOF
# Make sure to change the rc_need variable to the service for the
@@ -74,7 +73,7 @@ EOF
PDNSDCONFIG=""
EOF
- doconfd "${T}"/confd/* || die
+ doconfd "${T}"/confd/*
# gentoo resolvconf support
exeinto /etc/resolvconf/update.d
@@ -87,7 +86,7 @@ src_test() {
die "$1"
}
- mkdir "${T}/pdnsd"
+ mkdir "${T}/pdnsd" || die
echo -n -e "pd12\0\0\0\0" > "${T}/pdnsd/pdnsd.cache"
IPS=$(grep ^nameserver /etc/resolv.conf | sed -e 's/nameserver \(.*\)/\tip=\1;/g' | xargs)
sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \