summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-04-26 17:13:38 +0000
committerAlin Năstac <mrness@gentoo.org>2006-04-26 17:13:38 +0000
commite969d45b528a46c483242aaf7a1d3fe9a011e207 (patch)
treecc8bb3140f1508be4774246905c0a89c34b6ec80 /net-dns/pdnsd
parentStable on hppa. (diff)
downloadgentoo-2-e969d45b528a46c483242aaf7a1d3fe9a011e207.tar.gz
gentoo-2-e969d45b528a46c483242aaf7a1d3fe9a011e207.tar.bz2
gentoo-2-e969d45b528a46c483242aaf7a1d3fe9a011e207.zip
Fix src_test by inserting yet another sleep (#131341).
(Portage version: 2.0.54)
Diffstat (limited to 'net-dns/pdnsd')
-rw-r--r--net-dns/pdnsd/ChangeLog5
-rw-r--r--net-dns/pdnsd/Manifest12
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.4.ebuild5
3 files changed, 8 insertions, 14 deletions
diff --git a/net-dns/pdnsd/ChangeLog b/net-dns/pdnsd/ChangeLog
index 328467403888..1fdbba1f0102 100644
--- a/net-dns/pdnsd/ChangeLog
+++ b/net-dns/pdnsd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-dns/pdnsd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.53 2006/03/13 15:41:29 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.54 2006/04/26 17:13:38 mrness Exp $
+
+ 26 Apr 2006; Alin Nastac <mrness@gentoo.org> pdnsd-1.2.4.ebuild:
+ Fix src_test by inserting yet another sleep (#131341).
13 Mar 2006; Gustavo Zacarias <gustavoz@gentoo.org> pdnsd-1.2.4.ebuild:
Stable on sparc
diff --git a/net-dns/pdnsd/Manifest b/net-dns/pdnsd/Manifest
index ef20ebc1e1a9..9ea7c98a44a1 100644
--- a/net-dns/pdnsd/Manifest
+++ b/net-dns/pdnsd/Manifest
@@ -1,6 +1,3 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 f87d3cdbe5267512650bc66835752bfd ChangeLog 8023
MD5 841f98e9e42888ec6d3869f716017c5f files/digest-pdnsd-1.2.3 67
MD5 21ca3184ba7f84328d7cfbe1c4fcb596 files/digest-pdnsd-1.2.4 67
@@ -9,11 +6,4 @@ MD5 27071ebe71d4f810d57d7cfbd4099788 files/pdnsd.online 452
MD5 65809ab9f525565a98ebe800edea45ab files/pdnsd.rc6 755
MD5 03c559c81ebc357c5f906e8247f1b79b metadata.xml 402
MD5 ff5367e7e1e820b6d58bbf69326d72a1 pdnsd-1.2.3.ebuild 4280
-MD5 18d0330a7784dd95e4f4ddbd1ff04815 pdnsd-1.2.4.ebuild 3883
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2.2-ecc0.1.6 (GNU/Linux)
-
-iD8DBQFEFZK8KRy60XGEcJIRAiw1AKCSW/pOzHownLEhuFil8sQzYdX2+wCeMYeh
-e3qHPWwD/Oaa1yy8DDob4pE=
-=+Px7
------END PGP SIGNATURE-----
+MD5 772b22e9738bd32d9a7d72eeec7fb1ee pdnsd-1.2.4.ebuild 3893
diff --git a/net-dns/pdnsd/pdnsd-1.2.4.ebuild b/net-dns/pdnsd/pdnsd-1.2.4.ebuild
index 96e6a30cfb17..13677c37403b 100644
--- a/net-dns/pdnsd/pdnsd-1.2.4.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.4.ebuild,v 1.6 2006/03/13 15:41:30 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.2.4.ebuild,v 1.7 2006/04/26 17:13:38 mrness Exp $
inherit eutils
@@ -55,8 +55,9 @@ src_test() {
sed -e "s/\tip=/${IPS}/" -e "s:cache_dir=:cache_dir=${T}/pdnsd:" "${FILESDIR}/pdnsd.conf.test" \
> "${T}/pdnsd.conf.test"
src/pdnsd -c "${T}/pdnsd.conf.test" -g -s -d -p "${T}/pid" || die "couldn't start daemon"
- find "${T}" -ls
+ sleep 3
+ find "${T}" -ls
[ -s "${T}/pid" ] || die "empty or no pid file created"
[ -S "${T}/pdnsd/pdnsd.status" ] || die "no socket created"
src/pdnsd-ctl/pdnsd-ctl -c "${T}/pdnsd" server all up || die "failed to start the daemon"