summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-04-22 23:12:00 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-04-22 23:12:00 +0000
commit95e059c53c60135cdcce401dd0fee4e5f0cbac00 (patch)
tree9db15125b1b8084522040b20fba218eb0183de4a /net-dns/posadis/posadis-0.60.4_p1.ebuild
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-95e059c53c60135cdcce401dd0fee4e5f0cbac00.tar.gz
gentoo-2-95e059c53c60135cdcce401dd0fee4e5f0cbac00.tar.bz2
gentoo-2-95e059c53c60135cdcce401dd0fee4e5f0cbac00.zip
Version bumped.
Diffstat (limited to 'net-dns/posadis/posadis-0.60.4_p1.ebuild')
-rw-r--r--net-dns/posadis/posadis-0.60.4_p1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-dns/posadis/posadis-0.60.4_p1.ebuild b/net-dns/posadis/posadis-0.60.4_p1.ebuild
new file mode 100644
index 000000000000..2ff1ad19ae30
--- /dev/null
+++ b/net-dns/posadis/posadis-0.60.4_p1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/posadis/posadis-0.60.4_p1.ebuild,v 1.1 2004/04/22 23:12:00 matsuu Exp $
+
+DESCRIPTION="An authoritive/caching Domain Name Server"
+HOMEPAGE="http://www.posadis.org/projects/posadis.php"
+SRC_URI="mirror://sourceforge/posadis/${P/_p/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="fam"
+
+DEPEND=">=dev-cpp/poslib-1.0.4
+ fam? ( >=app-admin/fam-2.6.9 )"
+
+S=${WORKDIR}/${P/_p*}
+
+src_compile() {
+ econf `use_enable fam` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # make directory for posadis pidfile and zone data files
+ keepdir /var/posadis
+ keepdir /etc/posadis
+
+ exeinto /etc/init.d; newexe ${FILESDIR}/${PN}-init posadis
+ insinto /etc/
+ doins posadisrc
+
+ dodoc AUTHORS ChangeLog INSTALL README TODO
+}
+
+pkg_preinst() {
+ source /etc/init.d/functions.sh
+ if [ -L ${svcdir}/started/posadis ]; then
+ einfo "The posadis init script is running. I'll stop it, merge the new files and restart the script."
+ /etc/init.d/posadis stop
+ fi
+}