summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-09-09 22:36:33 +0000
committerRoy Marples <uberlord@gentoo.org>2006-09-09 22:36:33 +0000
commitdd85dcb38bb85ba0885d006f3f4490ddbf37b940 (patch)
tree0ec11bc7093ebe3084c87f9bb81a019f878ed64d /net-dns/resolvconf-gentoo
parentStable on x86, bug #141396. (diff)
downloadgentoo-2-dd85dcb38bb85ba0885d006f3f4490ddbf37b940.tar.gz
gentoo-2-dd85dcb38bb85ba0885d006f3f4490ddbf37b940.tar.bz2
gentoo-2-dd85dcb38bb85ba0885d006f3f4490ddbf37b940.zip
run-parts is Linux only, so replace with a bash loop
(Portage version: 2.1.1_rc1-r5)
Diffstat (limited to 'net-dns/resolvconf-gentoo')
-rw-r--r--net-dns/resolvconf-gentoo/ChangeLog6
-rw-r--r--net-dns/resolvconf-gentoo/files/resolvconf-gentoo-1.0-run-parts.patch28
-rw-r--r--net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild12
3 files changed, 43 insertions, 3 deletions
diff --git a/net-dns/resolvconf-gentoo/ChangeLog b/net-dns/resolvconf-gentoo/ChangeLog
index 8129e07b07b0..5c45570f1c0f 100644
--- a/net-dns/resolvconf-gentoo/ChangeLog
+++ b/net-dns/resolvconf-gentoo/ChangeLog
@@ -1,9 +1,11 @@
# ChangeLog for net-dns/resolvconf-gentoo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/ChangeLog,v 1.12 2006/09/09 21:59:43 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/ChangeLog,v 1.13 2006/09/09 22:36:33 uberlord Exp $
09 Sep 2006; Roy Marples <uberlord@gentoo.org>
- resolvconf-gentoo-1.0.ebuild:
+ +files/resolvconf-gentoo-1.0-run-parts.patch,
+ +resolvconf-gentoo-1.0.ebuild:
+ run-parts is Linux only, so replace with a bash loop
Keyworded ~x86-fbsd
07 Sep 2006; Guy Martin <gmsoft@gentoo.org> resolvconf-gentoo-1.0.ebuild:
diff --git a/net-dns/resolvconf-gentoo/files/resolvconf-gentoo-1.0-run-parts.patch b/net-dns/resolvconf-gentoo/files/resolvconf-gentoo-1.0-run-parts.patch
new file mode 100644
index 000000000000..7a60b07327eb
--- /dev/null
+++ b/net-dns/resolvconf-gentoo/files/resolvconf-gentoo-1.0-run-parts.patch
@@ -0,0 +1,28 @@
+--- bin/resolvconf 2006-05-25 18:35:31 +0000
++++ bin/resolvconf 2006-09-09 22:12:23 +0000
+@@ -211,6 +211,10 @@
+ echo "${IFACE}" >> "${ADDORDER}"
+ fi
+
+-run-parts "--arg=${CMD}" ${IFACE:+--arg=${IFACE}} /etc/resolvconf/update.d
++for x in /etc/resolvconf/update.d/* ; do
++ [[ -e ${x} ]] && "${x}" "${CMD}" "${IFACE}"
++done
++
++exit 0
+
+ # vim: ts=4 :
+--- update.d/libc 2006-06-04 16:55:13 +0000
++++ update.d/libc 2006-09-09 22:13:18 +0000
+@@ -108,6 +108,10 @@
+ fi
+
+ # Notify users of the resolver
+-exec run-parts ${1:+--arg $1} ${2:+--arg $2} /etc/resolvconf/update-libc.d
++for x in /etc/resolvconf/update-libc.d/* ; do
++ [[ -e ${x} ]] && "${x}" "$@"
++done
++
++exit 0
+
+ # vim: ts=4 :
diff --git a/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild b/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild
index df57602c19e4..ac75078ce1de 100644
--- a/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild
+++ b/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild,v 1.11 2006/09/09 21:59:43 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/resolvconf-gentoo/resolvconf-gentoo-1.0.ebuild,v 1.12 2006/09/09 22:36:33 uberlord Exp $
+
+inherit eutils
DESCRIPTION="A framework for managing DNS information"
HOMEPAGE="http://www.gentoo.org"
@@ -23,6 +25,14 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # run-parts is Linux only, so replace with a bash loop
+ epatch "${FILESDIR}/${P}-run-parts.patch"
+}
+
src_install() {
make ROOT="${D}" install || die "Failed to install"
}