summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2006-05-14 14:33:52 +0000
committerThilo Bangert <bangert@gentoo.org>2006-05-14 14:33:52 +0000
commit5d848674cd3f0e5c2329441c77ec8993640b0139 (patch)
treeddd3453b40e64128ddf79ee60485e30b2126e1fe /net-dns/tinystats/tinystats-1.1.ebuild
parentStable on x86 wrt bug #133097. (diff)
downloadgentoo-2-5d848674cd3f0e5c2329441c77ec8993640b0139.tar.gz
gentoo-2-5d848674cd3f0e5c2329441c77ec8993640b0139.tar.bz2
gentoo-2-5d848674cd3f0e5c2329441c77ec8993640b0139.zip
initial import. tinystats is a filter that reads tinydns logs and stores stats about query types and errors.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'net-dns/tinystats/tinystats-1.1.ebuild')
-rw-r--r--net-dns/tinystats/tinystats-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-dns/tinystats/tinystats-1.1.ebuild b/net-dns/tinystats/tinystats-1.1.ebuild
new file mode 100644
index 000000000000..172ac7dd12c1
--- /dev/null
+++ b/net-dns/tinystats/tinystats-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/tinystats/tinystats-1.1.ebuild,v 1.1 2006/05/14 14:33:52 bangert Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tinydns logging helper app."
+HOMEPAGE="http://morettoni.net/tinystats.en.html"
+SRC_URI="http://morettoni.net/bsd/${P}.tar.gz"
+IUSE="ipv6"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+RDEPEND="net-dns/djbdns"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ use ipv6 && IPV6="-D WITH_IPV6"
+ $(tc-getCC) ${CFLAGS} ${IPV6} -o tinystats tinystats.c || \
+ die "compile failed"
+}
+
+src_install() {
+ dobin tinystats
+ dodoc README
+ docinto sample
+ dodoc start_slave.sh.sample update_slave.sh.sample \
+ tinydns.log.run.sample tinydns.sh.sample
+}