summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-06-24 11:41:10 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-06-24 11:41:10 +0000
commit4e29d5740801fdb4678e7e42a8a27d50bb234e75 (patch)
tree512c7c847018d461208620808fc7231c5d202e14 /net-dns
parentadded usbirboy. Changed the old name LIRC_DRIVERS to correct LIRC_DEVICES. (diff)
downloadgentoo-2-4e29d5740801fdb4678e7e42a8a27d50bb234e75.tar.gz
gentoo-2-4e29d5740801fdb4678e7e42a8a27d50bb234e75.tar.bz2
gentoo-2-4e29d5740801fdb4678e7e42a8a27d50bb234e75.zip
adding patch for www.3322.net, solving bug #69090.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ez-ipupdate/ChangeLog9
-rw-r--r--net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild101
-rw-r--r--net-dns/ez-ipupdate/files/digest-ez-ipupdate-3.0.11_beta8-r46
-rw-r--r--net-dns/ez-ipupdate/files/ez-ipupdate-3.0.11_beta8-3322.diff57
4 files changed, 172 insertions, 1 deletions
diff --git a/net-dns/ez-ipupdate/ChangeLog b/net-dns/ez-ipupdate/ChangeLog
index d71614ed9f45..91e258cfba4a 100644
--- a/net-dns/ez-ipupdate/ChangeLog
+++ b/net-dns/ez-ipupdate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/ez-ipupdate
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ChangeLog,v 1.17 2006/04/27 21:42:28 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ChangeLog,v 1.18 2006/06/24 11:41:10 sbriesen Exp $
+
+*ez-ipupdate-3.0.11_beta8-r4 (24 Jun 2006)
+
+ 24 Jun 2006; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/ez-ipupdate-3.0.11_beta8-3322.diff,
+ +ez-ipupdate-3.0.11_beta8-r4.ebuild:
+ adding patch for www.3322.net, solving bug #69090.
27 Apr 2006; Alec Warner <antarus@gentoo.org>
files/digest-ez-ipupdate-3.0.11_beta8-r1,
diff --git a/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild b/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild
new file mode 100644
index 000000000000..79e5020cbfd1
--- /dev/null
+++ b/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r4.ebuild,v 1.1 2006/06/24 11:41:10 sbriesen Exp $
+
+inherit eutils
+
+PATCH_VERSION="10"
+MY_PV="${PV/_beta/b}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Dynamic DNS client for lots of dynamic dns services"
+HOMEPAGE="http://ez-ipupdate.com/"
+SRC_URI="mirror://debian/pool/main/e/ez-ipupdate/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/e/ez-ipupdate/${PN}_${MY_PV}-${PATCH_VERSION}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${PN}_${MY_PV}-${PATCH_VERSION}.diff"
+ epatch "${FILESDIR}/${P}-dnsexit.diff"
+ epatch "${FILESDIR}/${P}-3322.diff"
+
+ # comment out obsolete options
+ sed -i -e "s:^\(run-as-user.*\):#\1:g" \
+ -e "s:^\(cache-file.*\):#\1:g" ex*conf
+}
+
+src_compile() {
+ econf --bindir=/usr/sbin || "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ newinitd "${FILESDIR}/ez-ipupdate.initd" ez-ipupdate
+ keepdir /etc/ez-ipupdate /var/cache/ez-ipupdate
+
+ # install docs
+ dodoc README
+ newdoc debian/README.Debian README.debian
+ newdoc debian/changelog ChangeLog.debian
+ newdoc CHANGELOG ChangeLog
+
+ # install example configs
+ docinto examples
+ dodoc ex*conf
+}
+
+pkg_preinst() {
+ enewgroup ez-ipupd
+ enewuser ez-ipupd -1 -1 /var/cache/ez-ipupdate ez-ipupd
+}
+
+pkg_postinst() {
+ chmod 750 /etc/ez-ipupdate /var/cache/ez-ipupdate
+ chown ez-ipupd:ez-ipupd /etc/ez-ipupdate /var/cache/ez-ipupdate
+
+ einfo
+ einfo "Please create one or more config files in"
+ einfo "/etc/ez-ipupdate/. A bunch of samples can"
+ einfo "be found in the doc directory."
+ einfo
+ einfo "All config files must have a '.conf' extension."
+ einfo
+ einfo "Please do not use the 'run-as-user', 'run-as-euser',"
+ einfo "'cache-file' and 'pidfile' options, since these are"
+ einfo "handled internally by the init-script!"
+ einfo
+ einfo "If you want to use ez-ipupdate in daemon mode,"
+ einfo "please add 'daemon' to the config file(s) and"
+ einfo "add the ez-ipupdate init-script to the default"
+ einfo "runlevel."
+ einfo
+ einfo "Without the 'daemon' option, you can run the"
+ einfo "init-script with the 'update' parameter inside"
+ einfo "your PPP ip-up script."
+ einfo
+
+ if [ -f /etc/ez-ipupdate.conf ]; then
+ ewarn "!!! IMPORTANT UPDATE NOTICE !!!"
+ ewarn
+ ewarn "The ez-ipupdate init-script can now handle more"
+ ewarn "than one config file. New config file location is"
+ ewarn "/etc/ez-ipupdate/*.conf"
+ ewarn
+ if [ ! -f /etc/ez-ipupdate/default.conf ]; then
+ mv -f /etc/ez-ipupdate.conf /etc/ez-ipupdate/default.conf
+ einfo "Your old configuration has been moved to"
+ einfo "/etc/ez-ipupdate/default.conf"
+ einfo
+ fi
+ ebeep
+ fi
+}
diff --git a/net-dns/ez-ipupdate/files/digest-ez-ipupdate-3.0.11_beta8-r4 b/net-dns/ez-ipupdate/files/digest-ez-ipupdate-3.0.11_beta8-r4
new file mode 100644
index 000000000000..d6b35e999ba1
--- /dev/null
+++ b/net-dns/ez-ipupdate/files/digest-ez-ipupdate-3.0.11_beta8-r4
@@ -0,0 +1,6 @@
+MD5 e400c9c8d594922e394806b717250c35 ez-ipupdate_3.0.11b8-10.diff.gz 58420
+RMD160 916da2553c2901bae62de43a09ee4ad9da492c95 ez-ipupdate_3.0.11b8-10.diff.gz 58420
+SHA256 a380abc3173ef49be5cf8600278e1bc941b4503129dd9e682707bb79e1538175 ez-ipupdate_3.0.11b8-10.diff.gz 58420
+MD5 000211add4c4845ffa4211841bff4fb0 ez-ipupdate_3.0.11b8.orig.tar.gz 81975
+RMD160 f193969c5d3c9faa1b6fec41d530557614d62c55 ez-ipupdate_3.0.11b8.orig.tar.gz 81975
+SHA256 bf5b8d11ffe055c5891d0ab64bbfa86e99cbda645d40f346146b939fec8d962d ez-ipupdate_3.0.11b8.orig.tar.gz 81975
diff --git a/net-dns/ez-ipupdate/files/ez-ipupdate-3.0.11_beta8-3322.diff b/net-dns/ez-ipupdate/files/ez-ipupdate-3.0.11_beta8-3322.diff
new file mode 100644
index 000000000000..7381383c8f4c
--- /dev/null
+++ b/net-dns/ez-ipupdate/files/ez-ipupdate-3.0.11_beta8-3322.diff
@@ -0,0 +1,57 @@
+diff -Nur ez-ipupdate-3.0.11b8/ez-ipupdate.c ez-ipupdate-3.0.11b8.3322/ez-ipupdate.c
+--- ez-ipupdate-3.0.11b8/ez-ipupdate.c 2002-03-11 19:31:47.000000000 -0400
++++ ez-ipupdate-3.0.11b8.3322/ez-ipupdate.c 2004-10-26 23:49:38.781671824 -0300
+@@ -62,6 +62,12 @@
+ #define DYNDNS_STAT_REQUEST "/nic/update"
+ #define DYNDNS_MAX_INTERVAL (25*24*3600)
+
++#define QDNS_DEFAULT_SERVER "members.3322.org"
++#define QDNS_DEFAULT_PORT "80"
++#define QDNS_REQUEST "/dyndns/update"
++#define QDNS_STAT_REQUEST "/dyndns/update"
++#define QDNS_MAX_INTERVAL (25*24*3600)
++
+ #define ODS_DEFAULT_SERVER "update.ods.org"
+ #define ODS_DEFAULT_PORT "7070"
+ #define ODS_REQUEST "update"
+@@ -299,6 +305,12 @@
+ static char *DYNDNS_fields_used[] = { "server", "user", "address", "wildcard", "mx", "host", NULL };
+ static char *DYNDNS_STAT_fields_used[] = { "server", "user", "address", "wildcard", "mx", "host", NULL };
+
++void QDNS_init(void);
++int QDNS_update_entry(void);
++int QDNS_check_info(void);
++static char *QDNS_fields_used[] = { "server", "user", "address", "wildcard", "mx", "host", NULL };
++static char *QDNS_STAT_fields_used[] = { "server", "user", "address", "wildcard", "mx", "host", NULL };
++
+ int ODS_update_entry(void);
+ int ODS_check_info(void);
+ static char *ODS_fields_used[] = { "server", "host", "address", NULL };
+@@ -412,6 +424,27 @@
+ DYNDNS_DEFAULT_PORT,
+ DYNDNS_REQUEST
+ },
++ { "qdns",
++ { "qdns", 0, 0, },
++ DYNDNS_init,
++ DYNDNS_update_entry,
++ DYNDNS_check_info,
++ DYNDNS_fields_used,
++ QDNS_DEFAULT_SERVER,
++ QDNS_DEFAULT_PORT,
++ QDNS_REQUEST
++ },
++ { "qdns-static",
++ { "qdns-static", "qdns-stat", "statdns", },
++ DYNDNS_init,
++ DYNDNS_update_entry,
++ DYNDNS_check_info,
++ DYNDNS_STAT_fields_used,
++ QDNS_DEFAULT_SERVER,
++ QDNS_DEFAULT_PORT,
++ QDNS_STAT_REQUEST
++ },
++
+ { "ods",
+ { "ods", 0, 0, },
+ NULL,