summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2013-05-04 20:54:57 +0000
committerSven Wegener <swegener@gentoo.org>2013-05-04 20:54:57 +0000
commit80afc657ea6ac623f9dc21cd8deb66b7d3be15c2 (patch)
treea64e13890ffcce053c5358b96130593d983f6c8f /net-dns
parentVersion bump to 2.1. (diff)
downloadgentoo-2-80afc657ea6ac623f9dc21cd8deb66b7d3be15c2.tar.gz
gentoo-2-80afc657ea6ac623f9dc21cd8deb66b7d3be15c2.tar.bz2
gentoo-2-80afc657ea6ac623f9dc21cd8deb66b7d3be15c2.zip
Version bump, security bug #404377.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x64D4CF24)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns-recursor/ChangeLog9
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.5.1.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 1d6d57269987..fd76848ce6ae 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/pdns-recursor
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.40 2012/12/06 04:05:23 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.41 2013/05/04 20:54:57 swegener Exp $
+
+*pdns-recursor-3.5.1 (04 May 2013)
+
+ 04 May 2013; Sven Wegener <swegener@gentoo.org> +pdns-recursor-3.5.1.ebuild:
+ Version bump, security bug #404377.
06 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
pdns-recursor-3.3.ebuild:
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.5.1.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.5.1.ebuild
new file mode 100644
index 000000000000..45771c6b2ec6
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.5.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.5.1.ebuild,v 1.1 2013/05/04 20:54:57 swegener Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND="lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ >=dev-libs/boost-1.33.1"
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.7.2-error-message.patch
+
+ sed -i -e s:/var/run/:/var/lib/powerdns: "${S}"/config.h || die
+}
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control
+ doman pdns_recursor.1 rec_control.1
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf
+
+ doinitd "${FILESDIR}"/precursor
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}