summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-06-28 12:08:10 +0000
committerSven Wegener <swegener@gentoo.org>2008-06-28 12:08:10 +0000
commitb2a830c3fa8ff079bbdda7a47284bb2557b8b60d (patch)
tree1a6c8b9e7cdd88a747a8eb987cd68460f5e5c134 /net-dns
parentFix a compilation problem on amd64, bug #229453. (diff)
downloadgentoo-2-b2a830c3fa8ff079bbdda7a47284bb2557b8b60d.tar.gz
gentoo-2-b2a830c3fa8ff079bbdda7a47284bb2557b8b60d.tar.bz2
gentoo-2-b2a830c3fa8ff079bbdda7a47284bb2557b8b60d.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns-recursor/ChangeLog8
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.1.7.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 778440bfcc11..64d621b73b62 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/pdns-recursor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.20 2008/06/15 18:38:19 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.21 2008/06/28 12:08:10 swegener Exp $
+
+*pdns-recursor-3.1.7 (28 Jun 2008)
+
+ 28 Jun 2008; Sven Wegener <swegener@gentoo.org>
+ +pdns-recursor-3.1.7.ebuild:
+ Version bump.
15 Jun 2008; Sven Wegener <swegener@gentoo.org>
+files/pdns-recursor-3.1.6-gcc-4.3.patch, pdns-recursor-3.1.6.ebuild:
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.1.7.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.1.7.ebuild
new file mode 100644
index 000000000000..1d9cde364daa
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.1.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.1.7.ebuild,v 1.1 2008/06/28 12:08:10 swegener Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND=">=dev-libs/boost-1.33.1
+ lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e s:/var/run/:/var/lib/powerdns: "${S}"/config.h || die
+}
+
+src_compile() {
+ # This is tricky, it gets the variables in the Makefile right
+ local OPTFLAGS="${CFLAGS}" CFLAGS="" CXXFLAGS=""
+
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="${OPTFLAGS}" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)" \
+ || die "emake failed"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control || die "dosbin failed"
+ doman pdns_recursor.1 rec_control.1 || die "doman failed"
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf || die "doins failed"
+
+ doinitd "${FILESDIR}"/precursor || die "doinitd failed"
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}