summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2004-01-19 07:52:20 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2004-01-19 07:52:20 +0000
commite4422aee940d6210c9dc14d26048e92546ec8d10 (patch)
treef6aa083d4497bd6822c0785c41a5023cf613b38d /net-dns
parentVersion bump. Fixes bug #37989 (diff)
downloadgentoo-2-e4422aee940d6210c9dc14d26048e92546ec8d10.tar.gz
gentoo-2-e4422aee940d6210c9dc14d26048e92546ec8d10.tar.bz2
gentoo-2-e4422aee940d6210c9dc14d26048e92546ec8d10.zip
Version bump. Fixes bug #37989
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/ChangeLog6
-rw-r--r--net-dns/pdns/Manifest4
-rw-r--r--net-dns/pdns/files/digest-pdns-2.9.151
-rw-r--r--net-dns/pdns/pdns-2.9.15.ebuild47
4 files changed, 55 insertions, 3 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
index 18894a2b05f1..da4ea1017909 100644
--- a/net-dns/pdns/ChangeLog
+++ b/net-dns/pdns/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-dns/pdns
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.6 2004/01/17 22:31:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.7 2004/01/19 07:52:12 jhhudso Exp $
+*pdns-2.9.15 (19 Jan 2004)
+
+ 19 Jan 2004; Jared Hudson <jhhudso@gentoo.org> : Version bump.
+
17 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> pdns-2.9.12-r1.ebuild:
dev-libs/libpq++ -> dev-cpp/libpqpp
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index 3ca7afe680e9..715425f7dc8b 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,8 +1,8 @@
MD5 8aad8f90ae03fd765adc9a72c493e944 pdns-2.9.12.ebuild 972
MD5 30f94a808982995cefdfac0c46a1d30a pdns-2.9.8.ebuild 971
MD5 f71c33d3646cab7f4e79b40dafba3737 metadata.xml 251
-MD5 5e9b6aabdf72c75ecd6132c8b65f9719 ChangeLog 1032
-MD5 19e4be0bbb44aae318b9c383a0b9f717 pdns-2.9.15.ebuild 1237
+MD5 46faf3bc4d3a6c26eb3d8a08a2d287e6 ChangeLog 1125
+MD5 cb8d39be8be0da117d6e8198e021815b pdns-2.9.15.ebuild 1232
MD5 19e4be0bbb44aae318b9c383a0b9f717 pdns-2.9.12-r1.ebuild 1237
MD5 0969ab0b2776f09c9aeb74b0996c4426 files/pdns 533
MD5 2737254767420d95c7794d890b5c4841 files/digest-pdns-2.9.15 63
diff --git a/net-dns/pdns/files/digest-pdns-2.9.15 b/net-dns/pdns/files/digest-pdns-2.9.15
new file mode 100644
index 000000000000..55b39a5b8351
--- /dev/null
+++ b/net-dns/pdns/files/digest-pdns-2.9.15
@@ -0,0 +1 @@
+MD5 3465694b9638c29f19a25dd5b0a77559 pdns-2.9.15.tar.gz 740625
diff --git a/net-dns/pdns/pdns-2.9.15.ebuild b/net-dns/pdns/pdns-2.9.15.ebuild
new file mode 100644
index 000000000000..0b3639d46c6f
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.15.ebuild,v 1.1 2004/01/19 07:52:12 jhhudso Exp $
+
+DESCRIPTION="The PowerDNS Daemon."
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql postgres static ldap"
+
+DEPEND="virtual/glibc
+ mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf=""
+ local modules=""
+
+ use static && myconf="$myconf --enable-static-binaries"
+ use postgres && myconf="$myconf --with-pgsql-includes=/usr/include"
+
+ use mysql && modules="gmysql $modules"
+ use postgres && modules="gpgsql $modules"
+ use ldap && modules="ldap $modules"
+
+ econf --with-modules="$modules" \
+ $myconf || die "Configuration failed"
+
+ emake || die "Make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog HACKING INSTALL README TODO WARNING pdns/COPYING
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/pdns
+
+ mv ${D}/etc/pdns.conf-dist ${D}/etc/pdns.conf
+}