summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-15 17:25:38 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-15 17:25:38 +0000
commit3ce7e2098229ba6c3714b5a4a590cb1732fa3821 (patch)
tree295119a464f1e79b932ea990078a030a2405a8e8 /net-firewall/fwbuilder/fwbuilder-4.2.2.3541.ebuild
parentAdd ~alpha/~ia64/~sparc wrt #359047 (diff)
downloadgentoo-2-3ce7e2098229ba6c3714b5a4a590cb1732fa3821.tar.gz
gentoo-2-3ce7e2098229ba6c3714b5a4a590cb1732fa3821.tar.bz2
gentoo-2-3ce7e2098229ba6c3714b5a4a590cb1732fa3821.zip
Version bump, now including libfwbuilder; bug 364515
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/fwbuilder/fwbuilder-4.2.2.3541.ebuild')
-rw-r--r--net-firewall/fwbuilder/fwbuilder-4.2.2.3541.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-firewall/fwbuilder/fwbuilder-4.2.2.3541.ebuild b/net-firewall/fwbuilder/fwbuilder-4.2.2.3541.ebuild
new file mode 100644
index 000000000000..837ae648b80b
--- /dev/null
+++ b/net-firewall/fwbuilder/fwbuilder-4.2.2.3541.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-4.2.2.3541.ebuild,v 1.1 2011/05/15 17:25:38 dilfridge Exp $
+
+EAPI=4
+
+inherit eutils qt4-r2 multilib autotools
+
+DESCRIPTION="A firewall GUI"
+HOMEPAGE="http://www.fwbuilder.org/"
+SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-gui-4.3
+ dev-libs/openssl
+ dev-libs/elfutils
+ sys-devel/gnuconfig
+ !net-libs/libfwbuilder"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt4-r2_src_prepare
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ eautoreconf
+
+ # This package fundamentally changed its build system. We have to
+ # manually copy config.{sub,guess} from /usr/share/gnuconfig/.
+ cp /usr/share/gnuconfig/config.{sub,guess} "${WORKDIR}/${P}/" \
+ || die "failed to copy config.{sub,guess}"
+}
+
+src_configure() {
+ econf
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ validate_desktop_entries
+
+ elog "You need to emerge sys-apps/iproute2 on the machine"
+ elog "that will run the firewall script."
+}