summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-02-09 20:47:18 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-02-09 20:47:18 +0000
commit9a7bec909602d5419d2c47a16e66c83511dfa3b2 (patch)
treee5fc32a7176a765f728e4990ac6db71200e9e5a7 /net-firewall/ipsec-tools
parentVersion bump for beta channel release. Set SONAME using first 3 version compo... (diff)
downloadgentoo-2-9a7bec909602d5419d2c47a16e66c83511dfa3b2.tar.gz
gentoo-2-9a7bec909602d5419d2c47a16e66c83511dfa3b2.tar.bz2
gentoo-2-9a7bec909602d5419d2c47a16e66c83511dfa3b2.zip
Version bump, bug #365077
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/ipsec-tools')
-rw-r--r--net-firewall/ipsec-tools/ChangeLog8
-rw-r--r--net-firewall/ipsec-tools/ipsec-tools-0.8.0.ebuild181
-rw-r--r--net-firewall/ipsec-tools/metadata.xml4
3 files changed, 190 insertions, 3 deletions
diff --git a/net-firewall/ipsec-tools/ChangeLog b/net-firewall/ipsec-tools/ChangeLog
index b47c0e8aa528..df55fd0b8f24 100644
--- a/net-firewall/ipsec-tools/ChangeLog
+++ b/net-firewall/ipsec-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipsec-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.80 2012/02/07 03:26:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.81 2012/02/09 20:47:18 blueness Exp $
+
+*ipsec-tools-0.8.0 (09 Feb 2012)
+
+ 09 Feb 2012; Anthony G. Basile <blueness@gentoo.org>
+ +ipsec-tools-0.8.0.ebuild:
+ Version bump, bug #365077
07 Feb 2012; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Added myself as maintainer, bug #365077
diff --git a/net-firewall/ipsec-tools/ipsec-tools-0.8.0.ebuild b/net-firewall/ipsec-tools/ipsec-tools-0.8.0.ebuild
new file mode 100644
index 000000000000..e1cf824698b1
--- /dev/null
+++ b/net-firewall/ipsec-tools/ipsec-tools-0.8.0.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.8.0.ebuild,v 1.1 2012/02/09 20:47:18 blueness Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic autotools linux-info
+
+DESCRIPTION="A port of KAME's IPsec utilities to the Linux-2.6 IPsec implementation"
+HOMEPAGE="http://ipsec-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="rc5 idea kerberos stats ipv6 nat selinux readline pam hybrid ldap"
+
+RDEPEND="
+ kerberos? ( virtual/krb5 )
+ selinux? (
+ sys-libs/libselinux
+ sec-policy/selinux-ipsec-tools
+ )
+ readline? ( sys-libs/readline )
+ pam? ( sys-libs/pam )
+ ldap? ( net-nds/openldap )
+ dev-libs/openssl
+ virtual/libiconv"
+# iconv? ( virtual/libiconv )
+# radius? ( net-dialup/gnuradius )
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.30"
+
+pkg_setup() {
+ get_version
+ if kernel_is -ge 2 6 19 ; then
+ einfo "Checking for suitable kernel configuration (Networking | Networking support | Networking options)"
+
+ if use nat; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~NETFILTER_XT_MATCH_POLICY"
+ export WARNING_NETFILTER_XT_MATCH_POLICY="NAT support may fail weirdly unless you enable this option in your kernel"
+ fi
+
+ for i in XFRM_USER NET_KEY; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ eval "export WARNING_${i}='No tunnels will be available at all'"
+ done
+
+ for i in INET_IPCOMP INET_AH INET_ESP \
+ INET_XFRM_MODE_TRANSPORT \
+ INET_XFRM_MODE_TUNNEL \
+ INET_XFRM_MODE_BEET ; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ eval "export WARNING_${i}='IPv4 tunnels will not be available'"
+ done
+
+ for i in INET6_IPCOMP INET6_AH INET6_ESP \
+ INET6_XFRM_MODE_TRANSPORT \
+ INET6_XFRM_MODE_TUNNEL \
+ INET6_XFRM_MODE_BEET ; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ eval "export WARNING_${i}='IPv6 tunnels will not be available'"
+ done
+
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_NULL"
+ export WARNING_CRYPTO_NULL="Unencrypted tunnels will not be available"
+ export CONFIG_CHECK
+
+ check_extra_config
+ else
+ eerror "You must have a kernel >=2.6.19 to run ipsec-tools."
+ eerror "Building now, assuming that you will run on a different kernel"
+ fi
+}
+
+src_prepare() {
+ # fix for bug #76741
+ sed -i 's:#include <sys/sysctl.h>::' src/racoon/pfkey.c src/setkey/setkey.c || die
+ # fix for bug #124813
+ sed -i 's:-Werror::g' "${S}"/configure.ac || die
+ # fix for building with gcc-4.6
+ sed -i 's: -R: -Wl,-R:' "${S}"/configure.ac || die
+
+ AT_M4DIR="${S}" eautoreconf
+ epunt_cxx
+}
+
+src_configure() {
+ # fix for bug #61025
+ filter-flags -march=c3
+
+ local myconf
+ myconf="--with-kernel-headers=/usr/include \
+ --enable-adminport \
+ --enable-frag \
+ --enable-dpd \
+ --enable-dependency-tracking \
+ $(use_enable rc5) \
+ $(use_enable idea) \
+ $(use_enable kerberos gssapi) \
+ $(use_enable stats) \
+ $(use_enable ipv6) \
+ $(use_enable nat natt) \
+ $(use_enable selinux security-context) \
+ $(use_with readline) \
+ $(use_with pam libpam) \
+ $(use_with ldap libldap)"
+
+ use nat && myconf="${myconf} --enable-natt-versions=yes"
+
+ # enable mode-cfg and xauth support
+ if use pam; then
+ myconf="${myconf} --enable-hybrid"
+ else
+ myconf="${myconf} $(use_enable hybrid)"
+ fi
+
+ # dev-libs/libiconv is hard masked
+ #use iconv && myconf="${myconf} $(use_with iconv libiconv)"
+
+ # the default (/usr/include/openssl/) is OK for Gentoo, leave it
+ # myconf="${myconf} $(use_with ssl openssl )"
+
+ # No way to get it compiling with freeradius or gnuradius
+ # We would need libradius which only exists on FreeBSD
+
+ # See bug #77369
+ #myconf="${myconf} --enable-samode-unspec"
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /var/lib/racoon
+ newconfd "${FILESDIR}"/racoon.conf.d racoon
+ newinitd "${FILESDIR}"/racoon.init.d racoon
+
+ dodoc ChangeLog README NEWS
+ dodoc -r src/racoon/samples
+ dodoc -r src/racoon/doc
+
+ docinto setkey
+ dodoc src/setkey/sample.cf
+
+ dodir /etc/racoon
+
+ # RFC are only available from CVS for the moment, see einfo below
+ #docinto "rfc"
+ #dodoc ${S}/src/racoon/rfc/*
+}
+
+pkg_postinst() {
+ if use nat; then
+ elog
+ elog "You have enabled the nat traversal functionnality."
+ elog "Nat versions wich are enabled by default are 00,02,rfc"
+ elog "you can find those drafts in the CVS repository:"
+ elog "cvs -d anoncvs@anoncvs.netbsd.org:/cvsroot co ipsec-tools"
+ elog
+ elog "If you feel brave enough and you know what you are"
+ elog "doing, you can consider emerging this ebuild with"
+ elog "EXTRA_ECONF=\"--enable-natt-versions=08,07,06\""
+ elog
+ fi
+
+ if use ldap; then
+ elog
+ elog "You have enabled ldap support with {$PN}."
+ elog "The man page does NOT contain any information on it yet."
+ elog "Consider using a more recent version or CVS."
+ elog
+ fi
+
+ elog
+ elog "Please have a look in /usr/share/doc/${P} and visit"
+ elog "http://www.netbsd.org/Documentation/network/ipsec/"
+ elog "to find more information on how to configure this tool."
+ elog
+}
diff --git a/net-firewall/ipsec-tools/metadata.xml b/net-firewall/ipsec-tools/metadata.xml
index afce4ab8f5da..6e6434cb2f5e 100644
--- a/net-firewall/ipsec-tools/metadata.xml
+++ b/net-firewall/ipsec-tools/metadata.xml
@@ -5,10 +5,10 @@
<email>blueness@gentoo.org</email>
</maintainer>
<use>
- <flag name='hybrid'>Makes available both mode-cfg and xauth
- support</flag>
+ <flag name='hybrid'>Makes available both mode-cfg and xauth support</flag>
<flag name='idea'>Enable support for the IDEA algorithm</flag>
<flag name='nat'>Enable NAT-Traversal</flag>
<flag name='rc5'>Enable support for the patented RC5 algorithm</flag>
+ <flag name='stats'>Enable statistics reporting</flag>
</use>
</pkgmetadata>