summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-03-16 20:26:54 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-03-16 20:26:54 +0000
commite7248e60fdc74d7039cc8c67f5fd3848806ca10e (patch)
treefe1e8883d695c99799bed69398a6a282193cd031 /net-firewall/ipset
parentStable on amd64, wrt bug #461394 (diff)
downloadgentoo-2-e7248e60fdc74d7039cc8c67f5fd3848806ca10e.tar.gz
gentoo-2-e7248e60fdc74d7039cc8c67f5fd3848806ca10e.tar.bz2
gentoo-2-e7248e60fdc74d7039cc8c67f5fd3848806ca10e.zip
Drop old versions, permissions granted by maintainer
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog8
-rw-r--r--net-firewall/ipset/files/ipset.initd-r153
-rw-r--r--net-firewall/ipset/ipset-4.5.ebuild101
-rw-r--r--net-firewall/ipset/ipset-6.10.ebuild110
-rw-r--r--net-firewall/ipset/ipset-6.11.ebuild110
-rw-r--r--net-firewall/ipset/ipset-6.13.ebuild111
-rw-r--r--net-firewall/ipset/ipset-6.14.ebuild111
-rw-r--r--net-firewall/ipset/ipset-6.8.ebuild109
-rw-r--r--net-firewall/ipset/ipset-6.9.1-r2.ebuild109
9 files changed, 7 insertions, 815 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index f0f8ad2187dd..40ea2e67c2f1 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.68 2013/02/17 19:05:58 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.69 2013/03/16 20:26:54 pinkbyte Exp $
+
+ 16 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> -ipset-4.5.ebuild,
+ -ipset-6.8.ebuild, -ipset-6.9.1-r2.ebuild, -ipset-6.10.ebuild,
+ -ipset-6.11.ebuild, -ipset-6.13.ebuild, -ipset-6.14.ebuild,
+ -files/ipset.initd-r1:
+ Drop old versions, permissions granted by maintainer
*ipset-6.16.1 (17 Feb 2013)
diff --git a/net-firewall/ipset/files/ipset.initd-r1 b/net-firewall/ipset/files/ipset.initd-r1
deleted file mode 100644
index 2f0b2c67cac0..000000000000
--- a/net-firewall/ipset/files/ipset.initd-r1
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/files/ipset.initd-r1,v 1.1 2011/10/12 13:26:16 pva Exp $
-
-extra_commands="save"
-
-IPSET_SAVE=${IPSET_SAVE:-/var/lib/ipset/rules-save}
-
-depend() {
- before iptables ip6tables
- use logger
-}
-
-checkconfig() {
- if [ ! -f "${IPSET_SAVE}" ] ; then
- eerror "Not starting ${SVCNAME}. First create some rules then run:"
- eerror "/etc/init.d/${SVCNAME} save"
- return 1
- fi
- return 0
-}
-
-start() {
- checkconfig || return 1
- ebegin "Loading ipset session"
- ipset restore < "${IPSET_SAVE}"
- eend $?
-}
-
-stop() {
- # check if there are any references to current sets
- if ! ipset list | gawk '($1 == "References:" && $2 > 0) { exit 1 }'; then
- eerror "ipset is in use, can't stop"
- return 1
- fi
-
- if [ "${SAVE_ON_STOP}" = "yes" ] ; then
- save || return 1
- fi
-
- ebegin "Removing kernel IP sets"
- ipset destroy
- eend $?
-}
-
-save() {
- ebegin "Saving ipset session"
- touch "${IPSET_SAVE}"
- chmod 0600 "${IPSET_SAVE}"
- ipset save > "${IPSET_SAVE}"
- eend $?
-}
diff --git a/net-firewall/ipset/ipset-4.5.ebuild b/net-firewall/ipset/ipset-4.5.ebuild
deleted file mode 100644
index 2c0cdea00744..000000000000
--- a/net-firewall/ipset/ipset-4.5.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-4.5.ebuild,v 1.4 2011/09/16 13:26:44 chainsaw Exp $
-
-EAPI="2"
-
-inherit eutils versionator toolchain-funcs linux-mod
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.4"
-DEPEND="${RDEPEND}"
-
-# configurable from outside
-[ -z "${IP_NF_SET_MAX}" ] && IP_NF_SET_MAX=256
-[ -z "${IP_NF_SET_HASHSIZE}" ] && IP_NF_SET_HASHSIZE=1024
-BUILD_PARAMS="IP_NF_SET_MAX=$IP_NF_SET_MAX IP_NF_SET_HASHSIZE=${IP_NF_SET_HASHSIZE}"
-# module fun
-BUILD_TARGETS="all"
-MODULE_NAMES_ARG="kernel/net/ipv4/netfilter:${S}/kernel"
-MODULE_NAMES=""
-for i in ip_set{,_{setlist,{ip,port,macip}map,{ip,net,ipport,ipportip,ipportnet}hash,iptree{,map}}} \
- ipt_{SET,set}; do
- MODULE_NAMES="${MODULE_NAMES} ${i}(${MODULE_NAMES_ARG})"
-done
-# sanity
-CONFIG_CHECK="NETFILTER"
-ERROR_CFG="ipset requires netfilter support in your kernel."
-
-pkg_setup() {
- get_version
-
- build_modules=0
- if use modules; then
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_builtin "IP_NF_SET"; then #274577
- einfo "Modular kernel detected but IP_NF_SET=y, will not build kernel modules"
- else
- build_modules=1
- einfo "Modular kernel detected, will build kernel modules"
- fi
- else
- einfo "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
-
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
- myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/$(get_libdir)"
- myconf="${myconf} BINDIR=/sbin"
- myconf="${myconf} MANDIR=/usr/share/man"
- myconf="${myconf} INCDIR=/usr/include"
- myconf="${myconf} NO_EXTRA_WARN_FLAGS=yes"
- export myconf
-}
-
-src_prepare() {
- sed -i \
- -e 's/KERNELDIR/(KERNELDIR)/g' \
- -e 's/^(\?KERNEL_\?DIR.*/KERNELDIR ?= /' \
- -e '/^all::/iV ?= 0' \
- -e '/^all::/iKBUILD_OUTPUT ?=' \
- -e '/$(MAKE)/{s/$@/ V=$(V) KBUILD_OUTPUT=$(KBUILD_OUTPUT) modules/}' \
- "${S}"/kernel/Makefile
-}
-
-src_compile() {
- einfo "Building userspace"
- emake \
- CC="$(tc-getCC)" \
- COPT_FLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- ${myconf} \
- binaries || die "failed to build"
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- cd "${S}/kernel"
- export KERNELDIR="${KERNEL_DIR}"
- linux-mod_src_compile || die "failed to build modules"
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" ${myconf} binaries_install || die "failed to package"
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- cd "${S}/kernel"
- export KERNELDIR="${KERNEL_DIR}"
- linux-mod_src_install
- fi
-}
diff --git a/net-firewall/ipset/ipset-6.10.ebuild b/net-firewall/ipset/ipset-6.10.ebuild
deleted file mode 100644
index 6714e180e914..000000000000
--- a/net-firewall/ipset/ipset-6.10.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.10.ebuild,v 1.1 2011/12/17 03:30:59 pva Exp $
-
-EAPI="4"
-inherit autotools linux-info linux-mod
-
-# Maintainer: with version bump take a look on:
-# http://git.netfilter.org/cgi-bin/gitweb.cgi?p=ipset.git;a=commit;h=70fdf030545f00888bcebb5fca8243a6dccca95b
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.4
- net-libs/libmnl"
-DEPEND="${RDEPEND}"
-
-# configurable from outside, e.g. /etc/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,net{port,iface}},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-
-check_header_patch() {
- if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
- eerror "Sorry, but you have to patch kernel sources with the following patch:"
- eerror " # cd ${KV_DIR}"
- eerror " # patch -i ${S}/netlink.patch -p1"
- eerror "You should recompile and run new kernel to avoid runtime errors."
- die "Unpatched kernel"
- fi
-}
-
-pkg_setup() {
- get_version
- CONFIG_CHECK="NETFILTER"
- ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
-
- build_modules=0
- if use modules; then
- kernel_is -lt 2 6 35 && die "${PN} requires kernel greater then 2.6.35."
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_present "IP_NF_SET" || \
- linux_chkconfig_present "IP_SET"; then #274577
- eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
- eerror "Please either build ipset with modules USE flag disabled"
- eerror "or rebuild kernel without IP_SET support and make sure"
- eerror "there is NO kernel ip_set* modules in /lib/modules/<you_kernel>/... ."
- die "USE=modules and in-kernel ipset support detected."
- else
- einfo "Modular kernel detected. Gonna build kernel modules..."
- build_modules=1
- fi
- else
- eerror "Nonmodular kernel detected, but USE=modules. Either build"
- eerror "modular kernel (without IP_SET) or disable USE=modules"
- die "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- [[ ${build_modules} -eq 1 ]] && check_header_patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir="${EPREFIX}"/$(get_libdir) \
- --with-ksource="${KV_DIR}" \
- --with-kbuild="${KV_OUT_DIR}"
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" install
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
-
- newinitd ${FILESDIR}/ipset.initd-r2 ${PN}
- newconfd ${FILESDIR}/ipset.confd ${PN}
- keepdir /var/lib/ipset
- find "${ED}" \( -name '*.la' -o -name '*.a' \) -exec rm -f '{}' +
-}
diff --git a/net-firewall/ipset/ipset-6.11.ebuild b/net-firewall/ipset/ipset-6.11.ebuild
deleted file mode 100644
index 7418f37fd6e5..000000000000
--- a/net-firewall/ipset/ipset-6.11.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.11.ebuild,v 1.2 2012/06/14 05:57:20 xmw Exp $
-
-EAPI="4"
-inherit autotools linux-info linux-mod
-
-# Maintainer: with version bump take a look on:
-# http://git.netfilter.org/cgi-bin/gitweb.cgi?p=ipset.git;a=commit;h=70fdf030545f00888bcebb5fca8243a6dccca95b
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.4
- net-libs/libmnl"
-DEPEND="${RDEPEND}"
-
-# configurable from outside, e.g. /etc/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,net{port,iface}},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-
-check_header_patch() {
- if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
- eerror "Sorry, but you have to patch kernel sources with the following patch:"
- eerror " # cd ${KV_DIR}"
- eerror " # patch -i ${S}/netlink.patch -p1"
- eerror "You should recompile and run new kernel to avoid runtime errors."
- die "Unpatched kernel"
- fi
-}
-
-pkg_setup() {
- get_version
- CONFIG_CHECK="NETFILTER"
- ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
-
- build_modules=0
- if use modules; then
- kernel_is -lt 2 6 35 && die "${PN} requires kernel greater then 2.6.35."
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_present "IP_NF_SET" || \
- linux_chkconfig_present "IP_SET"; then #274577
- eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
- eerror "Please either build ipset with modules USE flag disabled"
- eerror "or rebuild kernel without IP_SET support and make sure"
- eerror "there is NO kernel ip_set* modules in /lib/modules/<you_kernel>/... ."
- die "USE=modules and in-kernel ipset support detected."
- else
- einfo "Modular kernel detected. Gonna build kernel modules..."
- build_modules=1
- fi
- else
- eerror "Nonmodular kernel detected, but USE=modules. Either build"
- eerror "modular kernel (without IP_SET) or disable USE=modules"
- die "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- [[ ${build_modules} -eq 1 ]] && check_header_patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir="${EPREFIX}"/$(get_libdir) \
- --with-ksource="${KV_DIR}" \
- --with-kbuild="${KV_OUT_DIR}"
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" install
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
-
- newinitd ${FILESDIR}/ipset.initd-r2 ${PN}
- newconfd ${FILESDIR}/ipset.confd ${PN}
- keepdir /var/lib/ipset
- find "${ED}" \( -name '*.la' -o -name '*.a' \) -exec rm -f '{}' +
-}
diff --git a/net-firewall/ipset/ipset-6.13.ebuild b/net-firewall/ipset/ipset-6.13.ebuild
deleted file mode 100644
index d5cf60a92e63..000000000000
--- a/net-firewall/ipset/ipset-6.13.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.13.ebuild,v 1.1 2012/08/20 05:19:02 robbat2 Exp $
-
-EAPI="4"
-inherit autotools linux-info linux-mod
-
-# Maintainer: with version bump take a look on:
-# http://git.netfilter.org/cgi-bin/gitweb.cgi?p=ipset.git;a=commit;h=70fdf030545f00888bcebb5fca8243a6dccca95b
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.4
- net-libs/libmnl"
-DEPEND="${RDEPEND}"
-
-# configurable from outside, e.g. /etc/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,net{port,iface}},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-
-check_header_patch() {
- if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
- eerror "Sorry, but you have to patch kernel sources with the following patch:"
- eerror " # cd ${KV_DIR}"
- eerror " # patch -i ${S}/netlink.patch -p1"
- eerror "You should recompile and run new kernel to avoid runtime errors."
- die "Unpatched kernel"
- fi
-}
-
-pkg_setup() {
- get_version
- CONFIG_CHECK="NETFILTER"
- ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
-
- build_modules=0
- if use modules; then
- kernel_is -lt 2 6 35 && die "${PN} requires kernel greater then 2.6.35."
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_present "IP_NF_SET" || \
- linux_chkconfig_present "IP_SET"; then #274577
- eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
- eerror "Please either build ipset with modules USE flag disabled"
- eerror "or rebuild kernel without IP_SET support and make sure"
- eerror "there is NO kernel ip_set* modules in /lib/modules/<your_kernel>/... ."
- die "USE=modules and in-kernel ipset support detected."
- else
- einfo "Modular kernel detected. Gonna build kernel modules..."
- build_modules=1
- fi
- else
- eerror "Nonmodular kernel detected, but USE=modules. Either build"
- eerror "modular kernel (without IP_SET) or disable USE=modules"
- die "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- [[ ${build_modules} -eq 1 ]] && check_header_patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with modules kmod) \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir="${EPREFIX}"/$(get_libdir) \
- --with-ksource="${KV_DIR}" \
- --with-kbuild="${KV_OUT_DIR}"
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" install
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
-
- newinitd ${FILESDIR}/ipset.initd-r2 ${PN}
- newconfd ${FILESDIR}/ipset.confd ${PN}
- keepdir /var/lib/ipset
- find "${ED}" \( -name '*.la' -o -name '*.a' \) -exec rm -f '{}' +
-}
diff --git a/net-firewall/ipset/ipset-6.14.ebuild b/net-firewall/ipset/ipset-6.14.ebuild
deleted file mode 100644
index 7a4a1009ea97..000000000000
--- a/net-firewall/ipset/ipset-6.14.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.14.ebuild,v 1.1 2012/11/27 11:30:02 pinkbyte Exp $
-
-EAPI="4"
-inherit autotools linux-info linux-mod
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.7
- net-libs/libmnl"
-DEPEND="${RDEPEND}"
-
-DOCS=( ChangeLog INSTALL README UPGRADE )
-
-# configurable from outside, e.g. /etc/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,net{port,iface}},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-
-check_header_patch() {
- if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
- eerror "Sorry, but you have to patch kernel sources with the following patch:"
- eerror " # cd ${KV_DIR}"
- eerror " # patch -i ${S}/netlink.patch -p1"
- eerror "You should recompile and run new kernel to avoid runtime errors."
- die "Unpatched kernel"
- fi
-}
-
-pkg_setup() {
- get_version
- CONFIG_CHECK="NETFILTER"
- ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
-
- build_modules=0
- if use modules; then
- kernel_is -lt 2 6 35 && die "${PN} requires kernel greater then 2.6.35."
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_present "IP_NF_SET" || \
- linux_chkconfig_present "IP_SET"; then #274577
- eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
- eerror "Please either build ipset with modules USE flag disabled"
- eerror "or rebuild kernel without IP_SET support and make sure"
- eerror "there is NO kernel ip_set* modules in /lib/modules/<your_kernel>/... ."
- die "USE=modules and in-kernel ipset support detected."
- else
- einfo "Modular kernel detected. Gonna build kernel modules..."
- build_modules=1
- fi
- else
- eerror "Nonmodular kernel detected, but USE=modules. Either build"
- eerror "modular kernel (without IP_SET) or disable USE=modules"
- die "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- [[ ${build_modules} -eq 1 ]] && check_header_patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with modules kmod) \
- --disable-static \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir="${EPREFIX}/$(get_libdir)" \
- --with-ksource="${KV_DIR}" \
- --with-kbuild="${KV_OUT_DIR}"
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- default
- prune_libtool_files
-
- newinitd "${FILESDIR}"/ipset.initd-r2 ${PN}
- newconfd "${FILESDIR}"/ipset.confd ${PN}
- keepdir /var/lib/ipset
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
-}
diff --git a/net-firewall/ipset/ipset-6.8.ebuild b/net-firewall/ipset/ipset-6.8.ebuild
deleted file mode 100644
index f17440dcf9f2..000000000000
--- a/net-firewall/ipset/ipset-6.8.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.8.ebuild,v 1.3 2011/09/16 13:26:44 chainsaw Exp $
-
-EAPI="4"
-inherit autotools linux-info linux-mod
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.4
- net-libs/libmnl"
-DEPEND="${RDEPEND}"
-
-# configurable from outside, e.g. /etc/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,net{port,iface}},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-CONFIG_CHECK="NETFILTER IP6_NF_IPTABLES !IP_SET"
-ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
-ERROR_IP6_NF_IPTABLES="ipset requires IP6_NF_IPTABLES support in your kernel."
-ERROR_IP_SET="There is IP_SET support in your kernel. Please build ipset with modules USE flag disabled or you may have troubles loading correct modules."
-
-check_header_patch() {
- if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
- eerror "Sorry, but you have to patch kernel sources with the following patch:"
- eerror " # cd ${KV_DIR}"
- eerror " # patch -i ${S}/netlink.patch -p1"
- eerror "You do not need to recompile your kernel."
- die "Unpatched kernel"
- fi
-}
-
-pkg_setup() {
- get_version
-
- build_modules=0
- if use modules; then
- kernel_is -lt 2 6 35 && die "${PN} requires kernel greater then 2.6.35."
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_builtin "IP_NF_SET"; then #274577
- einfo "Modular kernel detected but IP_NF_SET=y, will not build kernel modules"
- else
- if kernel_is -gt 2 6 39; then
- einfo "This kernel has modules inside, will not build kernel modules"
- else
- einfo "Modular kernel detected, will build kernel modules"
- build_modules=1
- fi
- fi
- else
- einfo "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
-
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- [[ ${build_modules} -eq 1 ]] && check_header_patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir="${EPREFIX}"/$(get_libdir) \
- --with-ksource="${KV_DIR}" \
- --with-kbuild="${KV_OUT_DIR}"
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" install
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
- find "${ED}" \( -name '*.la' -o -name '*.a' \) -exec rm -f '{}' +
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- elog "Note you need to rebuid and run kernel with netlink.patch or you'll get error:"
- elog "Kernel error received: Invalid argument"
-}
diff --git a/net-firewall/ipset/ipset-6.9.1-r2.ebuild b/net-firewall/ipset/ipset-6.9.1-r2.ebuild
deleted file mode 100644
index 6d89ad5ea9cb..000000000000
--- a/net-firewall/ipset/ipset-6.9.1-r2.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.9.1-r2.ebuild,v 1.2 2011/10/12 14:13:35 pva Exp $
-
-EAPI="4"
-inherit autotools linux-info linux-mod
-
-# Maintainer: with version bump take a look on:
-# http://git.netfilter.org/cgi-bin/gitweb.cgi?p=ipset.git;a=commit;h=70fdf030545f00888bcebb5fca8243a6dccca95b
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.4
- net-libs/libmnl"
-DEPEND="${RDEPEND}"
-
-# configurable from outside, e.g. /etc/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,net{port,iface}},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-
-check_header_patch() {
- if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
- eerror "Sorry, but you have to patch kernel sources with the following patch:"
- eerror " # cd ${KV_DIR}"
- eerror " # patch -i ${S}/netlink.patch -p1"
- eerror "You should recompile and run new kernel to avoid runtime errors."
- die "Unpatched kernel"
- fi
-}
-
-pkg_setup() {
- get_version
- CONFIG_CHECK="NETFILTER"
- ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
-
- build_modules=0
- if use modules; then
- kernel_is -lt 2 6 35 && die "${PN} requires kernel greater then 2.6.35."
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_present "IP_NF_SET" || \
- linux_chkconfig_present "IP_SET"; then #274577
- eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
- eerror "Please either build ipset with modules USE flag disabled"
- eerror "or rebuild kernel without IP_SET support and make sure"
- eerror "there is NO kernel ip_set* modules in /lib/modules/<you_kernel>/... ."
- die "USE=modules and in-kernel ipset support detected."
- else
- einfo "Modular kernel detected. Gonna build kernel modules..."
- build_modules=1
- fi
- else
- eerror "Nonmodular kernel detected, but USE=modules. Either build"
- eerror "modular kernel (without IP_SET) or disable USE=modules"
- die "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- [[ ${build_modules} -eq 1 ]] && check_header_patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir="${EPREFIX}"/$(get_libdir) \
- --with-ksource="${KV_DIR}" \
- --with-kbuild="${KV_OUT_DIR}"
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" install
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
-
- newinitd ${FILESDIR}/ipset.initd-r1 ${PN}
- keepdir /var/lib/ipset
- find "${ED}" \( -name '*.la' -o -name '*.a' \) -exec rm -f '{}' +
-}