summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-06-16 12:35:16 +0000
committerPeter Volkov <pva@gentoo.org>2011-06-16 12:35:16 +0000
commit5b54a507b6e567c4b6b62c56e8f3e57b63d116a3 (patch)
tree3d589133daf3a727c7638ac4e1151d28bd348c41 /net-firewall/iptables
parentVersion bump for dev channel release. Remove old. (diff)
downloadgentoo-2-5b54a507b6e567c4b6b62c56e8f3e57b63d116a3.tar.gz
gentoo-2-5b54a507b6e567c4b6b62c56e8f3e57b63d116a3.tar.bz2
gentoo-2-5b54a507b6e567c4b6b62c56e8f3e57b63d116a3.zip
Fix ip{,6}tables manpage generation.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog8
-rw-r--r--net-firewall/iptables/files/iptables-1.4.11.1-man-fixes.patch17
-rw-r--r--net-firewall/iptables/iptables-1.4.11.1-r1.ebuild84
3 files changed, 108 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index d79f377e1619..0fb33d3d5407 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.238 2011/06/14 02:12:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.239 2011/06/16 12:35:16 pva Exp $
+
+*iptables-1.4.11.1-r1 (16 Jun 2011)
+
+ 16 Jun 2011; Peter Volkov <pva@gentoo.org> +iptables-1.4.11.1-r1.ebuild,
+ +files/iptables-1.4.11.1-man-fixes.patch:
+ Fix ip{,6}tables manpage generation.
14 Jun 2011; Jeroen Roovers <jer@gentoo.org> iptables-1.4.10-r1.ebuild,
iptables-1.4.11.1.ebuild:
diff --git a/net-firewall/iptables/files/iptables-1.4.11.1-man-fixes.patch b/net-firewall/iptables/files/iptables-1.4.11.1-man-fixes.patch
new file mode 100644
index 000000000000..d83a7059f37b
--- /dev/null
+++ b/net-firewall/iptables/files/iptables-1.4.11.1-man-fixes.patch
@@ -0,0 +1,17 @@
+diff --git a/iptables/Makefile.am b/iptables/Makefile.am
+index 13cca9c..a068278 100644
+--- a/iptables/Makefile.am
++++ b/iptables/Makefile.am
+@@ -51,10 +51,10 @@ v6_sbin_links = ip6tables ip6tables-restore ip6tables-save
+ endif
+
+ iptables.8: ${srcdir}/iptables.8.in ../extensions/matches4.man ../extensions/targets4.man
+- ${AM_VERBOSE_GEN} sed -e 's/@PACKAGE_AND_VERSION@/${PACKAGE} ${PACKAGE_VERSION}/g' -e '/@MATCH@/ r extensions/matches4.man' -e '/@TARGET@/ r extensions/targets4.man' $< >$@;
++ ${AM_VERBOSE_GEN} sed -e 's/@PACKAGE_AND_VERSION@/${PACKAGE} ${PACKAGE_VERSION}/g' -e '/@MATCH@/ r ../extensions/matches4.man' -e '/@TARGET@/ r ../extensions/targets4.man' $< >$@;
+
+ ip6tables.8: ${srcdir}/ip6tables.8.in ../extensions/matches6.man ../extensions/targets6.man
+- ${AM_VERBOSE_GEN} sed -e 's/@PACKAGE_AND_VERSION@/${PACKAGE} ${PACKAGE_VERSION}/g' -e '/@MATCH@/ r extensions/matches6.man' -e '/@TARGET@/ r extensions/targets6.man' $< >$@;
++ ${AM_VERBOSE_GEN} sed -e 's/@PACKAGE_AND_VERSION@/${PACKAGE} ${PACKAGE_VERSION}/g' -e '/@MATCH@/ r ../extensions/matches6.man' -e '/@TARGET@/ r ../extensions/targets6.man' $< >$@;
+
+ pkgconfig_DATA = xtables.pc
+
diff --git a/net-firewall/iptables/iptables-1.4.11.1-r1.ebuild b/net-firewall/iptables/iptables-1.4.11.1-r1.ebuild
new file mode 100644
index 000000000000..32a1d4fb8a06
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.11.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.11.1-r1.ebuild,v 1.1 2011/06/16 12:35:16 pva Exp $
+
+EAPI="4"
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 netlink"
+
+COMMON_DEPEND="
+ netlink? ( net-libs/libnfnetlink )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/os-headers
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+
+src_prepare() {
+ # Only run autotools if user patched something
+ epatch "${FILESDIR}/${P}-man-fixes.patch"
+ epatch_user && eautoreconf || elibtoolize
+}
+
+src_configure() {
+ sed -i \
+ -e "/nfnetlink=[01]/s:=[01]:=$(use netlink && echo 1 || echo 0):" \
+ configure
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc INCOMPATIBILITIES iptables/iptables.xslt
+
+ # all the iptables binaries are in /sbin, so might as well
+ # put these small files in with them
+ into /
+ dosbin iptables/iptables-apply
+ dosym iptables-apply /sbin/ip6tables-apply
+ doman iptables/iptables-apply.8
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h)
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables
+ fi
+
+ # Move important libs to /lib
+ gen_usr_ldscript -a ip{4,6}tc ipq iptc xtables
+ find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}