summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2013-03-17 09:31:45 +0000
committerConstanze Hausner <constanze@gentoo.org>2013-03-17 09:31:45 +0000
commit7ef90633009e71d6820cb024c5c03ff3c1079a7f (patch)
tree7173d6a8d01981f9840459fe98547f8c49a72bed /net-firewall/shorewall6
parentCheck for presence of file before changing its permissions. Bug #461962, repo... (diff)
downloadgentoo-2-7ef90633009e71d6820cb024c5c03ff3c1079a7f.tar.gz
gentoo-2-7ef90633009e71d6820cb024c5c03ff3c1079a7f.tar.bz2
gentoo-2-7ef90633009e71d6820cb024c5c03ff3c1079a7f.zip
Changed keepdir to dodir with regard to bug 459316
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key BB80F419010E3EC3)
Diffstat (limited to 'net-firewall/shorewall6')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/shorewall6-4.5.11.2-r1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index b75bf2d13264..2cc8427f09ee 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.63 2013/02/12 20:27:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.64 2013/03/17 09:31:45 constanze Exp $
+
+*shorewall6-4.5.11.2-r1 (17 Mar 2013)
+
+ 17 Mar 2013; Constanze Hausner <constanze@gentoo.org>
+ +shorewall6-4.5.11.2-r1.ebuild:
+ Changed keepdir to dodir with regard to bug #459316
12 Feb 2013; Agostino Sarubbo <ago@gentoo.org> shorewall6-4.5.8.2-r1.ebuild:
Stable for sparc, wrt bug #452830
diff --git a/net-firewall/shorewall6/shorewall6-4.5.11.2-r1.ebuild b/net-firewall/shorewall6/shorewall6-4.5.11.2-r1.ebuild
new file mode 100644
index 000000000000..c99e5db046dc
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.5.11.2-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.5.11.2-r1.ebuild,v 1.1 2013/03/17 09:31:45 constanze Exp $
+
+EAPI="4"
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}"
+MY_P_DOCS="${MY_PN}-docs-html-${PV}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+RDEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}"
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc_new || die "install.sh failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples6
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ dodir /var/lock/subsys
+}