summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-19 21:36:51 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-19 21:36:51 +0000
commit05cf0b6cf5faf5127cd9b101afb2df27eab5870e (patch)
tree32189efc768aa9c01785f740d30e6f18536d48f3 /net-firewall
parentLast patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug 332957).... (diff)
downloadgentoo-2-05cf0b6cf5faf5127cd9b101afb2df27eab5870e.tar.gz
gentoo-2-05cf0b6cf5faf5127cd9b101afb2df27eab5870e.tar.bz2
gentoo-2-05cf0b6cf5faf5127cd9b101afb2df27eab5870e.zip
Only force autotools on people using epatch_user, and clean up the lib move from /usr to / #332175.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog6
-rw-r--r--net-firewall/iptables/iptables-1.4.9.1-r2.ebuild19
2 files changed, 14 insertions, 11 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index d1a3cbe9c4fe..1bfc03338d59 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.222 2010/08/12 13:22:33 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.223 2010/08/19 21:36:51 vapier Exp $
+
+ 19 Aug 2010; Mike Frysinger <vapier@gentoo.org> iptables-1.4.9.1-r2.ebuild:
+ Only force autotools on people using epatch_user, and clean up the lib move
+ from /usr to / #332175.
*iptables-1.4.9.1-r2 (12 Aug 2010)
diff --git a/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild b/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild
index 0519c5278c39..602860205e4d 100644
--- a/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild
+++ b/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild
@@ -1,8 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild,v 1.1 2010/08/12 13:22:33 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.9.1-r2.ebuild,v 1.2 2010/08/19 21:36:51 vapier Exp $
EAPI="2"
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
inherit eutils toolchain-funcs autotools
DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
@@ -18,14 +22,13 @@ DEPEND="virtual/os-headers"
RDEPEND=""
src_prepare() {
- epatch_user
- eautoreconf
+ # Only run autotools if user patched something
+ epatch_user && eautoreconf || elibtoolize
}
src_configure() {
econf \
--sbindir=/sbin \
- --libdir=/$(get_libdir) \
--libexecdir=/$(get_libdir) \
--enable-devel \
--enable-libipq \
@@ -58,10 +61,6 @@ src_install() {
newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
fi
- # Remove .la from /lib, keep static archives in /usr/lib
- find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
- dodir /usr/$(get_libdir)/
- mv "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/ || die "failed to mv static libs"
- mv "${D}"{/,/usr/}"$(get_libdir)"/pkgconfig || die "failed to mv pkg-config files"
- gen_usr_ldscript libip4tc.so libip6tc.so libipq.so libiptc.so libxtables.so
+ # Move important libs to /lib
+ gen_usr_ldscript -a ip{4,6}tc ipq iptc xtables
}