summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-12-08 00:05:22 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-12-08 00:05:22 +0000
commitd725b7a0eee700042fdedeed183237dd945fc4fb (patch)
treed779a9d3db697d3296a5e8b37aa3368d46ede154 /net-firewall
parentChanged deps for wxgtk, marked stable x86 (diff)
downloadgentoo-2-d725b7a0eee700042fdedeed183237dd945fc4fb.tar.gz
gentoo-2-d725b7a0eee700042fdedeed183237dd945fc4fb.tar.bz2
gentoo-2-d725b7a0eee700042fdedeed183237dd945fc4fb.zip
Converted to linux-mod eclass.
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipp2p/ChangeLog8
-rw-r--r--net-firewall/ipp2p/Manifest12
-rw-r--r--net-firewall/ipp2p/files/digest-ipp2p-0.6-r11
-rw-r--r--net-firewall/ipp2p/ipp2p-0.6-r1.ebuild59
4 files changed, 69 insertions, 11 deletions
diff --git a/net-firewall/ipp2p/ChangeLog b/net-firewall/ipp2p/ChangeLog
index a2040f163204..1eb5056e3a8b 100644
--- a/net-firewall/ipp2p/ChangeLog
+++ b/net-firewall/ipp2p/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipp2p
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.2 2004/12/06 20:31:38 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.3 2004/12/08 00:05:22 eradicator Exp $
+
+*ipp2p-0.6-r1 (07 Dec 2004)
+
+ 07 Dec 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +ipp2p-0.6-r1.ebuild:
+ Converted to linux-mod eclass.
06 Dec 2004; Jeremy Huddleston <eradicator@gentoo.org> ipp2p-0.6.ebuild:
Updated HOMEPAGE per request of upstream author. Stable amd64, x86.
diff --git a/net-firewall/ipp2p/Manifest b/net-firewall/ipp2p/Manifest
index 6c380a08004e..1f3281ca5ac7 100644
--- a/net-firewall/ipp2p/Manifest
+++ b/net-firewall/ipp2p/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 3ee568b63d3eb9028fa9214414c94986 ipp2p-0.6.ebuild 1019
MD5 3923b6ae9bc25fc124e24e7747c8a802 metadata.xml 226
MD5 e26153e9c70f6ec79b79080ac9ae52e1 ChangeLog 538
+MD5 292fbaa5c503ead4314b78aa93061f43 ipp2p-0.6-r1.ebuild 1086
MD5 7dde11c31f867f3b9c624ac8dcb944a4 files/digest-ipp2p-0.6 58
MD5 210b099d966d09350c8cfc0d81ec56ce files/ipp2p-0.6-Makefile.patch 996
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBtMI9ArHZZzCEUG0RAjy/AJoCTozCV3Bj7kbPyMYGTUZzshm02wCdFUqG
-ToFAVjk/PoLyRhJBHQYQCX8=
-=KLx0
------END PGP SIGNATURE-----
+MD5 7dde11c31f867f3b9c624ac8dcb944a4 files/digest-ipp2p-0.6-r1 58
diff --git a/net-firewall/ipp2p/files/digest-ipp2p-0.6-r1 b/net-firewall/ipp2p/files/digest-ipp2p-0.6-r1
new file mode 100644
index 000000000000..bf369b132197
--- /dev/null
+++ b/net-firewall/ipp2p/files/digest-ipp2p-0.6-r1
@@ -0,0 +1 @@
+MD5 9ac3ab4f48755500dbb0020292088efe ipp2p.06.tar.gz 6752
diff --git a/net-firewall/ipp2p/ipp2p-0.6-r1.ebuild b/net-firewall/ipp2p/ipp2p-0.6-r1.ebuild
new file mode 100644
index 000000000000..376f6a865d6f
--- /dev/null
+++ b/net-firewall/ipp2p/ipp2p-0.6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.6-r1.ebuild,v 1.1 2004/12/08 00:05:22 eradicator Exp $
+
+IUSE=""
+
+inherit linux-mod eutils
+
+MY_PV=${PV/./}
+MY_P="${PN}.${MY_PV}"
+S="${WORKDIR}/${PN}"
+
+DESCRIPTION="Netfilter module for dealing with P2P Applications."
+HOMEPAGE="http://www.ipp2p.org/index_en.html"
+SRC_URI="http://www.ipp2p.org/downloads/${MY_P}.tar.gz"
+
+SLOT="${KV}"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/modutils"
+
+DEPEND="${RDEPEND}
+ >=net-firewall/iptables-1.2.11
+ virtual/linux-sources"
+
+pkg_setup() {
+ CONFIG_CHECK="NETFILTER"
+ NETFILTER_ERROR="Your kernel is not configured to support Netfilter."
+ MODULE_NAMES="ipt_ipp2p"
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-Makefile.patch
+}
+
+src_compile() {
+ xarch="${ARCH}"
+ unset ARCH
+ emake KERNEL_SRC=${KV_DIR} || die "Parallel Make Failed"
+ ARCH="${xarch}"
+}
+
+src_install() {
+ exeinto /$(get_libdir)/iptables
+ doexe libipt_ipp2p.so
+
+ dodoc README
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}