summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-03-16 07:57:29 +0000
committerPeter Volkov <pva@gentoo.org>2010-03-16 07:57:29 +0000
commitec83ec184a665fbf3c611a953250579803824b01 (patch)
tree7b079696125e996a5ccf058bdedc1766a2f7d26d /net-firewall
parentVersion bump, #309479 thank hitachi for report. (diff)
downloadgentoo-2-ec83ec184a665fbf3c611a953250579803824b01.tar.gz
gentoo-2-ec83ec184a665fbf3c611a953250579803824b01.tar.bz2
gentoo-2-ec83ec184a665fbf3c611a953250579803824b01.zip
Version bump, #309475 thank hitachi for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/arptables/ChangeLog9
-rw-r--r--net-firewall/arptables/arptables-0.0.3.4.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/net-firewall/arptables/ChangeLog b/net-firewall/arptables/ChangeLog
index c763f7b994c7..20f86d4c03fa 100644
--- a/net-firewall/arptables/ChangeLog
+++ b/net-firewall/arptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/arptables
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/arptables/ChangeLog,v 1.14 2008/10/13 11:13:26 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/arptables/ChangeLog,v 1.15 2010/03/16 07:57:29 pva Exp $
+
+*arptables-0.0.3.4 (16 Mar 2010)
+
+ 16 Mar 2010; Peter Volkov <pva@gentoo.org> +arptables-0.0.3.4.ebuild:
+ Version bump, #309475 thank hitachi for report.
13 Oct 2008; Peter Volkov <pva@gentoo.org> arptables-0.0.3.3-r1.ebuild:
Fixed build issue when no optimisation or only -O0 was passed in CFLAGS,
diff --git a/net-firewall/arptables/arptables-0.0.3.4.ebuild b/net-firewall/arptables/arptables-0.0.3.4.ebuild
new file mode 100644
index 000000000000..9dc1a4dfa779
--- /dev/null
+++ b/net-firewall/arptables/arptables-0.0.3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/arptables/arptables-0.0.3.4.ebuild,v 1.1 2010/03/16 07:57:29 pva Exp $
+
+EAPI="2"
+inherit versionator eutils
+
+MY_P=${PN}-v$(replace_version_separator 3 - )
+
+DESCRIPTION="set up, maintain, and inspect the tables of ARP rules in the Linux kernel"
+HOMEPAGE="http://ebtables.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ebtables/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # -O0 does not work and at least -O2 is required, bug #240752
+ emake CC="$(tc-getCC)" COPT_FLAGS="-O2 ${CFLAGS//-O0/-O2}" || die "make failed"
+ sed -ie 's:__EXEC_PATH__:/sbin:g' arptables-save arptables-restore \
+ || die "sed failed"
+}
+
+src_install() {
+ into /
+ dosbin arptables arptables-restore arptables-save || die
+ doman arptables.8 || die
+}