summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-20 20:02:54 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-20 20:02:54 +0000
commitf1912c9771d63e03ccd36e0c370b972fcd2f549c (patch)
tree648f1d13b1b1dd8a873da2716af579bc1060641e /net-fs/samba
parentfix PATH in gunzip. bug #210871 (diff)
downloadgentoo-2-f1912c9771d63e03ccd36e0c370b972fcd2f549c.tar.gz
gentoo-2-f1912c9771d63e03ccd36e0c370b972fcd2f549c.tar.bz2
gentoo-2-f1912c9771d63e03ccd36e0c370b972fcd2f549c.zip
Added patches to fix bugs #210527 and #210662 and the broken-readdir detection.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-fs/samba')
-rw-r--r--net-fs/samba/ChangeLog10
-rw-r--r--net-fs/samba/files/3.0.28-fix_broken_readdir_detection.patch18
-rw-r--r--net-fs/samba/files/3.0.28-inotify_include.patch53
-rw-r--r--net-fs/samba/files/3.0.28-libcap_detection.patch40
-rw-r--r--net-fs/samba/samba-3.0.28.ebuild13
5 files changed, 129 insertions, 5 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 44108ed3102a..078703e39aa5 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/samba
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.327 2007/12/18 18:57:34 dev-zero Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.328 2008/02/20 20:02:53 dev-zero Exp $
+
+ 20 Feb 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/3.0.28-fix_broken_readdir_detection.patch,
+ +files/3.0.28-inotify_include.patch, +files/3.0.28-libcap_detection.patch,
+ samba-3.0.28.ebuild:
+ Added patches to fix bugs #210527 and #210662 and the broken-readdir detection.
18 Dec 2007; Tiziano Müller <dev-zero@gentoo.org>
-files/3.0.25c-CVE-2007-4138.patch, -files/3.0.25c-lazyldflags.patch,
diff --git a/net-fs/samba/files/3.0.28-fix_broken_readdir_detection.patch b/net-fs/samba/files/3.0.28-fix_broken_readdir_detection.patch
new file mode 100644
index 000000000000..47f33d7bb920
--- /dev/null
+++ b/net-fs/samba/files/3.0.28-fix_broken_readdir_detection.patch
@@ -0,0 +1,18 @@
+diff -Naur samba-3.0.28.orig/source/tests/os2_delete.c samba-3.0.28/source/tests/os2_delete.c
+--- samba-3.0.28.orig/source/tests/os2_delete.c 2007-11-15 04:15:04.000000000 +0100
++++ samba-3.0.28/source/tests/os2_delete.c 2008-02-20 20:47:53.878055947 +0100
+@@ -105,6 +105,9 @@
+
+ return 0;
+ }
++
++#if 0
++
+ /*
+ test readdir/unlink pattern that OS/2 uses
+ tridge@samba.org July 2005
+@@ -212,3 +215,4 @@
+
+ return 0;
+ }
++#endif
diff --git a/net-fs/samba/files/3.0.28-inotify_include.patch b/net-fs/samba/files/3.0.28-inotify_include.patch
new file mode 100644
index 000000000000..7ce8078b9ecd
--- /dev/null
+++ b/net-fs/samba/files/3.0.28-inotify_include.patch
@@ -0,0 +1,53 @@
+diff -Naur samba-3.0.28.orig/source/configure.in samba-3.0.28/source/configure.in
+--- samba-3.0.28.orig/source/configure.in 2007-11-21 04:58:01.000000000 +0100
++++ samba-3.0.28/source/configure.in 2008-02-19 17:56:52.383852151 +0100
+@@ -2541,7 +2541,7 @@
+
+ AC_CACHE_CHECK([for inotify support],samba_cv_HAVE_INOTIFY,[
+ AC_CHECK_HEADERS(linux/inotify.h asm/unistd.h)
+-AC_CHECK_FUNC(inotify_init)
++AC_CHECK_FUNCS([inotify_init])
+ AC_HAVE_DECL(__NR_inotify_init, [#include <asm/unistd.h>])
+ ],
+ samba_cv_HAVE_INOTIFY=yes,
+diff -Naur samba-3.0.28.orig/source/include/config.h.in samba-3.0.28/source/include/config.h.in
+--- samba-3.0.28.orig/source/include/config.h.in 2007-12-10 17:04:29.000000000 +0100
++++ samba-3.0.28/source/include/config.h.in 2008-02-19 17:58:05.092981395 +0100
+@@ -685,6 +685,9 @@
+ /* Whether kernel has inotify support */
+ #undef HAVE_INOTIFY
+
++/* Whether system libc defines the inotify_init function */
++#undef HAVE_INOTIFY_INIT
++
+ /* Whether int16 typedef is included by rpc/rpc.h */
+ #undef HAVE_INT16_FROM_RPC_RPC_H
+
+diff -Naur samba-3.0.28.orig/source/smbd/notify_inotify.c samba-3.0.28/source/smbd/notify_inotify.c
+--- samba-3.0.28.orig/source/smbd/notify_inotify.c 2007-11-15 04:15:04.000000000 +0100
++++ samba-3.0.28/source/smbd/notify_inotify.c 2008-02-19 17:56:52.387155138 +0100
+@@ -30,10 +30,12 @@
+ #include <asm/types.h>
+ #endif
+
++#ifndef HAVE_INOTIFY_INIT
++
+ #include <linux/inotify.h>
+ #include <asm/unistd.h>
+
+-#ifndef HAVE_INOTIFY_INIT
++
+ /*
+ glibc doesn't define these functions yet (as of March 2006)
+ */
+@@ -51,6 +53,10 @@
+ {
+ return syscall(__NR_inotify_rm_watch, fd, wd);
+ }
++#else
++
++#include <sys/inotify.h>
++
+ #endif
+
+
diff --git a/net-fs/samba/files/3.0.28-libcap_detection.patch b/net-fs/samba/files/3.0.28-libcap_detection.patch
new file mode 100644
index 000000000000..991375c636cd
--- /dev/null
+++ b/net-fs/samba/files/3.0.28-libcap_detection.patch
@@ -0,0 +1,40 @@
+diff -Naurb samba-3.0.28.orig/source/configure.in samba-3.0.28/source/configure.in
+--- samba-3.0.28.orig/source/configure.in 2007-11-21 04:58:01.000000000 +0100
++++ samba-3.0.28/source/configure.in 2008-02-20 14:31:05.167709211 +0100
+@@ -2663,6 +2663,7 @@
+ if test x"$samba_cv_HAVE_POSIX_CAPABILITIES" = x"yes"; then
+ AC_DEFINE(HAVE_POSIX_CAPABILITIES, 1,
+ [Whether POSIX capabilities are available])
++ AC_CHECK_DECLS([capget], , , [#include <sys/capability.h>])
+ else
+ LIBS=$ac_save_LIBS
+ fi
+diff -Naurb samba-3.0.28.orig/source/include/config.h.in samba-3.0.28/source/include/config.h.in
+--- samba-3.0.28.orig/source/include/config.h.in 2007-12-10 17:04:29.000000000 +0100
++++ samba-3.0.28/source/include/config.h.in 2008-02-20 14:32:41.246837408 +0100
+@@ -1211,6 +1211,9 @@
+ /* Whether POSIX capabilities are available */
+ #undef HAVE_POSIX_CAPABILITIES
+
++/* Whether the capget (and capset) function is available (libcap-2.x has it) */
++#undef HAVE_DECL_CAPGET
++
+ /* Whether posix_fadvise is available */
+ #undef HAVE_POSIX_FADVISE
+
+diff -Naurb samba-3.0.28.orig/source/smbd/oplock_linux.c samba-3.0.28/source/smbd/oplock_linux.c
+--- samba-3.0.28.orig/source/smbd/oplock_linux.c 2007-11-15 04:15:04.000000000 +0100
++++ samba-3.0.28/source/smbd/oplock_linux.c 2008-02-20 14:31:48.327720338 +0100
+@@ -34,10 +34,12 @@
+ uint32 inheritable;
+ } data;
+
++#if defined HAVE_DECL_CAPGET && !HAVE_DECL_CAPGET
+ extern int capget(struct cap_user_header * hdrp,
+ struct cap_user_data * datap);
+ extern int capset(struct cap_user_header * hdrp,
+ const struct cap_user_data * datap);
++#endif
+
+ static SIG_ATOMIC_T signals_received;
+ #define FD_PENDING_SIZE 100
diff --git a/net-fs/samba/samba-3.0.28.ebuild b/net-fs/samba/samba-3.0.28.ebuild
index 1eab0f7f6b29..d6ce6f04257f 100644
--- a/net-fs/samba/samba-3.0.28.ebuild
+++ b/net-fs/samba/samba-3.0.28.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.28.ebuild,v 1.3 2007/12/29 10:27:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.28.ebuild,v 1.4 2008/02/20 20:02:53 dev-zero Exp $
-inherit eutils pam python multilib versionator confutils
+inherit autotools eutils pam python multilib versionator confutils
MY_P=${PN}-${PV/_/}
@@ -53,6 +53,12 @@ src_unpack() {
# Bug #196015 (upstream: #5021)
epatch "${FILESDIR}/3.0.26a-invalid-free-fix.patch"
+ epatch "${FILESDIR}/${PV}-libcap_detection.patch" \
+ "${FILESDIR}/${PV}-inotify_include.patch" \
+ "${FILESDIR}/${PV}-fix_broken_readdir_detection.patch"
+
+ eautoconf -I. -Ilib/replace
+
# Ok, agreed, this is ugly. But it avoids a patch we
# need for every samba version and we don't need autotools
sed -i \
@@ -61,6 +67,7 @@ src_unpack() {
configure || die "sed failed"
rm "${S}/docs/manpages"/{mount,umount}.cifs.8
+
}
src_compile() {