summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-01 22:10:08 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-01 22:10:08 +0000
commita61b84f4373efe65ee94cecf1089e7cb6e2462da (patch)
tree144e22d4258ce3dc7c5915d646a7492195075745 /net-ftp/atftp
parentMask recent nvidia drivers in KDE profiles because of sigprocmask corruption,... (diff)
downloadgentoo-2-a61b84f4373efe65ee94cecf1089e7cb6e2462da.tar.gz
gentoo-2-a61b84f4373efe65ee94cecf1089e7cb6e2462da.tar.bz2
gentoo-2-a61b84f4373efe65ee94cecf1089e7cb6e2462da.zip
Add unit file, bug #492698 by Christian Strahl
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-ftp/atftp')
-rw-r--r--net-ftp/atftp/ChangeLog10
-rw-r--r--net-ftp/atftp/atftp-0.7-r3.ebuild72
-rw-r--r--net-ftp/atftp/files/atftp.service9
-rw-r--r--net-ftp/atftp/files/atftp.service.conf2
4 files changed, 91 insertions, 2 deletions
diff --git a/net-ftp/atftp/ChangeLog b/net-ftp/atftp/ChangeLog
index 29fce8c79466..d0fafb1b5bc4 100644
--- a/net-ftp/atftp/ChangeLog
+++ b/net-ftp/atftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/atftp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/ChangeLog,v 1.30 2012/05/13 11:13:32 swift Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/ChangeLog,v 1.31 2013/12/01 22:10:08 pacho Exp $
+
+*atftp-0.7-r3 (01 Dec 2013)
+
+ 01 Dec 2013; Pacho Ramos <pacho@gentoo.org> +atftp-0.7-r3.ebuild,
+ +files/atftp.service, +files/atftp.service.conf:
+ Add unit file, bug #492698 by Christian Strahl
13 May 2012; <swift@gentoo.org> atftp-0.7-r1.ebuild, atftp-0.7-r2.ebuild:
SELinux policy module for TFTP is provided by selinux-tftp
diff --git a/net-ftp/atftp/atftp-0.7-r3.ebuild b/net-ftp/atftp/atftp-0.7-r3.ebuild
new file mode 100644
index 000000000000..da9493396466
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.7-r3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/atftp-0.7-r3.ebuild,v 1.1 2013/12/01 22:10:08 pacho Exp $
+
+EAPI=5
+inherit eutils flag-o-matic systemd
+
+DEBIAN_PV="11"
+DEBIAN_A="${PN}_${PV}-${DEBIAN_PV}.diff.gz"
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
+SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz
+ mirror://debian/pool/main/a/${PN}/${DEBIAN_A}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="selinux tcpd readline pcre"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ selinux? ( sec-policy/selinux-tftp )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}
+ !net-ftp/netkit-tftp
+ !net-ftp/tftp-hpa"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${DEBIAN_A}
+ epatch "${FILESDIR}"/${P}-pcre.patch
+ epatch "${FILESDIR}"/${P}-password.patch
+ epatch "${FILESDIR}"/${P}-tests.patch
+ epatch "${FILESDIR}"/${P}-glibc24.patch
+ epatch "${FILESDIR}"/${P}-blockno.patch
+ epatch "${FILESDIR}"/${P}-spaced_filename.patch
+ epatch "${FILESDIR}"/${P}-illreply.patch
+ # remove upstream's broken CFLAGS
+ sed -i.orig -e \
+ '/^CFLAGS="-g -Wall -D_REENTRANT"/s,".*","",g' \
+ "${S}"/configure
+}
+
+src_configure() {
+ append-flags -D_REENTRANT -DRATE_CONTROL
+ econf \
+ $(use_enable tcpd libwrap) \
+ $(use_enable readline libreadline) \
+ $(use_enable pcre libpcre) \
+ --enable-mtftp
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
+
+ systemd_dounit "${FILESDIR}"/atftp.service
+ systemd_install_serviced "${FILESDIR}"/atftp.service.conf
+
+ dodoc README* BUGS FAQ Changelog INSTALL TODO
+ dodoc "${S}"/docs/*
+
+ docinto test
+ cd "${S}"/test
+ dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
+}
diff --git a/net-ftp/atftp/files/atftp.service b/net-ftp/atftp/files/atftp.service
new file mode 100644
index 000000000000..e6570f63445c
--- /dev/null
+++ b/net-ftp/atftp/files/atftp.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Advanced TFTP implementation client/server
+After=syslog.target network.target
+
+[Service]
+ExecStart=/usr/sbin/atftpd --daemon --no-fork --user nobody --group nobody $TFTPD_ROOT
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-ftp/atftp/files/atftp.service.conf b/net-ftp/atftp/files/atftp.service.conf
new file mode 100644
index 000000000000..d8aa19abe32f
--- /dev/null
+++ b/net-ftp/atftp/files/atftp.service.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment="TFTPD_ROOT=/tftproot"