summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-03-20 14:28:32 +0000
committerAron Griffis <agriffis@gentoo.org>2003-03-20 14:28:32 +0000
commitbebea2c9080175a929a13e42dcc74e7b10e27e09 (patch)
treeff6cf97ff20ee4a1989b75603a6073ac874a28b8 /net-ftp/curl
parentRemoved usage of pic USE flag (diff)
downloadgentoo-2-bebea2c9080175a929a13e42dcc74e7b10e27e09.tar.gz
gentoo-2-bebea2c9080175a929a13e42dcc74e7b10e27e09.tar.bz2
gentoo-2-bebea2c9080175a929a13e42dcc74e7b10e27e09.zip
remove pic
Diffstat (limited to 'net-ftp/curl')
-rw-r--r--net-ftp/curl/ChangeLog8
-rw-r--r--net-ftp/curl/curl-7.10.2.ebuild5
-rw-r--r--net-ftp/curl/curl-7.10.3-r1.ebuild33
-rw-r--r--net-ftp/curl/curl-7.10.3.ebuild5
4 files changed, 44 insertions, 7 deletions
diff --git a/net-ftp/curl/ChangeLog b/net-ftp/curl/ChangeLog
index e10839172dfe..847e4981c0b9 100644
--- a/net-ftp/curl/ChangeLog
+++ b/net-ftp/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/curl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/ChangeLog,v 1.11 2003/03/09 20:37:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/ChangeLog,v 1.12 2003/03/20 14:28:32 agriffis Exp $
+
+*curl-7.10.3-r1 (20 Mar 2003)
+
+ 20 Mar 2003; Aron Griffis <agriffis@gentoo.org> curl-7.10.2.ebuild,
+ curl-7.10.3-r1.ebuild, curl-7.10.3.ebuild:
+ Remove pic USE-flag and bump rev
*curl-7.10.3 (28 Feb 2003)
diff --git a/net-ftp/curl/curl-7.10.2.ebuild b/net-ftp/curl/curl-7.10.2.ebuild
index 83e9209f561c..d3fc57af71df 100644
--- a/net-ftp/curl/curl-7.10.2.ebuild
+++ b/net-ftp/curl/curl-7.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/curl-7.10.2.ebuild,v 1.7 2003/02/28 16:55:00 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/curl-7.10.2.ebuild,v 1.8 2003/03/20 14:28:32 agriffis Exp $
DESCRIPTION="A Client that groks URLs"
SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
@@ -9,7 +9,7 @@ HOMEPAGE="http://curl.haxx.se/"
SLOT="0"
LICENSE="MIT X11"
KEYWORDS="x86 ppc sparc alpha"
-IUSE="ssl pic ipv6 ldap"
+IUSE="ssl ipv6 ldap"
DEPEND=">=sys-libs/pam-0.75
ssl? ( >=dev-libs/openssl-0.9.6a )"
@@ -19,7 +19,6 @@ src_compile() {
--enable-dict --enable-telnet --enable-nonblocking"
use ipv6 && myconf="${myconf} --enable-ipv6"
use ldap && myconf="${myconf} --enable-ldap"
- use pic && myconf="${myconf} --with-pic"
use ssl && myconf="${myconf} --with-ssl"
econf ${myconf}
diff --git a/net-ftp/curl/curl-7.10.3-r1.ebuild b/net-ftp/curl/curl-7.10.3-r1.ebuild
new file mode 100644
index 000000000000..9e2e5ba99393
--- /dev/null
+++ b/net-ftp/curl/curl-7.10.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/curl-7.10.3-r1.ebuild,v 1.1 2003/03/20 14:28:32 agriffis Exp $
+
+DESCRIPTION="A Client that groks URLs"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+HOMEPAGE="http://curl.haxx.se/"
+
+SLOT="0"
+LICENSE="MIT X11"
+KEYWORDS="~x86 ~ppc ~sparc alpha"
+IUSE="ssl ipv6 ldap"
+
+DEPEND=">=sys-libs/pam-0.75
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_compile() {
+ local myconf="--with-gnu-ld --enable-http --enable-ftp --enable-gopher --enable-file \
+ --enable-dict --enable-telnet --enable-nonblocking"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+ use ldap && myconf="${myconf} --enable-ldap"
+ use ssl && myconf="${myconf} --with-ssl"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc LEGAL CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-ftp/curl/curl-7.10.3.ebuild b/net-ftp/curl/curl-7.10.3.ebuild
index 7eb2413f8fac..8dfe74e3478d 100644
--- a/net-ftp/curl/curl-7.10.3.ebuild
+++ b/net-ftp/curl/curl-7.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/curl-7.10.3.ebuild,v 1.2 2003/03/09 20:37:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/curl-7.10.3.ebuild,v 1.3 2003/03/20 14:28:32 agriffis Exp $
DESCRIPTION="A Client that groks URLs"
SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
@@ -9,7 +9,7 @@ HOMEPAGE="http://curl.haxx.se/"
SLOT="0"
LICENSE="MIT X11"
KEYWORDS="~x86 ~ppc ~sparc alpha"
-IUSE="ssl pic ipv6 ldap"
+IUSE="ssl ipv6 ldap"
DEPEND=">=sys-libs/pam-0.75
ssl? ( >=dev-libs/openssl-0.9.6a )"
@@ -19,7 +19,6 @@ src_compile() {
--enable-dict --enable-telnet --enable-nonblocking"
use ipv6 && myconf="${myconf} --enable-ipv6"
use ldap && myconf="${myconf} --enable-ldap"
- use pic && myconf="${myconf} --with-pic"
use ssl && myconf="${myconf} --with-ssl"
econf ${myconf}