summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-28 15:40:26 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-28 15:40:26 +0000
commit46461a0a75697614032496eee407a2c77da6bea3 (patch)
tree22a996c023d845e4f09f30c53c7fa97e45ce0ab9 /net-ftp/ftp
parentarm/s390/sh stable (diff)
downloadgentoo-2-46461a0a75697614032496eee407a2c77da6bea3.tar.gz
gentoo-2-46461a0a75697614032496eee407a2c77da6bea3.tar.bz2
gentoo-2-46461a0a75697614032496eee407a2c77da6bea3.zip
Fix from Fedora for building with glibc-2.8 #226513 by Peter.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'net-ftp/ftp')
-rw-r--r--net-ftp/ftp/ChangeLog6
-rw-r--r--net-ftp/ftp/files/netkit-ftp-0.17-arg_max.patch55
-rw-r--r--net-ftp/ftp/ftp-0.17-r7.ebuild3
3 files changed, 62 insertions, 2 deletions
diff --git a/net-ftp/ftp/ChangeLog b/net-ftp/ftp/ChangeLog
index 6854504e58dd..13e8ae70bdaa 100644
--- a/net-ftp/ftp/ChangeLog
+++ b/net-ftp/ftp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/ftp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ChangeLog,v 1.31 2008/06/16 03:49:27 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ChangeLog,v 1.32 2008/06/28 15:40:25 vapier Exp $
+
+ 28 Jun 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/netkit-ftp-0.17-arg_max.patch, ftp-0.17-r7.ebuild:
+ Fix from Fedora for building with glibc-2.8 #226513 by Peter.
16 Jun 2008; Joseph Jezak <josejx@gentoo.org> ftp-0.17-r7.ebuild:
Marked ppc/ppc64 stable.
diff --git a/net-ftp/ftp/files/netkit-ftp-0.17-arg_max.patch b/net-ftp/ftp/files/netkit-ftp-0.17-arg_max.patch
new file mode 100644
index 000000000000..08a88bb54b41
--- /dev/null
+++ b/net-ftp/ftp/files/netkit-ftp-0.17-arg_max.patch
@@ -0,0 +1,55 @@
+diff -up netkit-ftp-0.17/ftp/glob.c.arg_max netkit-ftp-0.17/ftp/glob.c
+--- netkit-ftp-0.17/ftp/glob.c.arg_max 2008-04-07 11:41:14.000000000 +0200
++++ netkit-ftp-0.17/ftp/glob.c 2008-04-07 12:01:53.000000000 +0200
+@@ -50,6 +50,7 @@ char glob_rcsid[] =
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+
+ #include "ftp_var.h" /* for protos only */
+ #include "glob.h"
+@@ -57,7 +58,7 @@ char glob_rcsid[] =
+ #define QUOTE 0200
+ #define TRIM 0177
+ #define eq(a,b) (strcmp(a, b)==0)
+-#define GAVSIZ (ARG_MAX/6)
++#define GAVSIZ (sysconf(_SC_ARG_MAX)/6)
+ #define isdir(d) ((d.st_mode & S_IFMT) == S_IFDIR)
+
+ const char *globerr;
+@@ -115,7 +116,7 @@ char **
+ ftpglob(const char *v)
+ {
+ char agpath[BUFSIZ];
+- entry agargv[GAVSIZ];
++ entry *agargv;
+ centry vv[2];
+ vv[0].text = v;
+ vv[1].text = NULL;
+@@ -133,6 +134,8 @@ ftpglob(const char *v)
+ /* added ()'s to sizeof, (ambigious math for the compiler) */
+ lastgpathp = agpath + (sizeof(agpath)- 2);
+
++ agargv = (entry *)malloc(sizeof (entry) * GAVSIZ);
++ if (agargv == NULL) fatal("Out of memory");
+ ginit(agargv);
+ globcnt = 0;
+ collect(v);
+@@ -156,7 +159,7 @@ ginit(entry *agargv)
+ gargv = agargv;
+ sortbas = agargv;
+ gargc = 0;
+- gnleft = ARG_MAX - 4;
++ gnleft = sysconf(_SC_ARG_MAX) - 4;
+ }
+
+ static
+@@ -674,6 +677,7 @@ efree(entry *av)
+ {
+ int i;
+ for (i=0; av[i].text; i++) free(av[i].text);
++ free((void *)av);
+ }
+
+ static
diff --git a/net-ftp/ftp/ftp-0.17-r7.ebuild b/net-ftp/ftp/ftp-0.17-r7.ebuild
index 508df1f14291..74f05c351bbb 100644
--- a/net-ftp/ftp/ftp-0.17-r7.ebuild
+++ b/net-ftp/ftp/ftp-0.17-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r7.ebuild,v 1.4 2008/06/28 15:39:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r7.ebuild,v 1.5 2008/06/28 15:40:25 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -33,6 +33,7 @@ src_unpack() {
epatch "${FILESDIR}"/${MY_P}-segv.patch #fedora
epatch "${FILESDIR}"/${MY_P}-custom-cflags.patch
epatch "${FILESDIR}"/${MY_P}-sigseg.patch #fedora, #199206
+ epatch "${FILESDIR}"/${MY_P}-arg_max.patch #fedora, #226513
append-lfs-flags #101038
}