summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2005-10-14 23:05:57 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2005-10-14 23:05:57 +0000
commit021cfd2c05588d0343189455ec1389f9b4c70f1e (patch)
treea4f9d112121386b7eb8dcb6d2a93264a81f3c4eb /net-ftp/gftp/gftp-2.0.18-r2.ebuild
parentStable on x86; bug #108538 (diff)
downloadgentoo-2-021cfd2c05588d0343189455ec1389f9b4c70f1e.tar.gz
gentoo-2-021cfd2c05588d0343189455ec1389f9b4c70f1e.tar.bz2
gentoo-2-021cfd2c05588d0343189455ec1389f9b4c70f1e.zip
get rid of gtk2 useflag, clean up old ebuilds, fixes #108555
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-ftp/gftp/gftp-2.0.18-r2.ebuild')
-rw-r--r--net-ftp/gftp/gftp-2.0.18-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-ftp/gftp/gftp-2.0.18-r2.ebuild b/net-ftp/gftp/gftp-2.0.18-r2.ebuild
new file mode 100644
index 000000000000..5bed3b0991e9
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.0.18-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/gftp-2.0.18-r2.ebuild,v 1.1 2005/10/14 23:05:57 allanonjl Exp $
+
+inherit eutils
+
+DESCRIPTION="Gnome based FTP Client"
+SRC_URI="http://www.gftp.org/${P}.tar.bz2"
+HOMEPAGE="http://www.gftp.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls gtk ssl"
+
+DEPEND="virtual/x11
+ ssl? ( dev-libs/openssl )
+ gtk? ( >=x11-libs/gtk+-2 )
+ !gtk? ( sys-libs/readline
+ sys-libs/ncurses
+ =dev-libs/glib-1.2* )"
+
+#RDEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+
+ local myconf
+
+ # do not use enable-{gtk20,gtkport} they are not recognized
+ # and will disable building the gtkport alltogether
+ if ! use gtk; then
+ einfo "gtk+ disabled"
+ myconf="${myconf} --disable-gtkport --disable-gtk20"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable ssl) \
+ ${myconf} \
+ || die
+
+ emake || die
+
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING ChangeLog README* THANKS \
+ TODO docs/USERS-GUIDE
+
+}