summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStewart Honsberger <blkdeath@gentoo.org>2004-03-04 08:42:16 +0000
committerStewart Honsberger <blkdeath@gentoo.org>2004-03-04 08:42:16 +0000
commitbea3de27f97c65ac7c67742a18efa55455f7a509 (patch)
treec60af12b0110ee9e8a4bff9622c6d2ae7bb90764 /net-ftp/proftpd/proftpd-1.2.9_rc1.ebuild
parentinitial ebuild (diff)
downloadgentoo-2-bea3de27f97c65ac7c67742a18efa55455f7a509.tar.gz
gentoo-2-bea3de27f97c65ac7c67742a18efa55455f7a509.tar.bz2
gentoo-2-bea3de27f97c65ac7c67742a18efa55455f7a509.zip
Removed outdated versions + release candidates
Diffstat (limited to 'net-ftp/proftpd/proftpd-1.2.9_rc1.ebuild')
-rw-r--r--net-ftp/proftpd/proftpd-1.2.9_rc1.ebuild119
1 files changed, 0 insertions, 119 deletions
diff --git a/net-ftp/proftpd/proftpd-1.2.9_rc1.ebuild b/net-ftp/proftpd/proftpd-1.2.9_rc1.ebuild
deleted file mode 100644
index 818624093cb5..000000000000
--- a/net-ftp/proftpd/proftpd-1.2.9_rc1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.9_rc1.ebuild,v 1.7 2004/01/24 04:38:49 raker Exp $
-
-IUSE="ldap pam postgres mysql ssl tcpd"
-
-MY_P=${P/_/}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="An advanced and very configurable FTP server"
-SRC_URI="ftp://ftp.proftpd.org/distrib/source/${MY_P}.tar.bz2"
-HOMEPAGE="http://www.proftpd.org/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc hppa alpha ppc"
-
-DEPEND="net-libs/libpcap
- pam? ( >=sys-libs/pam-0.75 )
- mysql? ( >=dev-db/mysql-3.23.26 )
- ldap? ( >=net-nds/openldap-1.2.11 )
- postgres? ( >=dev-db/postgresql-7.3 )
- ssl? ( >=dev-libs/openssl-0.9.6f )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6-r3 )"
-
-src_unpack() {
- unpack ${MY_P}.tar.bz2
- cd ${S}
-}
-
-
-src_compile() {
- local modules myconf
-
- modules="mod_ratio:mod_readme"
- use pam && modules="${modules}:mod_auth_pam"
- use tcpd && modules="${modules}:mod_wrap"
-
- if use ldap; then
- einfo ldap
- modules="${modules}:mod_ldap"
- export LDFLAGS="-lresolv"
- fi
-
- if use ssl; then
- einfo ssl
-
- # enable mod_tls
- modules="${modules}:mod_tls"
- fi
-
- if use mysql; then
- modules="${modules}:mod_sql:mod_sql_mysql"
- myconf="--with-includes=/usr/include/mysql"
- elif use postgres; then
- modules="${modules}:mod_sql:mod_sql_postgres"
- myconf="--with-includes=/usr/include/postgresql"
- fi
-
- # New modules for 1.2.9
- # Not sure how these should be enabled yet as no use variables
- # apply currently. Uncomment if you want to use them though.
- # -raker 06/16/2003
- #
- # modules="${modules}:mod_ifsession"
- # modules="${modules}:mod_radius"
- # modules="${modules}:mod_rewrite"
-
- econf \
- --sbindir=/usr/sbin \
- --localstatedir=/var/run \
- --sysconfdir=/etc/proftpd \
- --enable-shadow \
- --disable-sendfile \
- --enable-autoshadow \
- --with-modules=${modules} \
- ${myconf} || die "bad ./configure"
-
- make || die "compile problem"
-}
-
-src_install() {
- # Note rundir needs to be specified to avoid sandbox violation
- # on initial install. See Make.rules
- make DESTDIR=${D} install || die
-
- keepdir /home/ftp
- keepdir /var/run/proftpd
-
- dodoc contrib/README.mod_sql ${FILESDIR}/proftpd.conf \
- COPYING CREDITS ChangeLog NEWS README* \
- doc/{license.txt,GetConf}
- dohtml doc/*.html
- docinto rfc
- dodoc doc/rfc/*.txt
-
- mv ${D}/etc/proftpd/proftpd.conf ${D}/etc/proftpd/proftpd.conf.distrib
-
- insinto /etc/proftpd
- newins ${FILESDIR}/proftpd.conf proftpd.conf.sample
-
- if use pam; then
- insinto /etc/pam.d
- newins ${S}/contrib/dist/rpm/ftp.pamd ftp
- fi
-
- insinto /etc/xinetd.d
- newins ${FILESDIR}/proftpd.xinetd proftpd
-
- exeinto /etc/init.d ; newexe ${FILESDIR}/proftpd.rc6 proftpd
-}
-
-pkg_postinst() {
- groupadd proftpd &>/dev/null
- id proftpd &>/dev/null || \
- useradd -g proftpd -d /home/ftp -s /bin/false proftpd
- einfo
- einfo 'You can find the config files in /etc/proftpd'
- einfo
-}