summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-21 11:25:00 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-21 11:25:00 +0000
commit11838984d1a908a062b3d63ca09f121df68288e9 (patch)
tree2d1aca1cff8bb150854a8b29494bcdd794bab02f /net-ftp
parentAdd dev-python/yapsy, bug 421833. Thanks to Pinkbyte (diff)
downloadgentoo-2-11838984d1a908a062b3d63ca09f121df68288e9.tar.gz
gentoo-2-11838984d1a908a062b3d63ca09f121df68288e9.tar.bz2
gentoo-2-11838984d1a908a062b3d63ca09f121df68288e9.zip
net-ftp/pureadmin: Add fix for gold, #369103
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pureadmin/ChangeLog6
-rw-r--r--net-ftp/pureadmin/files/pureadmin-0.4-gold.patch28
-rw-r--r--net-ftp/pureadmin/metadata.xml8
-rw-r--r--net-ftp/pureadmin/pureadmin-0.4-r1.ebuild33
4 files changed, 56 insertions, 19 deletions
diff --git a/net-ftp/pureadmin/ChangeLog b/net-ftp/pureadmin/ChangeLog
index 4590d13d0841..8ebf2015c762 100644
--- a/net-ftp/pureadmin/ChangeLog
+++ b/net-ftp/pureadmin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/pureadmin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.21 2012/05/03 05:37:18 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.22 2012/06/21 11:25:00 jlec Exp $
+
+ 21 Jun 2012; Justin Lecher <jlec@gentoo.org> pureadmin-0.4-r1.ebuild,
+ +files/pureadmin-0.4-gold.patch, metadata.xml:
+ Add fix for gold, #369103
03 May 2012; Jeff Horelick <jdhore@gentoo.org> pureadmin-0.2.2.ebuild,
pureadmin-0.3.ebuild, pureadmin-0.4-r1.ebuild:
diff --git a/net-ftp/pureadmin/files/pureadmin-0.4-gold.patch b/net-ftp/pureadmin/files/pureadmin-0.4-gold.patch
new file mode 100644
index 000000000000..7b19565ac10a
--- /dev/null
+++ b/net-ftp/pureadmin/files/pureadmin-0.4-gold.patch
@@ -0,0 +1,28 @@
+ src/Makefile.am | 2 +-
+ src/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 94f61e0..0ebb561 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -38,5 +38,5 @@ pureadmin_CFLAGS = -std=gnu99 -Wall
+
+ pureadmin_LDFLAGS = -export-dynamic
+
+-pureadmin_LDADD = @GTK_LIBS@ $(INTLLIBS) @BINRELOC_LIBS@
++pureadmin_LDADD = @GTK_LIBS@ $(INTLLIBS) @BINRELOC_LIBS@ -lm -lX11
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index b2ade45..dd9401c 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -249,7 +249,7 @@ pureadmin_SOURCES = \
+
+ pureadmin_CFLAGS = -std=gnu99 -Wall
+ pureadmin_LDFLAGS = -export-dynamic
+-pureadmin_LDADD = @GTK_LIBS@ $(INTLLIBS) @BINRELOC_LIBS@
++pureadmin_LDADD = @GTK_LIBS@ $(INTLLIBS) @BINRELOC_LIBS@ -lm -lX11
+ all: all-am
+
+ .SUFFIXES:
diff --git a/net-ftp/pureadmin/metadata.xml b/net-ftp/pureadmin/metadata.xml
index faed1db766e6..b82577c71988 100644
--- a/net-ftp/pureadmin/metadata.xml
+++ b/net-ftp/pureadmin/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>maintainer-needed@gentoo.org</email>
-</maintainer>
-<longdescription>Graphical tool used to make the management of PureFTPd a little easier.</longdescription>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Graphical tool used to make the management of PureFTPd a little easier.</longdescription>
</pkgmetadata>
diff --git a/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild b/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild
index c806ac1448a6..11dcda2ce7de 100644
--- a/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild
+++ b/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild,v 1.4 2012/05/03 05:37:18 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild,v 1.5 2012/06/21 11:25:00 jlec Exp $
+
+EAPI=4
-EAPI=3
inherit eutils
-DESCRIPTION="PureAdmin is a GUI tool used to make the management of Pure-FTPd a little easier."
+DESCRIPTION="GUI tool used to make the management of Pure-FTPd a little easier"
HOMEPAGE="http://purify.sourceforge.net/"
SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
@@ -14,17 +15,21 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="debug doc"
-RDEPEND="gnome-base/libglade:2.0
- sys-libs/zlib
- virtual/fam
- x11-libs/gtk+:2"
+RDEPEND="
+ gnome-base/libglade:2.0
+ sys-libs/zlib
+ virtual/fam
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig"
src_prepare() {
- echo src/eggstatusicon.c >> po/POTFILES.skip
- echo src/eggtrayicon.c >> po/POTFILES.skip
- echo src/prereq_usrmanager.c >> po/POTFILES.skip
+ cat >> po/POTFILES.skip <<- EOF
+ src/eggstatusicon.c
+ src/eggtrayicon.c
+ src/prereq_usrmanager.c
+ EOF
+ epatch "${FILESDIR}"/${P}-gold.patch
}
src_configure() {
@@ -36,13 +41,13 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
# Move the docs to the correct location, if we want the docs
if use doc ; then
- dodoc "${D}"usr/share/pureadmin/docs/* || die
+ dodoc "${ED}"usr/share/pureadmin/docs/*
fi
- rm -Rfv "${D}"usr/share/pureadmin/docs || die
+ rm -Rfv "${ED}"usr/share/pureadmin/docs || die
make_desktop_entry pureadmin "Pure-FTPd menu config" pureadmin
}