summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-10-29 07:49:43 +0000
committerNick Hadaway <raker@gentoo.org>2003-10-29 07:49:43 +0000
commit2feb2374179ac9a81d75d9182a552173f6efbe20 (patch)
treefe5ae291f6747f318329772ea33ac99c107f6269 /net-ftp
parentPAM fix plus other minor updates (diff)
downloadgentoo-2-2feb2374179ac9a81d75d9182a552173f6efbe20.tar.gz
gentoo-2-2feb2374179ac9a81d75d9182a552173f6efbe20.tar.bz2
gentoo-2-2feb2374179ac9a81d75d9182a552173f6efbe20.zip
PAM fix plus other minor updates
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pure-ftpd/ChangeLog8
-rw-r--r--net-ftp/pure-ftpd/Manifest4
-rw-r--r--net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.16c1
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.16c.ebuild76
4 files changed, 86 insertions, 3 deletions
diff --git a/net-ftp/pure-ftpd/ChangeLog b/net-ftp/pure-ftpd/ChangeLog
index 32e0079ee1fa..ebd3a5a3f14a 100644
--- a/net-ftp/pure-ftpd/ChangeLog
+++ b/net-ftp/pure-ftpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/pure-ftpd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.19 2003/10/20 10:38:02 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.20 2003/10/29 07:49:37 raker Exp $
+
+*pure-ftpd-1.0.16c (29 Oct 2003)
+
+ 29 Oct 2003; Nick Hadaway <raker@gentoo.org> pure-ftpd-1.0.16c.ebuild:
+ Version bump. A fix for PAM authentication and some other minor
+ changes.
20 Oct 2003; Nick Hadaway <raker@gentoo.org> pure-ftpd-1.0.16b.ebuild:
Marking stable for all arches based on the suggestion of the upstream
diff --git a/net-ftp/pure-ftpd/Manifest b/net-ftp/pure-ftpd/Manifest
index 40c8976cff32..f88be65d5e75 100644
--- a/net-ftp/pure-ftpd/Manifest
+++ b/net-ftp/pure-ftpd/Manifest
@@ -1,6 +1,6 @@
MD5 98c99ce293bb00af0555701bd6b12ab6 pure-ftpd-1.0.16b.ebuild 2231
-MD5 98c99ce293bb00af0555701bd6b12ab6 pure-ftpd-1.0.16c.ebuild 2231
-MD5 c4777243baf53edcad3f31f66b01dc9e ChangeLog 3081
+MD5 2f562e95d7e61d1a0764826a5ccb5c68 pure-ftpd-1.0.16c.ebuild 2236
+MD5 57c6f3938d511abb58fd141d513b722a ChangeLog 3268
MD5 12158b386c76f1fa317b9b474abfb30e metadata.xml 249
MD5 0e2de54a63d8f1c4a44d15f95e38b044 files/digest-pure-ftpd-1.0.16b 70
MD5 f1a1d4817df4539dc199812979aac307 files/digest-pure-ftpd-1.0.16c 70
diff --git a/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.16c b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.16c
new file mode 100644
index 000000000000..774cefd6101d
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.16c
@@ -0,0 +1 @@
+MD5 422ef27622882ffa773616ffaa20e06c pure-ftpd-1.0.16c.tar.bz2 440205
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.16c.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.16c.ebuild
new file mode 100644
index 000000000000..d6fac5c106a6
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-1.0.16c.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/pure-ftpd-1.0.16c.ebuild,v 1.1 2003/10/29 07:49:37 raker Exp $
+
+IUSE="pam mysql postgres ldap ssl"
+
+DESCRIPTION="Pure-FTPd is a fast, production-quality, standard-conformant FTP server"
+SRC_URI="ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/${P}.tar.bz2"
+HOMEPAGE="http://www.pureftpd.org/"
+
+SLOT="0"
+LICENSE="BSD" # Changed from GPL-2 to BSD 06/09/2003
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3* )
+ postgres? ( >=dev-db/postgresql-7.2.2 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+
+src_compile() {
+ local myconf=""
+
+ use pam && myconf="${myconf} --with-pam"
+ use ldap && myconf="${myconf} --with-ldap"
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+ use ssl && myconf="${myconf} --with-tls"
+
+ econf \
+ --with-altlog --with-extauth \
+ --with-puredb --with-cookie \
+ --with-throttling --with-ratios \
+ --with-quotas --with-ftpwho \
+ --with-uploadscript --with-virtualhosts \
+ --with-virtualchroot --with-diraliases \
+ --with-peruserlimits ${myconf}
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall
+
+ dodoc AUTHORS CONTACT COPYING ChangeLog FAQ HISTORY INSTALL README* NEWS
+
+ dodir /etc/{conf.d,init.d}
+ cp ${FILESDIR}/ftpusers ${D}/etc/ftpusers
+ cp ${FILESDIR}/pure-ftpd.conf_d ${D}/etc/conf.d/pure-ftpd
+
+ use pam && insinto /etc/pam.d && doins pam/pure-ftpd
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pure-ftpd.rc6-r1 pure-ftpd
+
+ insopts -m 644
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/pure-ftpd.xinetd pure-ftpd
+
+ if [ `use ldap` ]; then
+ dodir /etc/openldap/schema
+ insinto /etc/openldap/schema
+ doins pureftpd.schema
+ insinto /etc/openldap
+ doins pureftpd-ldap.conf
+ fi
+}
+
+pkg_postinst() {
+ einfo "Before starting Pure-FTPd, you have to edit the /etc/conf.d/pure-ftpd file."
+ echo
+ ewarn "It's *really* important to read the README provided with Pure-FTPd."
+ ewarn "Check out - http://www.pureftpd.org/README"
+ ewarn "And for SSL/TLS help - http://www.pureftpd.org/README.TLS"
+}