summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-05-30 04:50:23 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-05-30 04:50:23 +0000
commit7c7d90f62b58874a4b0fcdc969ae6e454d7a1969 (patch)
treea6a9e14a84afbe4e9cd75fa1f3554bb7364cfb3d /net-ftp
parentFixed the patches for 28.0 so they work correctly. (diff)
downloadgentoo-2-7c7d90f62b58874a4b0fcdc969ae6e454d7a1969.tar.gz
gentoo-2-7c7d90f62b58874a4b0fcdc969ae6e454d7a1969.tar.bz2
gentoo-2-7c7d90f62b58874a4b0fcdc969ae6e454d7a1969.zip
fixed compilation with USE=kerberos. Thanks to Kevin Fullerton & Fredrik Eriksson for the changes and Gautam Iyer for reporting. Closes bug #201741
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/yafc/ChangeLog8
-rw-r--r--net-ftp/yafc/yafc-1.1.1-r1.ebuild23
2 files changed, 25 insertions, 6 deletions
diff --git a/net-ftp/yafc/ChangeLog b/net-ftp/yafc/ChangeLog
index 3ea1651beb1e..53bfb2fffffe 100644
--- a/net-ftp/yafc/ChangeLog
+++ b/net-ftp/yafc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/yafc
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.35 2007/11/12 14:10:56 armin76 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.36 2008/05/30 04:50:23 darkside Exp $
+
+ 30 May 2008; Jeremy Olexa <darkside@gentoo.org> yafc-1.1.1-r1.ebuild:
+ fixed compilation with USE=kerberos. Thanks to Kevin Fullerton & Fredrik
+ Eriksson for the changes and Gautam Iyer for reporting. Closes bug #201741
12 Nov 2007; Raúl Porcel <armin76@gentoo.org> -yafc-1.1.ebuild:
old
diff --git a/net-ftp/yafc/yafc-1.1.1-r1.ebuild b/net-ftp/yafc/yafc-1.1.1-r1.ebuild
index f1e6f3e1f3f4..1b6cfa0d44d8 100644
--- a/net-ftp/yafc/yafc-1.1.1-r1.ebuild
+++ b/net-ftp/yafc/yafc-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1-r1.ebuild,v 1.7 2007/09/23 22:23:00 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1-r1.ebuild,v 1.8 2008/05/30 04:50:23 darkside Exp $
inherit autotools eutils
@@ -31,8 +31,23 @@ src_unpack() {
src_compile() {
local myconf=""
- use kerberos && myconf="${myconf} --with-krb5=/usr/ --with-gssapi=/usr" \
- || myconf="${myconf} --with-krb5=no --with-gssapi=no"
+ if use kerberos ; then
+ if has_version app-crypt/heimdal ; then
+ myconf="${myconf} --with-krb5=/usr/ --with-krb4=no --with-gssapi=/usr"
+ elif has_version app-crypt/mit-krb5 ; then
+ if built_with_use app-crypt/mit-krb5 krb4 ; then
+ myconf="${myconf} --with-krb5=/usr/ --with-krb4=/usr/ --with-gssapi=/usr"
+ else
+ myconf="${myconf} --with-krb5=/usr/ --with-krb4=no --with-gssapi=/usr"
+ fi
+ else
+ die "No supported kerberos provider detected"
+ fi
+ else
+ myconf="${myconf} --without-krb4 --without-krb5"
+ fi
+# use kerberos && myconf="${myconf} --with-krb5=/usr/ --with-gssapi=/usr" \
+# || myconf="${myconf} --with-krb5=no --with-krb4=no --with-gssapi=no"
use socks5 && myconf="${myconf} --with-socks5=/usr" \
|| myconf="${myconf} --with-socks5=no"
use readline && myconf="${myconf} --with-readline=/usr" \