summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-02-21 16:56:31 +0000
committerKevin McCarthy <signals@gentoo.org>2011-02-21 16:56:31 +0000
commitb88ee2fc78050b28599b34296cc96c1d2266837a (patch)
tree8844f9a12e9a4813a27f36473b0ac3fcd4771d83 /net-im/ayttm
parentAdd ~x86-fbsd based on Dmitri Bogomolov's report in bug 341123. Remove old ve... (diff)
downloadgentoo-2-b88ee2fc78050b28599b34296cc96c1d2266837a.tar.gz
gentoo-2-b88ee2fc78050b28599b34296cc96c1d2266837a.tar.bz2
gentoo-2-b88ee2fc78050b28599b34296cc96c1d2266837a.zip
New ebuild: ayttm IM client
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'net-im/ayttm')
-rw-r--r--net-im/ayttm/ChangeLog11
-rw-r--r--net-im/ayttm/ayttm-0.6.3.ebuild68
-rw-r--r--net-im/ayttm/files/ayttm-0.6.3-opt-webcam.patch28
-rw-r--r--net-im/ayttm/files/ayttm-0.6.3-opt-xscreensaver.patch16
-rw-r--r--net-im/ayttm/metadata.xml21
5 files changed, 144 insertions, 0 deletions
diff --git a/net-im/ayttm/ChangeLog b/net-im/ayttm/ChangeLog
new file mode 100644
index 000000000000..5ffc6003e5f9
--- /dev/null
+++ b/net-im/ayttm/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-im/ayttm
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ayttm/ChangeLog,v 1.17 2011/02/21 16:56:31 signals Exp $
+
+*ayttm-0.6.3 (21 Feb 2011)
+
+ 21 Feb 2011; Kevin McCarthy <signals@gentoo.org> +ayttm-0.6.3.ebuild,
+ +files/ayttm-0.6.3-opt-webcam.patch,
+ +files/ayttm-0.6.3-opt-xscreensaver.patch, +metadata.xml:
+ New ebuild for ayttm. Ebuild written by me. See bug #354085
+
diff --git a/net-im/ayttm/ayttm-0.6.3.ebuild b/net-im/ayttm/ayttm-0.6.3.ebuild
new file mode 100644
index 000000000000..e6c941bfdea2
--- /dev/null
+++ b/net-im/ayttm/ayttm-0.6.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ayttm/ayttm-0.6.3.ebuild,v 1.1 2011/02/21 16:56:31 signals Exp $
+
+EAPI=4
+inherit autotools eutils multilib
+
+DESCRIPTION="A multi-protocol instant messaging client"
+HOMEPAGE="http://ayttm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ayttm/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="crypt esd icq irc jabber lj msn nls oscar smtp webcam xscreensaver yahoo"
+
+CDEPEND="app-text/enchant
+ dev-libs/glib:2
+ dev-libs/openssl
+ virtual/libiconv
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/pango
+ crypt? ( app-crypt/gpgme )
+ esd? ( media-sound/esound )
+ webcam? ( media-libs/jasper )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ yahoo? ( net-libs/libyahoo2 )"
+RDEPEND="${CDEPEND}
+ webcam? ( media-tv/xawtv )"
+DEPEND="${CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-opt-xscreensaver.patch \
+ "${FILESDIR}"/${P}-opt-webcam.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable crypt aycryption) \
+ $(use_enable esd) \
+ $(use_enable icq) \
+ $(use_enable irc) \
+ $(use_enable jabber) \
+ $(use_enable lj) \
+ $(use_enable msn) \
+ $(use_enable nls) \
+ $(use_enable oscar) \
+ $(use_enable smtp) \
+ $(use_enable webcam) \
+ $(use_enable xscreensaver) \
+ $(use_enable yahoo) \
+ --disable-arts \
+ --enable-posix-dlopen \
+ --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README README.LINUX TODO
+ rm -f "${D}"/usr/$(get_libdir)/${PN}/*.la
+}
diff --git a/net-im/ayttm/files/ayttm-0.6.3-opt-webcam.patch b/net-im/ayttm/files/ayttm-0.6.3-opt-webcam.patch
new file mode 100644
index 000000000000..e805d90746d6
--- /dev/null
+++ b/net-im/ayttm/files/ayttm-0.6.3-opt-webcam.patch
@@ -0,0 +1,28 @@
+Make the building of the webcam-related plugins optional.
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- configure.ac
++++ configure.ac
+@@ -436,6 +439,10 @@
+ AC_MSG_WARN(You need gpgme to compile the aycryption module))
+ fi
+
++if test "$enable_webcam" != no; then
++ OPTIONAL_PLUG_DIR="$OPTIONAL_PLUG_DIR image_filter"
++fi
++
+ ###########################################################################
+ # End Optional Modules
+ ###########################################################################
+--- modules/Makefile.am
++++ modules/Makefile.am
+@@ -1,7 +1,7 @@
+ DIST_SUBDIRS = aim-oscar irc jabber msn2 yahoo2 smtp importers \
+ livejournal utility aycryption smileys image_filter
+
+-SUBDIRS = @OPTIONAL_PLUG_DIR@ importers utility smileys image_filter
++SUBDIRS = @OPTIONAL_PLUG_DIR@ importers utility smileys
+
+ # Gets rid of the datarootdir warning
+ datarootdir=@datarootdir@
diff --git a/net-im/ayttm/files/ayttm-0.6.3-opt-xscreensaver.patch b/net-im/ayttm/files/ayttm-0.6.3-opt-xscreensaver.patch
new file mode 100644
index 000000000000..7c6f09f5117e
--- /dev/null
+++ b/net-im/ayttm/files/ayttm-0.6.3-opt-xscreensaver.patch
@@ -0,0 +1,16 @@
+Add --enable-xscreensaver to configure for USE flag support
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- configure.ac
++++ configure.ac
+@@ -316,6 +316,9 @@
+ #endif
+ ])
+
++AC_ARG_ENABLE(xscreensaver, AC_HELP_STRING([--enable-xscreensaver],
++ [compile with X Screensaver]), [have_xss=$enableval], [have_xss=no] )
++
+ if test "$have_xss" = yes; then
+ # Let's figure out what library it's in...
+
diff --git a/net-im/ayttm/metadata.xml b/net-im/ayttm/metadata.xml
new file mode 100644
index 000000000000..97ea6d692fa4
--- /dev/null
+++ b/net-im/ayttm/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>signals@gentoo.org</email>
+ <name>Kevin McCarthy</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ayttm is a multi-protocol instant messaging client with some novel features
+ such as the ability to connect to livejournal.com and the ability to send
+ short messages via RFC2821 SMTP.
+ </longdescription>
+ <use>
+ <flag name="irc">Enable Internet Relay Chat support</flag>
+ <flag name="lj">Enable livejournal.com support</flag>
+ <flag name="smtp">Adds support for sending messages via RFC2821 SMTP</flag>
+ <flag name="webcam">Adds webcam support for Yahoo Messenger</flag>
+ </use>
+</pkgmetadata>
+