summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-07-27 14:50:27 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-07-27 14:50:27 +0000
commitbb418837ff6700b9b41564a8c24ad10e8aed43ed (patch)
tree7cb6c8c943dcf39fdd4bd6c00b26e7cb0ff6c10f /net-im/centericq
parentadded KEYWORDS and SLOT for QA happiness (diff)
downloadgentoo-2-bb418837ff6700b9b41564a8c24ad10e8aed43ed.tar.gz
gentoo-2-bb418837ff6700b9b41564a8c24ad10e8aed43ed.tar.bz2
gentoo-2-bb418837ff6700b9b41564a8c24ad10e8aed43ed.zip
I suck. Ebuild.disjointed and I somehow didn't notice it.
Diffstat (limited to 'net-im/centericq')
-rw-r--r--net-im/centericq/centericq-4.7.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-im/centericq/centericq-4.7.8.ebuild b/net-im/centericq/centericq-4.7.8.ebuild
new file mode 100644
index 000000000000..a4621a07bee8
--- /dev/null
+++ b/net-im/centericq/centericq-4.7.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/centericq-4.7.8.ebuild,v 1.1 2002/07/27 14:50:27 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A ncurses ICQ/Yahoo!/MSN Client"
+SRC_URI="http://konst.org.ua/download/${P}.tar.gz"
+HOMEPAGE="http://konst.org.ua/eng/software/centericq/info.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ =dev-libs/libsigc++-1.0*"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myopts=""
+
+ use nls || myopts="--disable-nls"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --with-included-gettext \
+ ${myopts} || die "Configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING FAQ README THANKS TODO
+}