summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-10-28 11:25:40 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-10-28 11:25:40 +0000
commit7e9be0697a4c5da3e99f8e74166a3e4b2645070d (patch)
treedbd232ad22a7560beb6dbe4f67b328a3ab287884 /net-im/climm/climm-0.6.1-r1.ebuild
parentraise gnome-bluetooth dependency (diff)
downloadgentoo-2-7e9be0697a4c5da3e99f8e74166a3e4b2645070d.tar.gz
gentoo-2-7e9be0697a4c5da3e99f8e74166a3e4b2645070d.tar.bz2
gentoo-2-7e9be0697a4c5da3e99f8e74166a3e4b2645070d.zip
Add a dep to otr 3.0 for bug #195862 and add a check for ssl/gloox useflags to fix jabber connection issues reported by armin76 on IRC
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-im/climm/climm-0.6.1-r1.ebuild')
-rw-r--r--net-im/climm/climm-0.6.1-r1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-im/climm/climm-0.6.1-r1.ebuild b/net-im/climm/climm-0.6.1-r1.ebuild
index 35b54042da7b..2aef15826474 100644
--- a/net-im/climm/climm-0.6.1-r1.ebuild
+++ b/net-im/climm/climm-0.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/climm/climm-0.6.1-r1.ebuild,v 1.1 2007/10/22 21:51:36 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/climm/climm-0.6.1-r1.ebuild,v 1.2 2007/10/28 11:25:40 jokey Exp $
DESCRIPTION="ICQ text-mode client with many features"
HOMEPAGE="http://www.climm.org/"
@@ -13,7 +13,16 @@ IUSE="gloox otr tcl ssl"
DEPEND="gloox? ( net-libs/gloox )
ssl? ( >=net-libs/gnutls-0.8.10 dev-libs/openssl )
- tcl? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )
+ otr? ( >=net-libs/libotr-3.0.0 )"
+
+pkg_setup() {
+ if use gloox && ! use ssl ; then
+ eerror "You need to set the ssl flag when you want to use the gloox"
+ eerror "Jabber library"
+ die "Set ssl or unset gloox for ${PN}"
+ fi
+}
src_compile() {
econf \